D-Link DWL-G520 connection to a linksys router



  • Hi guys…

    I'm having an ongoing nightmare with this config going on for weeks now.

    The setup:

    next to the WAN and LAN there is an OPT1 (D-link) interface connected to a wireless router (linksys). Router has internet access, so I'm trying to use it as a second WAN for my multiwan config.
    I'm using wpa2 security setup.

    On the interface page i am getting ENORMOUS amount of errors (like every 3 packets in there is an error, and every 100 packets out the same, roughly)
    Periodic disconnects...
    Can't ping gateway address although the status page reads "associated".
    (Load balancer status page says offline even when I ping the control address normaly)
    Sometimes I can ping the gateway from my LAN, sometimes I can't (Same goes for the pfsense box itself)

    I am crazy already...
    dunno what to do. It's not a signal strength issue I think (powerful antena, and windows boxex in the same spot give max signal power)

    If you need extra info please tell me what and I'll paste it...

    ttnx



  • I've been less than impressed with the wireless stuff in freebsd :(  If you STF you will find the various issues I had.  I finally gave up and went back to a separate AP.  What I would recommend: pull the WLAN card and replace with another enet card, connected only to the AP you have.  Make that OPT1 enet card the other gateway and go from there.



  • It might help other readers to know what version of pfSense you are using and what driver attaches to your WLAN card (e.g. ath, ral, etc).

    danswartz has reported problems with ath in pfSense 1.2.3 while I have had satisfactory experience with ath in 1.2.3



  • Sorry…

    Using pfsense 1.2.3

    athstats

    352      data frames received
    332      data frames transmit
    3        tx frames with an alternate rate
    12       long on-chip tx retries
    128      mib overflow interrupts
    48M      current transmit rate
    212      tx management frames
    661      tx frames discarded prior to association
    2        tx encapsulation failed
    201      tx frames with no ack marked
    397      tx frames with short preamble
    919      rx failed 'cuz of bad CRC
    235      rx failed 'cuz of PHY err
       235      CCK restart
    52       periodic calibrations
    27       rssi of last ack
    24       avg recv rssi
    -96      rx noise floor
    Antenna profile:
    [1] tx      527 rx    16584

    ifconfig
    re0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
           options=389b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_ucast,wol_mcast,wol_magic>ether 00:22:b0:cf:c7:7f
           inet 192.168.5.1 netmask 0xffffff00 broadcast 192.168.5.255
           inet6 fe80::222:b0ff:fecf:c77f%re0 prefixlen 64 scopeid 0x1
           media: Ethernet autoselect (100baseTX <full-duplex>)
           status: active
    fxp0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
           options=8 <vlan_mtu>ether 00:02:a5:e3:87:ed
           inet6 fe80::202:a5ff:fee3:87ed%fxp0 prefixlen 64 scopeid 0x2
           media: Ethernet autoselect (100baseTX <full-duplex>)
           status: active
    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
           ether 00:22:b0:ea:f8:79
           inet6 fe80::222:b0ff:feea:f879%ath0 prefixlen 64 scopeid 0x3
           inet 192.168.1.101 netmask 0xffffff00 broadcast 192.168.1.255
           media: IEEE 802.11 Wireless Ethernet autoselect mode 11g (OFDM/24Mbps)
           status: associated
           ssid Doma channel 11 (2462 Mhz 11g) bssid xx:xx:xx:xx:xx:xx
           authmode WPA2/802.11i privacy ON deftxkey UNDEF TKIP 4:128-bit
           txpower 31.5 bmiss 7 scanvalid 60 bgscan bgscanintvl 300
           bgscanidle 250 roam:rssi11g 7 roam:rate11g 5 protmode OFF burst
           roaming MANUAL
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
           inet 127.0.0.1 netmask 0xff000000
           inet6 ::1 prefixlen 128
           inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4
    enc0: flags=0<> metric 0 mtu 1536
    pfsync0: flags=41 <up,running>metric 0 mtu 1460
           pfsync: syncdev: lo0 syncpeer: 224.0.0.240 maxupd: 128
    pflog0: flags=100 <promisc>metric 0 mtu 33204
    ng0: flags=88d1 <up,pointopoint,running,noarp,simplex,multicast>metric 0 mtu 1492
           inet xxx.xxx.xxx.xxx –> xxx.xxx.xxx.xxx netmask 0xffffffff
           inet6 fe80::222:b0ff:fecf:c77f%ng0 prefixlen 64 scopeid 0x8
    ng1: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng2: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng3: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng4: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng5: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng6: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng7: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng8: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng9: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng10: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng11: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng12: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng13: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng14: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng15: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500
    ng16: flags=8890 <pointopoint,noarp,simplex,multicast>metric 0 mtu 1500

    read and tried changing antenna settings and diversity... no luck... still errors, still disconnects after some time (10, maybe 15 hours, usualy when there's no trafic)
    tried changing transmission power from 20 all the way to 100, still nothing...

    EDIT: when it's connected I get full bandwidth to the internet (10 mbit). Basically I don't care about the errors. Just the disconnects!
    EDIT2: what danswartz said... When I click the save button on the OPT1 interface page (without making changes) it reconnects and everything starts working again. (On the status page it ALWAYS say associated

    Could it be some kind of powersave mode? no traffic disables wireless? I don't know... still experimenting</pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></pointopoint,noarp,simplex,multicast></up,pointopoint,running,noarp,simplex,multicast></promisc></up,running></up,loopback,running,multicast></up,broadcast,running,simplex,multicast></full-duplex></vlan_mtu></up,broadcast,running,simplex,multicast></full-duplex></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_ucast,wol_mcast,wol_magic></up,broadcast,running,simplex,multicast>



  • that was what was happening to me too - getting disconnected - if even for a few seconds, aborts any apps i was running.



  • tried playing around with in/out buffers and calibration settings…. nothing :(

    at this point I am considering doing a cron scheduled script that simulates clicking on the save button every 5 hours or so...
    any idea how to do that?



  • Resolved with dd-wrt enabled router in bridge client mode.

    Works like a charm now.
    Never looked back



  • Were you getting any "stuck beacon" error messages in your system log?  I've seen that at first with both Atheros-based cards I've tried (5212 and 5416 chipsets).  Changing channels or removing the antennas sometimes would make it stop.  It eventually seemed to go away on its own in both cases after I had already tried changing channels, rebooting, etc., and I was then able to use the channel I wanted without seeing the error.  They may require some kind of calibration period before they work right on the ath driver.

    I've also seen good results from a card I have that is based on the Marvell 88W8363 (mwl driver in FreeBSD), but with no initial issues either, unlike the Atheros cards.  It does require at least FreeBSD 8, however; which means it won't work in pfSense 1.2.3, only 2.0.  The card supports 802.11n, but the mwl driver doesn't seem to support 802.11n rates yet (only up to 54mbps).  Like ath, the mwl driver also supports virtual access points on 2.0 (new in FreeBSD 8 ), but unfortunately the mwl driver is currently missing something that is needed for the additional access points to actually be usable by wireless clients.


Log in to reply