Need help about broken images on captiveportal



  • Hello to all from pfsense  ;)

    Can someone help me  ???

    i use a CF image on a pc from http://shopping.hacom.net/catalog/pub/pfsense/pfSense-1.0-RC2-1gb-ad0.img.gz

    and it seems to work perfetly.

    I switch on captiveportal function with the same file as my old monowall version 1.22

    I saw it didn't work because all file (html and jpg or gif) must be begin by captiveportal- as it's write on this post : http://forum.pfsense.org/index.php/topic,1714.0.html

    Here is the directory listing :

    ls -al /var/etc/

    total 42
    drwxr-xr-x  4 root    wheel    512 Oct  4 20:07 .
    drwxr-xr-x  12 root    wheel    512 Oct  4 20:07 ..
    -rw-r–r--  1 root    wheel    240 Oct  4 22:04 captiveportal-error.html
    -rw-r--r--  1 root    wheel    277 Oct  4 22:04 captiveportal.html
    -rw-------  1 root    wheel  2031 Oct  4 22:04 cert-portal.pem
    -rw-------  1 root    wheel  2060 Oct  4 20:07 cert.pem
    -rw-r--r--  1 root    wheel    106 Oct  4 20:06 hosts
    -rw-r--r--  1 root    wheel      0 Oct  4 20:06 inetd.conf
    -rw-r--r--  1 root    wheel  5510 Oct  4 22:04 lighty-CaptivePortal-SSL.conf
    -rw-r--r--  1 root    wheel  5420 Oct  4 22:04 lighty-CaptivePortal.conf
    -rw-r--r--  1 root    wheel  5387 Oct  4 20:07 lighty-webConfigurator.conf
    drwxr-xr-x  2 root    wheel    512 Oct  4 20:06 mpd-vpn
    drwxr-xr-x  2 nobody  nobody  512 Oct  4 20:06 openvpn_csc
    -rw-r--r--  1 root    wheel    59 Oct  4 20:06 resolv.conf
    -rw-r--r--  1 root    wheel      0 Oct  4 20:06 slbd.conf
    -rw-r--r--  1 root    wheel    610 Oct  4 20:06 syslog.conf

    ls -al /var/db/cpelements/

    total 96
    drwxr-xr-x  2 root  wheel  1024 Oct  4 22:04 .
    drwxr-xr-x  6 root  wheel    512 Oct  4 22:05 ..
    -rw-r--r--  1 root  wheel  20871 Oct  4 22:04 captiveportal-bandeau4.gif
    -rw-r--r--  1 root  wheel  6745 Oct  4 22:04 captiveportal-bandeau4.jpg
    -rw-r--r--  1 root  wheel  7008 Oct  4 22:04 captiveportal-bandeau5.gif
    -rw-r--r--  1 root  wheel  2587 Oct  4 22:04 captiveportal-bandeau5.jpg
    -rw-r--r--  1 root  wheel  10169 Oct  4 22:04 captiveportal-bandeau7.gif
    -rw-r--r--  1 root  wheel  3345 Oct  4 22:04 captiveportal-bandeau7.jpg
    -rw-r--r--  1 root  wheel  1567 Oct  4 22:04 captiveportal-index_1.gif
    -rw-r--r--  1 root  wheel  3799 Oct  4 22:04 captiveportal-index_1.jpg
    -rw-r--r--  1 root  wheel  2647 Oct  4 22:04 captiveportal-index_3.gif
    -rw-r--r--  1 root  wheel  3435 Oct  4 22:04 captiveportal-index_3.jpg
    -rw-r--r--  1 root  wheel  4484 Oct  4 22:04 captiveportal-index_logo.gif
    -rw-r--r--  1 root  wheel  3281 Oct  4 22:04 captiveportal-index_logo.jpg
    -rw-r--r--  1 root  wheel  4320 Oct  4 22:04 captiveportal-index_soucoupe.gif
    -rw-r--r--  1 root  wheel  4600 Oct  4 22:04 captiveportal-index_soucoupe.jpg

    more /var/etc/captiveportal.html

    <title>Wi-Fi Access</title>

    <center>

    |

    | | |   |
    | |
    |

    |   |

    |

    |
    |

    |   |

    Wi-Fi
                    CTTC Network

    |

    |   |   |

    |
    | <
    /td>
                |

    <form method="post" action="$PORTAL_ACTION$">

    Login :

    Password :

    </form>

    |
    |   |
    |   |
    |   |

    |
    | ![](captiveportal-index_te<br />xte.jpg) |

    Si vous souhaitez vous connecter, demander
              à l'accueil un couple login / password

    If you want to use Wi-Fi access, please
              ask a login / password

    |

    </center>

    Firefox 1.5.0.7 or IE 6 doesn't display images !

    Thanks in advance for your help.

    David



  • There were several CP fixes between RC2 and RC3 (not to mention that we resynced against m0n0 CP again). Upgrade to RC3b. RC2 is not supported anymore.



  • Thanks, I'll try to update to RC3 with this file :

    http://pfsense.bol2riz.com/updates/pfSense-Full-Update-1.0-RC3.tgz

    but the tmp dir for update is limited to 20Mo with 20% occuped, also I try to update with this file :

    http://pfsense.bol2riz.com/updates/pfSense-Mini-Embedded-Update-1.0-RC3.tgz.

    At this time, i don't know if the process is correct but system status give me 1.0 RC3 version.

    The bad news is the problem is always present : not image from captiveportal.

    Thanks…



  • You need to reinstall.



  • Hello Sullrich, you told right  ;)

    I reinstall with 1.0 RC3 (livecd) and everything is allright now.  8)

    Thank to all for your help…


Log in to reply