Loadbalancing und Failover



  • Hallo,

    Ich habe eine ADSL Leitung und eine SDSL Leitung.
    Der lokale Gateway der SDSL Leitung arbeitet im bridged Modus, und die pfSense hat an diesem Anschluss einige öffentliche IP's.
    An der ADSL Leitung habe ich einen Router angeschlossen, der die Einwahl übernimmt und NAT auf das interne Subnet macht, das direkt mit dem OPT1 Port der pfSense verbunden ist.

    SDSL Gateway xxx.xxx.xxx.13
    ADSL Gateway 192.168.0.1

    pfSense:
    LAN 192.168.100.1
    WAN xxx.xxx.xxx.17 (und weitere über CARP, doch das ist die Haupt-IP)
    OPT1 192.168.0.2

    Nun habe ich nach Anleitung von pfsense.org drei Pools erstellt.
    Einen für Loadbalance und zwei für Failover.
    Wenn ich nun einen Stecker ziehe wird die Leitung auch im Loadbalancer Status als offline markiert.
    Failover routet dann auch über den noch verfügbaren Gateway, dauert jedoch ca. 20 Sekunden bis pfSense merkt das eine Leitung offline ist, aber das wird normal sein oder?

    Nun ist mein Problem, wenn beide Leitungen verfügbar sind so routet er mich konstant über die OPT1 Leitung.
    Ich habe auf wieistmeineip.de mehrmals auf aktualisieren geklickt, sowie mehrmals hintereinander einen ping und traceroute auf irgendeinen host.

    Er hat mich dann immer über die OPT1 nach draußen geschickt.
    Danach habe ich nochmal den Failover versucht, und dazu den OPT1 gezogen.
    Nun hat er mich über den Wan nach draußen geschickt.
    Nach wiedereinstecken der OPT1 hat er mich trozdem nur über den WAN nach außen geschickt.

    Also nochmal kurz, Failover funktioniert jedoch kein Loadbalancing.
    Kann mir jemand einen Tipp geben, wo ich anfangen könnte nach dem fehler zu suchen?



  • Hallo,

    Hast Du in den LAN-Regeln denn definiert, dass die ausgehenden Verbindungen auch über die Loadbalancing/Failover-Gateways geleitet werden?


Log in to reply