Aportacion a problema con Portal Cautivo en pfsense 1.2.3



  • Bueno compañeros, no se si ya se haya publicado este post, pero aqui va.

    Tengo configurado un servidor con la version de PfSense 1.2.3 con Multi WAN, DHCP, DNS Forwarder, SNMP y NTP Clock Sync, ademas de los packages de Rate y Notes.

    Anteriormente tenia activo el Avahi y el Portal Cautivo Sin Autentificacion y mostrandose solamente a las direcciones MAC que no estuvieran, en la lista, lamentablemente comence a tener problemas de conexion al intentar conectarme a los servidores FTP externos, y pense que era a raiz de la instalacion del Avahi, despues de reinstalar mi Pfsense varias veces, y de eliminar cualquier cabo suelto, me di cuenta que la unica constante en todo este problema era el Portal Cautivo.

    Asi que mi comentario es, el Portal Cautivo instalado en Pfsense 1.2.3 (es en el unico donde lo he probado) bloquea las conexiones al FTP en uno de los puertos, no se si sea en el puerto 21 o en el puerto dinamico de respuesta (Aunque sospecho que si es en este), pero las bloquea.

    Aqui mi aportacion espero y sea de utilidad.



  • el Portal Cautivo instalado en Pfsense 1.2.3 (es en el unico donde lo he probado) bloquea las conexiones al FTP

    ¿Cómo tienes la casilla Disable the userland FTP-Proxy application de la interfase con la que tienes el portal cautivo?

    En consola tienes que ver algo como:

    firewall:~#  ps -aux | grep ftp
    proxy    678  0.0  0.5  3260  1240  ??  Is    9Feb10   0:00.28 /usr/local/sbin/pftpx -c 8021 -g 8021 192.168.AAA.1
    proxy    714  0.0  0.5  3260  1244  ??  Is    9Feb10   0:00.01 /usr/local/sbin/pftpx -c 8024 -g 8021 192.168.BBB.1
    proxy    738  0.0  0.5  3260  1272  ??  Is    9Feb10   0:00.50 /usr/local/sbin/pftpx -c 8025 -g 8021 192.168.101.1
    proxy  63504  0.0  0.5  3260  1264  ??  INs  Sat09PM   0:00.00 /usr/local/sbin/pftpx -c 8026 -g 8021 192.168.CCC.1
    root   40977  0.0  0.5  3364  1160  p0  S+    7:53PM   0:00.01 grep ftp
    

    como comprobación de que el FTP-Proxy Helper funciona en la interfase correspondiente (192.168.AAA.1, 192.168.BBB.1, 192.168.CCC.1 y 192.168.DDD.1, en el ejemplo).

    Saludos,

    Josep Pujadas



  • En la interfaz LAN que es donde tengo el portal cautivo es en la unica donde tengo desmarcada la casilla Disable the userland FTP-Proxy application y en las otras dos interfaces la tengo activa.



  • Prueba a poner una regla en LAN:

    TCP LAN net * 127.0.0.1 * *

    y mejor aún

    TCP LAN net * 127.0.0.1 8021 *

    Es una regla en principio innecesaria, pero en versiones anteriores me había encontrado con que si no la tenías no iban las descargas FTP, a pesar de tener el FTP-Proxy Helper funcionando.



  • De hecho si habia aplicado estas reglas

    Prueba a poner una regla en LAN:

    TCP LAN net * 127.0.0.1 * *

    y mejor aún

    TCP LAN net * 127.0.0.1 8021 *

    pero lamentablemente tampoco habia funcionado de esa manera, de hecho fue lo primero que intente en la instalacion inicial cuando aun tenia el avahi y el portal cautivo activos, procurare en algun momento que no haya mucho uso de mi red el tener esa regla activa con la instalacion actual de mi pfsense, obviamente activando tambien el portal cautivo, a ver que pasa ya les comentare despues.

    Gracias Bellera


Log in to reply