Sit to site vpn and portforwarding



  • Hi i have a site to site vpn which works great!

    mainsite(vpn) has port forwarding just say 192.168.20.x:46001(which is a camera sits on the remote side of the vpn)

    this is the setup

    (me at home)===(internet)==(pfsense router w/ vpn and portf)==(vpn tunnel)==(pfsensevpnrouter)=(192.168.20.x)

    the problem is if i 'm home i can't access that camera over the vpn tunnel  - the pfsensevpnrouter show my outside ipaddress from home and blocks me by the default rule. I would think it would go over the vpn tunnel and not show my outside ip adress.

    i hope this isn't confusing

    any help would be great!!!!!



  • this shows up in the log being blocked- remote end of the vpn
    Mar 12 14:17:48 LAN 192.168.20.XX:46008 173.15.XX.XX:3525 TCP

    the 173 number is my house



  • I assume the site on which the camera is has it's own internet connection?
    The request TO the camera arrive correctly.
    The problem is, that the answer goeas directly to the cameras default gateway and not back over the VPN tunnel.

    What you can do is:

    • Disable automatically generated rules for the VPN.
    • Assign the VPN interface.
    • Enable advanced outbound NAT and create a NAT rule for the VPN interface.
      –> Set as destination the IP of the camera.

    Like this , from the camera seen, the requests originate from the pfSense on the other side of the VPN tunnel
    --> The answer will go back over the VPN.


Log in to reply