RRD quality graphs broken



  • Hi,

    My rrd quality graphs show 100% packet loss….

    I look at the updaterrd.sh and see this:

    root@pfSense.local]/root(4): cat /var/db/rrd/updaterrd.sh | grep ping                                                                                                                 
            out_wan=ping -c 5 -q xx.xx.xx.12001:xx:xx:1b::1                                                                                                                         
    [1.2.3-RELEASE]                                                                                                                                                                        [root@pfSense.local]/root(5): sh /var/db/rrd/updaterrd.sh                                                                                                                             
    ping: cannot resolve xx.xx.xx.12001:xx:xx:1b::1: Unknown host                                                                                                                       
    ^C                                                                                                                                                                                     
    [1.2.3-RELEASE]        .

    I think this is because I have ipv4 and ipv6 (tunnel) on my interfaces.
    It must be an error in the script that generate "updaterrd.sh"



  • if you restart the router or stop rrd and start it again does it fix the problem?  I get that a lot on my pfsense box 1.2.3.  I have never checked those logs though


  • Rebel Alliance Developer Netgate

    looks like somehow it's getting an IPv6 IP in there? Looks weird for sure.


Log in to reply