Wireless - No Internet



  • Using a Belkin F5D7000 v5100 (Atheros), I have setup a wireless access point in pfSense.  Everything worked easy, except I can't get internet.  I did create a firewall rule to allow any traffic on the interface, but something is still blocking my internet access.

    Besides setting up the WAP SSID, security, and adding the firewall rule, is there anything else?  I'd really love to get this working.  Everything else works great…the devs on this really deserve to be commended.



  • Is that 1.0-RELEASE? If not update please.



  • I figured it out.  I was using my ISP nameservers for DNS rather than the pfSense router's IP.  Once I set that, it worked.



  • I'm have a similar problem but please excuse me being a newbie with stand-alone firewalls. I'm trying to set this up to learn more about them and configurations.

    I'm using Charter Communication for cable and cloned my router's MAC and inserted it into pfsense as the WAN interface MAC so that I'm getting an IP lease from the ISP. And I then tured the router into an AP with WEP and made sure to configure firewall rules (allowing all access to/from both interfaces) yet I still cannot get web access. I can connect to different machines on the LAN but cannot use the webGUI to ping a host on the WAN side. Is there something simple I'm missing here? Maybe something Charter-specific?

    I have realized that pfsense is a fabulous firewall and really would like to make this work so I can learn more about it.

    Kudos to all who worked/work on it.



  • If you can't even ping the wan gateway IP from the webgui of the pfsense something is wrong with your wan. Cablemodems sometimes don't like changing things behind them. Unpower it for some time and turn it on again (something about 10-15 minutes). I don't have cable anywhere but have heard from several people with cable modems that this solves issues usually. If you still can't ping your gateway from the pfsense something in front of the pfSense's wan is wrong. Check cables (crossovercable needed?) and ISP.



  • I found that the problem is with DNS from the ISP. I can ping out IPs (one of Google's for example) from the box but looking at the wan interface, it didn't receive a DNS server. So the ISP's DHCP did give it a number and I can ping the gateway, but not any DNS info. The field is blank in pfsense. I have no problem when changing my AP back into router mode. It functions properly…DNS and all.

    Is there something pfsense is doing to block DNS from the ISP?



  • No, try a release/renew at status>interfaces. If that doesn't help manually assign dns servers at system>general.



  • Yes ok. I manually filled in one DNS address (release/renew on wan interface didn't help) and it worked. It also added another DNS address. Any idea why it didn't get a DNS server address from DHCP? As I said, if I change my AP (Belkin SOHO stuff) back to router mode (and I cloned over the MAC from the WAN side of the AP to the WAN side of the pfsense box) then I get everything as normal, except since the MACs are the same, the router will get one IP and one gateway and the pfsense box will get an entirely different gateway/IP. Is this a common occurrence? And is this normal when using a cable connection with pfsense?

    I much appreciate your help.



  • Never heard of issues like that yet. Maybe your ISP is a bit "special".


Log in to reply