Server can't be client?



  • Hi, I'm trying to connect 3 sites like this:

    s1 –> s2 --> s3

    All of them are running pfSense 1.2.3.
    s2 and s3 are configured as openVPN servers.
    s1 is client of s2, works fine.
    s2 is configured as client of s3, doesn't work.

    When the client at s2 tries to start, the log gives "TCP/UDP: Socket bind failed on local address [undef]:1194: Address already in use". If I check the configuration generated at /var/etc/openvpn_client0.conf I can see that regarding the configured server port there's always a "lport 1194" parameter added to the configuration, but there's no way to override that from the GUI

    Edit: As a workaround, adding "lport 1195" as custom option makes the tunnel work, a few more lines on top of the config file, "lport 1194" is still added.



  • Setting the checkbox "Dynamic sourceport" on the client allows the OpenVPN process to use dynamically a different port.



  • @GruensFroeschli:

    Setting the checkbox "Dynamic sourceport" on the client allows the OpenVPN process to use dynamically a different port.

    Taking note…


Log in to reply