Fit-PC2i



  • Has anyone loaded pfSense on the fit-PC2i?
    http://www.fit-pc.com/web/fit-pc2/fit-pc2i-specifications/

    I has an Atom, so it looks like a great (faster) alternative to the ALIX boards for close to the same wattage.



  • Nice find, I like the fact its lower energy costs as well as fanless…well ok the fanless bit really drew me into it since I like to have a very quiet machine if any noise at all...the size is another factor...already looking into preordering ones of the ones with dual interfaces and the HDD...gonna possibly swap out the HDD with SSD type...though I could possibly grab the SSD out of my toshiba and use that and just put the stock drive in it since I rarely need the portable anymore lol!! but nice find!! Looks to defiantly be worth it on this call.



  • Too bad the realtek enet controllers killed it. I wish they would have kept the intel controller as the 1 lan version has.



  • Ugh.  Didn't know that.



  • but the realtek card may work with PF sence, thats what I have on my PFbox now as the WAN port (intagrated NIC) and its working flawless…so it still has a chance...



  • Realtek's modern (Gbit) chips aren't as bad as their early 10/100 ones.  I've got a box with one of their Gbit chips and it has been just fine - no performance or load issues.



  • indeed, wasn't it primarily the Fit-PC2 "original" and the predecessor to that that had that issue?



  • I have one of their first run batches, that have the 4gb of flash built into the machine.  Also, it has a 160gb drive and the two ethernet ports built in.  pfSense installs just fine to this device and works like a charm.  It's handling one of my internet connections at home at works flawlessly.



  • hmmmm…so it still has a good chance of being a decent unit :) cool, still looking into getting one my self to have and play with!



  • So it appears we have our ALIX killer now.  jaime, how much power does it take?  Where did you buy it?



  • @valnar:

    So it appears we have our ALIX killer now.  jaime, how much power does it take?  Where did you buy it?

    lol, I don't have the fit yet, still looking to see where the lowest price is and reading more on it, but I am really considering one, I currently have a small MATX/ITX system that I use since I like to mess around with the innards alot and experiment, but im really thinking of getting one of the Pc2i with Wi-Fi and dual ethernet ports so I can have something for when I am on the go at a hotel (I don't trust unknown networks hehe) and use that as a portable firewall unit.



  • Just order the damn thing direct.  They are taking components and packaging into a nice little case, etc.

    http://www.fit-pc.com/web/purchase/order-fit-pc2i/

    You're not going to find it cheaper because no one else is selling it like this yet.



  • I'm holding off for a bit.  I've written the parent company CompuLab to see if they would be willing to come out with a version that had Intel gigabit ports instead.  There are embedded motherboards with an Atom Z510/Z530 and US15W chipset which do, so it's not that unusual.  They simply chose to use Realtek.  (I imagine for the cost).

    Here is one, although it probably costs a lot more because of the intended audience.
    http://www.rackmountnet.com/intel-atom-z530-16ghz-us15w-35inch-disk-size-dual-gigabit-id398-p-2936.html



  • I know my post is a bit late but I became a member just a few minutes ago.

    To business, I'm using a 1.6MHz pc2i with 1Gb RAM with pfsense 1.2.3 and it works like a charm with the exception that I cant get the wifi up and running. But I do have a feeling that the later will be solved when I find some free time in my agenda.

    I also spoke with the pc2i company and they are about to release a new upgraded box during the summer so if you haven't already got one it could be a quite good idea and give it a few more month.



  • I never got a reply from them but I stopped caring once I saw the Hacom units.  They are small - just not tiny - but they include Intel NIC's.



  • Has anyone had any luck getting the wireless card in the PC2i operational? I've had great luck with these devices as IPSec routers, but if I could use them as wireless access points, it would be excellent.



  • A quick look didn't reveal any hints of what device is used for the WLAN interface.

    Please post the output from the pfSense shell command dmesg so I can see what devices are present and what version of pfSense you are using.



  • The Fit PC2i wireless variant uses a mini-PCIe card slot for the wifi adapter.  According to their forums posts, this is a RT3070; uses the USB connection provided on the connector.
    I do suppose you could swap it out for a 3945ABG if the drivers are not supported for the Ralink.



  • I found some certification certificates on the fit PC site for RT3090.

    p51boy1: You want a card supporting wireless Access Point mode?



  • I would love to use this as an access point. I'm currently using 1.2.3 release. Here is my dmesg log.

    Copyright © 1992-2009 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
            The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 7.2-RELEASE-p5 #0: Sun Dec  6 23:20:31 EST 2009
        sullrich@FreeBSD_7.2_pfSense_1.2.3_snaps.pfsense.org:/usr/obj.pfSense/usr/pfSensesrc/src/sys/pfSense_SMP.7
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Intel(R) Atom(TM) CPU Z530  @ 1.60GHz (1596.00-MHz 686-class CPU)
      Origin = "GenuineIntel"  Id = 0x106c2  Stepping = 2
      Features=0xbfe9fbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>Features2=0x40c3bd<sse3,dtes64,mon,ds_cpl,vmx,est,tm2,ssse3,xtpr,pdcm,<b22>>
      AMD Features=0x100000 <nx>AMD Features2=0x1 <lahf>Logical CPUs per core: 2
    real memory  = 1063976960 (1014 MB)
    avail memory = 1027235840 (979 MB)
    ACPI APIC Table: <ptltd   ="" apic ="">FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
    cpu0 (BSP): APIC ID:  0
    cpu1 (AP/HT): APIC ID:  1
    ioapic0 <version 2.0="">irqs 0-23 on motherboard
    wlan: mac acl policy registered
    kbd1 at kbdmux0
    cryptosoft0: <software crypto="">on motherboard
    padlock0: No ACE support.
    acpi0: <ptltd   ="" xsdt="">on motherboard
    acpi0: [ITHREAD]
    ACPI Error (evxfevnt-0288): Could not enable PowerButton event [20070320]
    ACPI Warning (evxface-0235): Could not enable fixed event 2 [20070320]
    acpi0: Power Button (fixed)
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
    acpi_ec0: <embedded controller:="" gpe="" 0xd="">port 0x62,0x66 on acpi0
    acpi_hpet0: <high precision="" event="" timer="">iomem 0xfed00000-0xfed003ff on acpi0
    Timecounter "HPET" frequency 14318180 Hz quality 900
    acpi_acad0: <ac adapter="">on acpi0
    battery0: <acpi control="" method="" battery="">on acpi0
    battery1: <acpi control="" method="" battery="">on acpi0
    battery2: <acpi control="" method="" battery="">on acpi0
    acpi_button0: <power button="">on acpi0
    pcib0: <acpi host-pci="" bridge="">port 0xcf8-0xcff on acpi0
    pci0: <acpi pci="" bus="">on pcib0
    vgapci0: <vga-compatible display="">port 0x1800-0x1807 mem 0xd8080000-0xd80fffff,0xd0000000-0xd7ffffff,0xd8000000-0xd801ffff irq 16 at device 2.0 on pci0
    pcib1: <acpi pci-pci="" bridge="">irq 17 at device 28.0 on pci0
    pci2: <acpi pci="" bus="">on pcib1
    re0: <realtek 8168="" 8168b="" 8168c="" 8168cp="" 8168d="" 8111b="" 8111c="" 8111cp="" pcie="" gigabit="" ethernet="">port 0x2000-0x20ff mem 0xd8100000-0xd8100fff,0xd8500000-0xd850ffff irq 16 at device 0.0 on pci2
    re0: Using 1 MSI messages
    re0: Chip rev. 0x3c000000
    re0: MAC rev. 0x00400000
    miibus0: <mii bus="">on re0
    rgephy0: <rtl8169s 8110s="" 8211b="" media="" interface="">PHY 1 on miibus0
    rgephy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
    re0: Ethernet address: 00:01:c0:06:38:ee
    re0: [FILTER]
    pcib2: <acpi pci-pci="" bridge="">irq 16 at device 28.1 on pci0
    pci3: <acpi pci="" bus="">on pcib2
    re1: <realtek 8168="" 8168b="" 8168c="" 8168cp="" 8168d="" 8111b="" 8111c="" 8111cp="" pcie="" gigabit="" ethernet="">port 0x3000-0x30ff mem 0xd8200000-0xd8200fff,0xd8600000-0xd860ffff irq 17 at device 0.0 on pci3
    re1: Using 1 MSI messages
    re1: Chip rev. 0x3c000000
    re1: MAC rev. 0x00400000
    miibus1: <mii bus="">on re1
    rgephy1: <rtl8169s 8110s="" 8211b="" media="" interface="">PHY 1 on miibus1
    rgephy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
    re1: Ethernet address: 00:01:c0:06:38:ef
    re1: [FILTER]
    uhci0: <uhci (generic)="" usb="" controller="">port 0x1820-0x183f irq 23 at device 29.0 on pci0
    uhci0: [GIANT-LOCKED]
    uhci0: [ITHREAD]
    usb0: <uhci (generic)="" usb="" controller="">on uhci0
    usb0: USB revision 1.0
    uhub0: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb0
    uhub0: 2 ports with 2 removable, self powered
    uhci1: <uhci (generic)="" usb="" controller="">port 0x1840-0x185f irq 19 at device 29.1 on pci0
    uhci1: [GIANT-LOCKED]
    uhci1: [ITHREAD]
    usb1: <uhci (generic)="" usb="" controller="">on uhci1
    usb1: USB revision 1.0
    uhub1: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb1
    uhub1: 2 ports with 2 removable, self powered
    uhci2: <uhci (generic)="" usb="" controller="">port 0x1860-0x187f irq 18 at device 29.2 on pci0
    uhci2: [GIANT-LOCKED]
    uhci2: [ITHREAD]
    usb2: <uhci (generic)="" usb="" controller="">on uhci2
    usb2: USB revision 1.0
    uhub2: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usb2
    uhub2: 2 ports with 2 removable, self powered
    ehci0: <ehci (generic)="" usb="" 2.0="" controller="">mem 0xd8020000-0xd80203ff irq 21 at device 29.7 on pci0
    ehci0: [GIANT-LOCKED]
    ehci0: [ITHREAD]
    usb3: EHCI version 1.0
    usb3: companion controllers, 2 ports each: usb0 usb1 usb2
    usb3: <ehci (generic)="" usb="" 2.0="" controller="">on ehci0
    usb3: USB revision 2.0
    uhub3: <intel 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr="">on usb3
    uhub3: 8 ports with 8 removable, self powered
    ugen0: <ralink 0="" 2="" 802.11="" n="" wlan,="" class="" 0,="" rev="" 2.00="" 1.01,="" addr="">on uhub3
    isab0: <pci-isa bridge="">at device 31.0 on pci0
    isa0: <isa bus="">on isab0
    atapci0: <intel ata="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x1810-0x181f at device 31.1 on pci0
    ata0: <ata 0="" channel="">on atapci0
    ata0: [ITHREAD]
    ata1: <ata 1="" channel="">on atapci0
    ata1: [ITHREAD]
    acpi_tz0: <thermal zone="">on acpi0
    acpi_tz1: <thermal zone="">on acpi0
    sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    sio0: type 16550A, console
    sio0: [FILTER]
    cpu0: <acpi cpu="">on acpi0
    est0: <enhanced speedstep="" frequency="" control="">on cpu0
    p4tcc0: <cpu frequency="" thermal="" control="">on cpu0
    cpu1: <acpi cpu="">on acpi0
    est1: <enhanced speedstep="" frequency="" control="">on cpu1
    p4tcc1: <cpu frequency="" thermal="" control="">on cpu1
    pmtimer0 on isa0
    orm0: <isa option="" roms="">at iomem 0xce800-0xcf7ff,0xcf800-0xd07ff,0xe0000-0xe17ff pnpid ORM0000 on isa0
    atkbdc0: <keyboard controller="" (i8042)="">at port 0x60,0x64 on isa0
    atkbd0: <at keyboard="">irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    atkbd0: [ITHREAD]
    sc0: <system console="">at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    sio1: configured irq 3 not in bitmap of probed irqs 0
    sio1: port may not be enabled
    vga0: <generic isa="" vga="">at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    Timecounters tick every 1.000 msec
    IPsec: Initialized Security Association Processing.
    ad0: FAILURE - SET_MULTI status=51 <ready,dsc,error>error=4 <aborted>ad0: 7641MB <sandisk pssd-s2="" 8gb="" ssd="" 6.00="">at ata0-master UDMA33
    SMP: AP CPU #1 Launched!
    Trying to mount root from ufs:/dev/ad0s1a
    pflog0: promiscuous mode enabled
    re0: link state changed to UP
    re1: link state changed to UP
    WARNING: pseudo-random number generator used for IPsec processing</sandisk></aborted></ready,dsc,error></generic></system></at></keyboard></isa></cpu></enhanced></acpi></cpu></enhanced></acpi></thermal></thermal></ata></ata></intel></isa></pci-isa></ralink></intel></ehci></ehci></intel></uhci></uhci></intel></uhci></uhci></intel></uhci></uhci></rtl8169s></mii></realtek></acpi></acpi></rtl8169s></mii></realtek></acpi></acpi></vga-compatible></acpi></acpi></power></acpi></acpi></acpi></ac></high></embedded></ptltd ></software></version></ptltd ></lahf></nx></sse3,dtes64,mon,ds_cpl,vmx,est,tm2,ssse3,xtpr,pdcm,<b22></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>



  • The wireless device in the box is clearly unsupported by pfSense 1.2.3. However it looks very like a device newly supported in pfSense 2.0 BETA by the run driver which supports Access Point mode. The wireless device you have apparently uses the USB electrical interface on the mini PCIe connector and reports itself similarly to a USB stick I have that is recognised by the run driver in pfSense 2.0.

    On my pfSense 2.0 system the reported USB devices are:

    # usbconfig
    ugen0.1: <uhci root="" hub="" via="">at usbus0, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON
    ugen1.1: <uhci root="" hub="" via="">at usbus1, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON
    ugen2.1: <uhci root="" hub="" via="">at usbus2, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON
    ugen3.1: <ehci root="" hub="" via="">at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON
    ugen3.2: <802.11 n WLAN Ralink> at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON</ehci></uhci></uhci></uhci> 
    ```and the system startup reports that WLAN device in this fashion:
    

    ugen3.2: <ralink>at usbus3
    run0: <1.0> on usbus3
    run0: MAC/BBP RT3070 (rev 0x0201), RF RT3020 (MIMO 1T1R), address c8:3a:35:c4:ee:f3
    run0: firmware RT2870 loaded</ralink>

    It looks to me as you could probably put pfSense 2.0 on that box and be able to use it as a Wireless Access Point pretty soon after. (One problem you will probably encounter is that it is necessary to do a tweak to get the firmware loaded: search the pfSense 2.0 forum for the string "runfw" for the details.)
    
    Because pfSense 2.0 is not yet ready for production use it can be (and has been) unstable. You might not yet be ready to play with it. If I recall correctly, I've seen mini PCIe WLAN cards that should be supported in pfSense 1.2.3 and are capable of operating in Access Point mode available for purchase on eBay for reasonable prices.
    more details of the WLAN device are:


  • Very interesting. I have a spare pc2i here that I've been testing 2.0 beta on. I'll try runfw tomorrow and see what happens. I'll report back if I find anything out. THanks for your help!



  • Yep, that worked. Recognized the wireless card and I was able to set it up as an access point. 2.0 is still pretty buggy, so I'll stick with 1.2.3 until 2.0 release.

    Thanks for all your help!



  • Just some other question about the fitPC2i, which I own, all is running fine except rebooting the machine

    I tried with and without ACPI tried the sysctl acpi reboot options, however when I request the machine hangs and I need to remove the power, since the keyboard ain't working as well.

    Running the latest pfSense 2.0 BETA4



  • I have exactly the same problem as you Inferno.
    I have updated to the latest snapshot (pfSense-Full-Update-2.0-beta5-i386-1430.tgz 12-Jan-2011 18:42) and the problem persists with that you can not restart it. I need to remove the power.

    Have you found any solution yet?



  • I didn't found a fix yet



  • I've tested the new snapshot 2.0-BETA5 (i386) built on Sun Jan 16 22:00:36 EST 2011 with no luck.

    Setting "sysctl -w hw.acpi.handle_reboot=1" makes no difference.



  • Hi All,
    this is my first post here. I jut got a fitpc2i with the included 8G SSD and loaded 2.0rc1 embedded version on  it. The install went very well. The only difficulty is that the SSD cannot be easily removed so getting it loaded was interesting. I wound up creating a puppy linux version on a USB stick, booting off that, going online and getting the embedded file and copying that to the SSD. Having done searching here I knew I was going to need to use the serial port for the initial setup, that went very well, it took about 1 minute and I was up and running over the web interface. I had everything setup in about 2 minutes after that.

    This has been the quickest, easiest install I have ever done! Hats off to the development team, I was really impressed.

    So far everything is working great, I'm typing this message with my laptop hooked up to the LAN port so it does work! I haven't had time to do any stress testing yet, but so far the results are encouraging. Its handing out DHCP leases about 20 times faster that my previous router which is really greatly appreciated.

    Oh and BTW the reboot issue seems to have been fixed. I've had no problem whatsoever rebooting from several different programs. I'm not sure if this is a firmware or hardware upgrade.

    Next week my Cisco switch comes in at which point I'm going to get heavily intoVLANs etc. If today is any indication I'm going to have everything up and doing exactly what I want in a much shorter time than I had allocated.

    So far I'm very pleased with the combination.

    John S.


Log in to reply