Wireless Connection time out with MacBook (pfSense running on an ALIX board)



  • Let me preface by saying that I have searched the forums, wiki, internet and various Apple/Mac boards before posting. So if I missed it somewhere my apologies but I did exhaust all of my Google-fu :)

    Hardware set up
    ALIX.2D2 running pfSense 1.2.3-RELEASE
    Wireless is a Belkin USB 802.11g card (only one they made) ver 3.

    System in question
    MacBook 5.1 running 10.6.3 Snow Leopard (latest at the time of posting)

    Software set up:
    No separate Wi-Fi IP
    Bridge with LAN
    Protection OFF
    802.11g Only
    Enable WME
    Transmit power 99
    Channel - 4
    WPA 1 and 2
    Pre-shared Key
    Open System Authentication
    AES
    Everything else is default

    This set up works absolutely perfectly with my Dell (Win 7) and my iPhone, however my girlfriend's MacBook connects for about 10 seconds and then drops. If I try to connect manually it gives me a time out. I tried this on a Linksys router and it seems to have worked fine.

    I have tried all the fixes I could find on the Apple side:
    New location, Deleting config files, zapping PRAM, resetting SCS (I think that's what it's called).
    Tried turning off encryption, setting G only to off, changing between TKIP and AES, between WPA2 and WPA straight up, changing the passphrase and SSID. So pretty much out of ideas.

    I'm a n00b to pfSense and I found the following http://www.mail-archive.com/support@pfsense.com/msg19305.html
    The problem is that I am not sure WHERE to make these configs, as I see alot of dnsmasq entries.

    Any help will be appreciated :)



  • I doubt if that mailing list post you linked is related, that's only with DNS resolution on local hostnames, not losing connectivity entirely. Haven't had any issues with my MBP and I know a lot of others use the same, though it could be some kind of incompatibility between FreeBSD and that NIC or OS X that somehow no one else has seen. You've tried everything I would normally suggest it appears.



  • Thanks, that's actually good news. If this is just a WNIC issue, I'll be able to resolve it once my pigtail arrives (Atheros based card). Was concerned that it may be a pfSense issue.



  • OK, got my pigtail and set up the internal card, everything is working just fine now, looks like pfSense + Belkin G + OS X is a bad combination…


Log in to reply