IPTV - IGMP query interval



  • Also mit der pfsense 2.0 hab ich nun ohne Probs das IPTV von T-Home ans laufen gebracht, jedoch nur für ca. eine Minute immer (ja geht per Multicast). Hier scheint der IGMP query interval (genau nach 125 sec) ignoriert zu werden und somit bleibt das Bild dann stehen. Genau in dem Moment hab ich dann auch im Firewall-log zwei Einträge:

    
    block Apr 8 20:04:53 	WAN 	87.186.224.XX 	224.0.0.1 	IGMP
    block Apr 8 20:04:37 	IPTV 	87.151.127.XX 	224.0.0.1 	IGMP
    block Apr 8 20:03:53 	WAN 	87.186.224.XX 	224.0.0.1 	IGMP
    block Apr 8 20:03:36 	IPTV 	87.151.127.XX 	224.0.0.1 	IGMP
    
    

    Nach weiteren ca zwei Minuten startet das IP-TV wieder selbstständig. Hat dazu vllt jemand nen Einfall ?

    Achso konfiguriert ist folgendes:
    Firewall -> Rules -> LAN: hier habe ich der Default-Regel nur "This allows packets with IP options to pass. Otherwise they are blocked by default. This is usually only seen with multicast traffic." hinzu gefügt
    Firewall -> Rules -> IPTV: jeglichen Udp-Traffic mit Ziel 224.0.0.0/4 erlaubt
    Service -> IGMP Proxy: IPTV - Dev ist upstream mit nur einem Netz (193.158.34.0/23) <- aus DHCP-Request entnommen
    Service -> IGMP Proxy: LAN - Dev ist downstream ohne Eintragung da sich igmproxy eh an LAN-Subnet bindet

    Danke im voraus.



  • Ich weiß zwar nicht mehr genau, wie die Default-Regel lautet (schätzungsweise any bei Protokoll) aber hast Du schon mal versucht vorsichtshalber IGMP explizit als Protokoll zu erlauben? z.B. vor der Default-Regel?

    Proto  Source  	Port  	Destination  	Port  	Gateway
    IGMP  	WAN  	    *     224.0.0.0/4  	 *  	 * 
    
    

    Ist zwar OT, aber müllt bei Dir der IGMPproxyd auch so das Systemlog voll? Es wird unbenutzbar, weil alles nur noch IGMP ist.



  • @hbc:

    Ich weiß zwar nicht mehr genau, wie die Default-Regel lautet (schätzungsweise any bei Protokoll) aber hast Du schon mal versucht vorsichtshalber IGMP explizit als Protokoll zu erlauben? z.B. vor der Default-Regel?

    Proto  Source  	Port  	Destination  	Port  	Gateway
    IGMP  	WAN  	    *     224.0.0.0/4  	 *  	 * 
    
    

    Ist zwar OT, aber müllt bei Dir der IGMPproxyd auch so das Systemlog voll? Es wird unbenutzbar, weil alles nur noch IGMP ist.

    Jabs, aber dazu funktioniert es ja nicht einmal. Programm geht immer 1:30 und dann ne Ecke nicht usw.


Log in to reply