Portal Cautivo con HTTPS



  • Holas buenas tardes…

    espero sean de ayuda..

    por ahora tengo 2 interfaz activa WAN y LAN... tengo un linksys para un area especifica conectado a la LAN. hasta hace unos dias solo tenia portal cautivo por HTTP. luego vi unas opciones para que funcione con HTTPS, pero no he logrado hacer que funcione. bueno en verdad no se cual es la configuracion real.

    aplique una configuracion pero cuando me autentifico vuelvo a caer en la pag de autentificar. pareciera que no se autentifica realmente..
    en HTTP funciona la autentificacion de manera correcta.

    alguien puede faciltar una configuracion mas detallada del portal cautivo con HTTPS._–

    Gracias de antemano. :D



  • En [Documentación] [En inglés] [Tutoriales] de arriba tienes tutoriales sobre CP.

    Tendría que ir sin problemas. Activando la casilla HTTPS y completando los datos relativos al nombre de servidor, su certificado y llave.

    ¿Cómo tienes el tema del certificado+llave? Si no está al completo igual puede influir. Es lighthttpd como servidor web y no conozco el comportamiento…



  • :) hola…

    para este caso depende mucho de la version de pfsense que estes usando.

    1. si es antes de la 1.2 entonces habilitas el captive portal en https, y el pfsense crea las llaves , en mi caso nunca me funcionó

    2. si es 1.2 a 1.3 o 2.0 en entonces debes generar todas las llaves y certificados, HTTPS server name, HTTPS certificate, HTTPS private key, de lo contrario no funcionara.

    3. si es 1.3 o 2.0 entonces debes crear las llaves y certificados en una aplicacion de gestion de certificados que trae en el menu de sistema, una vez creadas alli debes habilitar el captive portal con https y apuntar las llaves y certificados a los creados



  • bueno muchas gracias… amigos...

    no tiene nada  que ver con versiones del pfsense...

    mi portal cautivo quedo calidad.
    solo configure un poco la fuente del htm y listo. con tiempo coloco el post con detalle.
    gracias por su ayuda.


Log in to reply