[OpenVPN] Mode brigde



  • Bonjour,

    J'ai installé OpenVPN selon le tuto officiel, pas de soucis particulier (j'y reviendrai plus tard !). Cela fonctionne en mode TUN. Merci pour celui-ci.
    Je voudrais essayé en mon Tap. J'ai donc suivi le tuto officiel "OpenVPN Bridge".
    Apparemment, il y aurait un petit soucis avec celui-ci, cf la première mention en haut de page.

    Voici la config (extrait XML) :

    
    			 <config><disable><protocol>UDP</protocol>
    				<dynamic_ip>on</dynamic_ip>
    				<local_port>4747</local_port>
    				<addresspool>192.168.173.0/24</addresspool>
    				 <nopool><local_network>10.133.173.0/24</local_network>
    				 <remote_network><client2client><crypto>AES-256-CBC</crypto>
    				<auth_method>pki</auth_method>
    				 <shared_key><ca_cert>enlevé pour publication sur le forum</ca_cert>
    				<server_cert>enlevé pour publication sur le forum</server_cert>
    				<server_key>enlevé pour publication sur le forum</server_key>
    				<dh_params>enlevé pour publication sur le forum</dh_params>
    				 <crl><tls><dhcp_domainname>cddp47.crdpaquitaine.ac-bordeaux.fr</dhcp_domainname>
    				<dhcp_dns>10.133.173.3;10.133.173.252</dhcp_dns>
    				<dhcp_wins>10.133.173.3</dhcp_wins>
    				 <dhcp_nbdd><dhcp_ntp>10.133.173.252</dhcp_ntp>
    				<dhcp_nbttype>0</dhcp_nbttype>
    				 <dhcp_nbtscope><dhcp_nbtdisable><use_lzo>on</use_lzo>
    				 <maxclients><passtos>on</passtos>
    				<gwredir>on</gwredir>
    				<custom_options>dev tap0;server-bridge 10.133.173.252 255.255.255.0 10.133.173.100 10.133.173.200</custom_options>
    				<description>UDP TAP</description></maxclients></dhcp_nbtdisable></dhcp_nbtscope></dhcp_nbdd></tls></crl></shared_key></client2client></remote_network></nopool></disable></config> 
    
    

    Donc, on remarque bien les ajouts adéquats dans la section 'custom options' ; de même, j'ai bien modifié le fichier config.xml pour ajouter les éléments XML nommés 'earlyshellcmd', et 'shellcmd', adaptés à ma config, ainsi :

    
    		<earlyshellcmd>ifconfig bridge0 create</earlyshellcmd>
    		<earlyshellcmd>ifconfig bridge0 addm rl0 up</earlyshellcmd>
    		<shellcmd>ifconfig bridge0 addm tap0</shellcmd>
    
    

    Je reboot.

    La commande 'ifconfig bridge0' restitue cela  :

    
    # ifconfig bridge0
    bridge0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	ether 3e:11:81:ba:d2:d1
    	id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
    	maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
    	root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
    	member: rl0 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 1 priority 128 path cost 2000000</learning,discover,autoedge,autoptp></up,broadcast,running,simplex,multicast> 
    

    Malheureusement, on remarque bien que le périphérique 'tap0', n'est pas membre du 'bridge0'.

    De plus, le log d'OpenVPN restitue cette erreur : openvpn[1771]: Options error: –server and --server-bridge cannot be used together.
    (même si mon anglais est très mauvais, j'en comprends le sens :p )

    Qu'aies-je donc loupé ?


Log in to reply