Probleme failover : marche pas sur tous les interfaces



  • Allez c'est reparti…

    Bonjour à tous...

    j'ai un problème sur le failover...

    Voici le problème

    routeur1----int wan-----pfsense1------int opty(vlany)----switch1-------------serveur1
                                          |failover                                  |lien fibre
    routeur2----int wan-----pfsense2------int opty(vlany)----switch2-------------serveur2

    Si du coté du routeur1 je pingue -t en direction du serveur 1 ou 2 cela fonctionne car j'ai nat 1:1 le serveur
    Si du coté serveur1, je pingue -t un client se trouvant derriere le routeur1 cela fonctionne...

    Sauf que si je reboot le pfsense1 et laisse le failover prendre le relais sur le pfsense2, les pingues s'arete...aussi bien d'un cote que de l'autre...

    A savoir que je ne m'occupe que du vlan1 coté routeur1 et 2, et coté switch c'est aussi vlan1, meme si cela ne sert à rien...je sais c'est juste pour mon ptit cerveau...

    Alors reprenons le meme schéma :

    routeur1----int optx(vlanx)-----pfsense1------int opty(vlany)----switch1-------------serveur1
                                                 |failover                  |lien fibre
    routeur2----int optx(vlanx)-----pfsense2------int opty(vlany)----switch2-------------serveur2

    en fait nous sommes dans un autre vlan...Si je pingue -t du coté routeur1 vers serveur1 cela fonctionne
    Si je pingue coté serveur1 vers @ip dans le vlanx, cela fonctionne...

    Si je reboot un des 2 pfsense CELA FONCTIONNE TOUJOURS, grace au carp-failvoer...parfait...

    Alors pourquoi dans le cas numero 1 cela ne fonctionne pas ???

    Je pense a un mauvais nat, et je me demandais si le nat outbound est necessaire ou si un simple nat 1:1 sera suffisant...
    et si un nat 1:1 est suffisant, faut-il le faire dans les 2 sens...un du serveur 1 vers @ipvirt du pf, et nu autre @ipvirt du pf vers serveur1...

    Merci de votre aide...

    Cdt



  • Bon j'ai peut etre une reponse :

    la gateway des clients du cas n°1 n'est pas l'adresse carp du vlan correspondant, mais l'adresse d'un des 2 routeurs (routeur1), donc une fois que le lien coupe, l'autre routeur ne prend pas le relais…et n'informe donc pas de la modification de topologie...

    je sais que pf gere le rip, je vais voir ce que ca donne, car je veux eviter de changer la gateway des clients...donc trouver un routage sur les routeurs...

    vaut-il mieux prendre un proto de routage de niveau 2 genre stp (ou autre), ou alors un proto de routage de niveau 3...

    Mais je n'ai que quelques serveurs derriere les pfs, et j'ai du nat 1:1 donc si je fait du rip je doi donner les adresses du reseau inaccessible par les routeurs...

    qui sait s'il y a un routage dynamique pouvant router des adresses uniques (pour ne pas casser mon nat 1:1) qui permet en cas de lien "down" entre le pfsense1 et le routeur1 de prendre le relais par le routeur 2 qui atteindre le pfsense2

    A savoir j'ai du STP sur les routeurs...mon root bridge etant le routeur1, et aussi du VRRP...

    bon desolé de troller...et merci a vous...


Log in to reply