IpCop et Pfsense



  • Bonjour tout le monde !

    Actuellement en stage, je voudrais lier PfSense (pou portail captif) à IpCop dans mon réseau.
    Mon réseau : (maquette) dsl mais je me suis trompé dans l'adresse de l'interface bleue qui devrait être : 10.205.0.1

    Le problème est la communication entre PfSense et IpCop qui ne s'établit pas.
    Je voudrais avant tout savoir si la communication est possible avec cette configuration là et si quelqu'un parmi vous a déjà réussi à coupler les 2 solutions.

    Si vous avez besoin de plus de détails, n'hésitez pas à me demander.



  • Bonjour,

    Tout d'abord la première chose que je voie c'est que plusieurs interfaces réseau possèdent la même adresse ip, ça ne peut pas marcher.

    L'interface externe de ton pfSense devrait avoir par exemple l'adresse 10.205.0.3
    L'interface interne de ton pfSense devrait avoir par exemple l'adresse 192.168.10.1

    pfSense et IPCop sont des routeurs.

    Sur ce site tu auras des notions sur le routage, ça t'aideras pour ton projet.

    http://christian.caleca.free.fr/

    Voilà !



  • Avant tout, merci pour de t'intéresser au sujet c'est sympa.

    Je tiens à m'excuser et j'ai précisé dans mon post que c'est juste une erreur de frappe sur la maquette  ???

    L'interface bleue a pour adresse : 10.205.0.1
    et Pfsense : 10.205.0.2

    Ensuite je vois que tu mets une adresse de classe A pour l'interface externe et une adresse de classe C pour l'interface interne.
    Ne peut-on pas tout mettre sur la même classe ?! Sachant que cette erreur de frappe a bien faussé le truc pour le coup  :-[

    PS : ta doc est intéressante merci je vais me pencher aussi là-dessus.



  • Pourquoi mettre IPCop + pfSense ??

    Tu ne peux pas mettre uniquement pfSense si c'est un portail captif que tu souhaites ?



  • Tout simplement parce que la partie représentée plus haut correspond à une maquette et que dans l'entreprise où je travaille l'ipcop existe et ne représente qu'un infime partie de son réseau.

    Je ne dois pas toucher à cette partie du réseau et intégrer PfSense au réseau existant.



  • Alors pour ton cas il me semble qu'il faudrait t'orienter vers une solution de firewall transparent.

    http://pfsense.trendchiller.com/transparent_firewall.pdf

    En effet si tu veux garder les même réseaux de chaque coté de Pf je ne voie que cette solution (je peux me tromper …).

    Oh et si je peut me permettre, j'avais déjà utiliser IPCop auparavant. C'est une solution élégante et qui marche bien mais selon moi pfSense et beaucoup plus complet. Une fois que tu auras terminé ton projet fait un livre blanc qui montre l'intérêt de migrer vers pfSense dans ton entreprise (sécurité, ergonomie, facilité d'administration, ...).



  • Ok merci je vais voir ca plus en détail mais je sais pas si tu as vu à la fin c'est marqué :

    There are some features that do not work with the transparent mode until now. Perhaps this will be different in future releases.
    Some features that do not work are:

    • Captive portal
    • Dynamic DNS (since dyndns must use the external WAN-IP)

    Je vais quand même tenter… ;)


    Pas très bon comme résultat !

    Déjà, surprise ! je ne peux pas cocher "enable filtering bridge" car la nouvelle version c'est comme ça.
    Il faut le faire directement depuis l'interface maintenant (dans Interfaces>LAN>bridge with WAN)

    Mais apparemment c'est pas suffisant car si par exemple je me connecte à la borne wifi :
    -> attribution adresse IP OK
    -> ping 10.205.10.2 OK
    -> ping 10.205.0.2 PAS OK

    :o



  • Il est clair que pfSense a beaucoup d'attraits versus un firewall IPCOP (… et que l'Ipcop existant serait plus simple et plus efficace avec pfSense !)

    Perso, je ne préconiserais pas de faire du transparent : le très standard NAT Outbond me parait indiqué !

    Mais, il me semble qu'en Ipcop, chaque adresse ip en Blue doit être validée ...



  • Bon ben vu que pf est un routeur donne un autre réseau à ta partie LAN Wifi de pf.

    Au lieu de 10.205.10.0/255.255.0.0
    je mettrai 10.204.10.0/255.255.0.0



  • Ah oui en effet c'est vrai que c'est beaucoup plus logique maintenant !  8)

    De plus, j'ai autorisé sur l'interface bleue de mon Ipcop l'interface WAN de mon PfSense et tout marche nikel !

    Merci à tous pour vous être donné la peine de m'aider !  ;)

    Résolu !



  • KISS : Keep It Simple and Stupid : pfSense, en mode normal NATte tout ce qui sort + Ipcop Blue qui autorise justement cette adresse WAN du pfSense !

    C'est en effet simple … et par conséquent efficace.


Log in to reply