No DHCP on bridged WLAN again…



  • Sorry for posting the 99th thread, but i´m unable to solve the problem with "no dhcp on bridged LAN-WLAN".

    I´m using 1.2.3-RELEASE  on Alix-board with atheros wifi mini-pci-card.
    IF1 is lan
    IF2 is WAN
    IF3 is WLAN

    As far as i understood, i need to add a firewall-rule on the wlan-interface, at least for port 67-68 (dhcp).
    I tried also any-any, but still got no ip from the dhcp-Server.
    Also tried the same rule on the LAN-interface, not helping.
    On LAN-Interface, DHCP works fine.

    I can connect to the wlan, but got no IP…

    I´m not shure if this alright (first line is empty...):

    SSID BSSID CHAN RATE RSSI INT CAPS

    ADDR AID CHAN RATE RSSI IDLE TXSEQ RXSEQ CAPS ERP
    00:25:d3:f5:ad:d8 1 2 54M 18.0 0 6 576 EPS AE


    $ ifconfig -a
    vr0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=2808 <vlan_mtu,wol_ucast,wol_magic>ether 00:0d:b9:1c:cc:ec
    inet6 fe80::20d:b9ff:fe1c:ccec%vr0 prefixlen 64 scopeid 0x1
    inet 192.168.1.100 netmask 0xffffff00 broadcast 192.168.1.255
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    vr1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=2808 <vlan_mtu,wol_ucast,wol_magic>ether 00:0d:b9:1c:cc:ed
    inet6 fe80::20d:b9ff:fe1c:cced%vr1 prefixlen 64 scopeid 0x2
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    vr2: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
    options=280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic>ether 00:0d:b9:1c:cc:ee
    media: Ethernet autoselect (none)
    status: no carrier
    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    ether 00:80:48:68:5e:36
    inet6 fe80::280:48ff:fe68:5e36%ath0 prefixlen 64 scopeid 0x4
    media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: associated
    ssid Michas channel 2 (2417 Mhz 11g) bssid 00:80:48:68:5e:36
    authmode WPA privacy ON deftxkey 3 TKIP 2:128-bit TKIP 3:128-bit
    txpower 31.5 scanvalid 60 bgscan bgscanintvl 300 bgscanidle 250
    roam:rssi11g 7 roam:rate11g 5 protmode OFF burst -apbridge
    dtimperiod 1
    enc0: flags=0<> metric 0 mtu 1536
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x6
    pfsync0: flags=41 <up,running>metric 0 mtu 1460
    pfsync: syncdev: lo0 syncpeer: 224.0.0.240 maxupd: 128
    pflog0: flags=100 <promisc>metric 0 mtu 33204
    ng0: flags=88d1 <up,pointopoint,running,noarp,simplex,multicast>metric 0 mtu 1492
    inet 78.35.153.102 --> 195.14.226.37 netmask 0xffffffff
    inet6 fe80::20d:b9ff:fe1c:ccec%ng0 prefixlen 64 scopeid 0xa
    bridge0: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
    ether e6:0c:89:11:d6:6b
    id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
    maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
    root id 00:00:00:00:00:00 priority 0 ifcost 0 port 0
    member: vr0 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 1 priority 128 path cost 200000

    What else can i do?
    I would appreciate any help...

    Thanks,
    Michael</learning,discover,autoedge,autoptp></broadcast,simplex,multicast></up,pointopoint,running,noarp,simplex,multicast></promisc></up,running></up,loopback,running,multicast></hostap></up,broadcast,running,simplex,multicast></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic></broadcast,simplex,multicast></full-duplex></vlan_mtu,wol_ucast,wol_magic></up,broadcast,running,simplex,multicast></full-duplex></vlan_mtu,wol_ucast,wol_magic></up,broadcast,running,promisc,simplex,multicast>


  • Rebel Alliance Developer Netgate

    It doesn't show that your wireless is a member of that bridge.

    Ensure you have it setup like so:

    LAN set to not bridged
    WLAN set bridged to LAN



  • If jimp's suggestion doesn't get it working it would be worth looking in the DHCP log and the firewall log. (web GUI: Status -> System logs then click on DHCP tab and Firewall tab) I've seen reports that the dhcp daemon dies; perhaps your firewall rule needs a little tweaking.

    I have WLAN bridged to LAN and the dhcp log reports incoming DHCP requests on vr0 (my LAN interface) rather than ath0 (my WLAN interface). I mention this so you won't be bothered if you see this unexpected report in the DHCP log.

    Packet capture on the WLAN interface can be useful to verify the DHCP requests are actually getting to the pfSense box.



  • Hi,

    bridging is set, only for wlan to lan, bridging for lan is not set.

    I checked that logging for my "WLAN-DHCP"-rule is on and i got entries in the firewall-log, but not in the dhcp-log.
    Firewall-log shows 2 entries for every dhcp-refresh on the wlan-client.

    -> Apr 30 15:32:47 WLAN 0.0.0.0:68 255.255.255.255:67 UDP
    -> Apr 30 15:31:48 WLAN 0.0.0.0:68 255.255.255.255:67 UDP

    Seems that my DHCP-Server does nor recognize the request, right?

    Thank you,
    Michael


  • Rebel Alliance Developer Netgate

    @Wusel_AC:

    Seems that my DHCP-Server does nor recognize the request, right?

    No. That only signifies that the firewall received the packet. From your previous output, your WLAN interface does not appear to be properly bridged to LAN.



  • Or you don't have a firewall rule to allow DHCP traffic?

    Have you checked that the rule you added would allow (pass) these logged packets?



  • Yes, i checked both. bridging is enabled on wlan and i got the above log from a rule that passes and logs hits of the rule.
    But i think i´m a step further….

    After restarting the client and the firewall, i got something different...

    Apr 30 15:56:45 dhclient[12672]: No working leases in persistent database - sleeping.
    Apr 30 15:56:45 dhclient[12672]: No DHCPOFFERS received.
    Apr 30 15:56:44 hostapd: ath0: STA 00:25:d3:f5:ad:d8 WPA: group key handshake completed (WPA)
    Apr 30 15:56:31 dhclient[12672]: DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 14
    Apr 30 15:56:14 dhclient[12672]: DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 17
    Apr 30 15:56:02 dhclient[12672]: DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 12
    Apr 30 15:55:50 dhclient[12672]: DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 12
    Apr 30 15:55:48 kernel: ath0: promiscuous mode disabled
    Apr 30 15:55:44 hostapd: ath0: STA 00:25:d3:f5:ad:d8 WPA: group key handshake completed (WPA)
    Apr 30 15:55:44 dhclient[12672]: DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 6
    Apr 30 15:54:08 php: /services_dhcp.php: NOTE: DHCP Server on LAN is enabled.

    I´m almost shure that i have 5 free Adresses  in DHCP-Range, but this looks as i don´t have one left and i´m stupid…

    Thanks,
    Michael



  • According to the log dhclient is run on ath0 but that would mean ath0 is used as a client on a wireless network, not as an access point. Which one is it?



  • Ah,

    you are right, i changed too much and also set the wlan-adapter to dhcp…
    Changed it back.
    Does this look correct?

    LAN interface (vr0)
    Status up
    MAC address 00:0d:b9:1c:cc:ec
    IP address 192.168.1.100 
    Subnet mask 255.255.255.0
    Media 100baseTX <full-duplex>In/out packets 6049689/8669774 (1.65 GB/1.38 GB)
    In/out errors 0/0
    Collisions 0
    Bridge (bridge0) learning

    WLAN interface (ath0)
    Status associated
    MAC address 00:80:48:68:5e:36
    IP address 0.0.0.0 
    Subnet mask 255.0.0.0
    Media autoselect mode 11g <hostap>Channel 2
    SSID Michas
    In/out packets 995/8541 (179 KB/39 KB)
    In/out errors 3407/0
    Collisions 0</hostap></full-duplex>


Log in to reply