Can't get xbox to show anything other than "strict" NAT. [Resolved]



  • I've read all the guides on the forum and tried them all.  Every time I just keep getting "Your NAT type is strict."  I don't have a fancy setup.  One computer with PfSense on it, a WAN, LAN, and WLAN interface.  I have two NAT forwarding rules entered, one for VNC, and one for Bit torrent.  I've tried forwarding 3074, I've tried adding rules to allow the multicast through as suggested in a post by one of the devs, I've tried using Upnp all with no luck.

    My xbox has a static ip of 192.168.1.155, and my DHCP server goes from 2 to 100.  I have my xbox set to use 192.168.1.1 as both a gateway, and DNS server.

    Anyone have any suggestions?

    FIXED

    I had my xbox set to a manual address of 192.168.1.155 and the DHCP server on pfsense set to a range of 2 to 100.  I put my xbox back to automatic in the network settings so it would use DHCP, and then did a static mapping using the xbox's MAC address in pfsense DHCP server to always give it .155.  I then turned on upnp and set it to default deny and put a rule in for .155 and it just started working.

    Not sure if it was something about pfsense not liking that the xbox had a manual ip outside its DHCP range considering I was trying to get upnp to work with that static ip, or if the xbox was doing something stupid because it was set to a manual ip?



  • I've read most of the threads regarding XBOX 360 console NAT & UPNP, etc. but still failed to get mine working.
    Just wanted to post that THIS solution finally worked for me.
    It could be that I just did not understand some of the other solution steps, (the best I got was "Your NAT type is moderate") but THIS solution finally got me to status of "open".

    My son is now once again rejoicing in the XBOX Live death & carnage of Modern Warfare 2 - haha

    I'm still learning - but really liking pfSense!



  • I did the following on OpenBSD PF and should be applicable to PFSense to get an OPEN nat connection

    1. Static IP for XBOX either by setting to IP address outside DHCP range or doing a static MAC entry in your DHCP server
    2. enable UPnP
    3. Use pfsense "Manual Outbound NAT rule generation (Advanced Outbound NAT (AON))"
    4. Generate your default rules required for your standard internet plus an extra rule for the xbox
        a. the extra rule should have a source IP of the Xbox static address to ANY but you must check static port

    NOTE - the extra rule has to be on top so that it can be evaluated first.

    re-test your network connection via xbox and it should come up as OPEN NAT.

    Here is something I posted on the pf forums awhile back
    http://www.mail-archive.com/pf@benzedrine.cx/msg08115.html



  • I've heard that numbers of  customers are slowly moving from the Wii system to rival game consoles like Microsoft's Xbox 360. I think Nintendo needs to create and introduce a brand new creation fast to match with its competitors if they want to return to positive growth.



  • Any chance we could get specifics on "…put a rule in for .155"  ???

    How is your NAT setup?

    Did you remove the port 3074 and 88 stuff ?

    I've found about 5 different threads that post a "method that works" yet none of them work for me on 1.2.3.

    @skysurf76:

    I've read all the guides on the forum and tried them all.  Every time I just keep getting "Your NAT type is strict."  I don't have a fancy setup.  One computer with PfSense on it, a WAN, LAN, and WLAN interface.  I have two NAT forwarding rules entered, one for VNC, and one for Bit torrent.  I've tried forwarding 3074, I've tried adding rules to allow the multicast through as suggested in a post by one of the devs, I've tried using Upnp all with no luck.

    My xbox has a static ip of 192.168.1.155, and my DHCP server goes from 2 to 100.  I have my xbox set to use 192.168.1.1 as both a gateway, and DNS server.

    Anyone have any suggestions?

    FIXED

    I had my xbox set to a manual address of 192.168.1.155 and the DHCP server on pfsense set to a range of 2 to 100.  I put my xbox back to automatic in the network settings so it would use DHCP, and then did a static mapping using the xbox's MAC address in pfsense DHCP server to always give it .155.  I then turned on upnp and set it to default deny and put a rule in for .155 and it just started working.

    Not sure if it was something about pfsense not liking that the xbox had a manual ip outside its DHCP range considering I was trying to get upnp to work with that static ip, or if the xbox was doing something stupid because it was set to a manual ip?



  • @vronp:

    I've found about 5 different threads that post a "method that works" yet none of them work for me on 1.2.3.

    Try the config per my post in the sticky thread.  Just be sure to disable UPnP.


Locked