WLAN and DHCP



  • Hello Forum!

    My configuration looks the following: WRAP with 2 LAN, 1 WLAN (CM9), WLAN bridged to LAN; WAN on PPPoE; using DHCP on LAN and Traffic shaping between LAN and WAN. That configuration worked pretty good in RC2 i had running for a long time - i recently installed the final release (no update, fresh flash), and now i have the following problem: Using different security configurations on WLAN (WPA, WPA2, both, AES, TKIP, both, etc), i can always connect to the wireless network with my PC, but the DHCP does not give me an IP Adress - there's not even anything about an DHCP Request in the logs for the DHCP server - only the usual stuff about starting on the LAN interface etc.
    The fresh install went the following way: i pulled a backup of the configuration, flashed the 128MB CF card with the 1.0 Release embedded version, put the card in the wrap, booted, logged in with the default credentials and then restored the config backup i made earlier. Everything else (traffic shaping, WLAN, etc.) seems to work fine, but i just can't seem to get an IP adress from the DHCP server.

    Anyone got a hint what's wrong? I'm very willing to put logs and such here to make diagnosis easier.

    Regards,
    Alex



  • Me too, using an IT-100. If I statically set the IP address, all is fine, but if I set my laptop to DHCP it's not getting an address. The Wireless is bridged with the LAN and in AP mode, and setup like this you can't add a DHCP relay (but this is supposed to be taken care of by the bridging anyway).

    A wired connection to the LAN interface gets an IP, and it seems that the wireless interface gets an IP (eventually) if the wired connection is plugged in at the same time, but not when I unplug the wired connection. There are other devices plugged into the LAN connection (it's a 4 port switch on the IT-100) so it shouldn't be a problem with the bridging due to the LAN interface being down.



  • if the lan is not plugt in then there is no bridge
    wlan can only be bridged if the lan is up

    bridging only works when all the bridged interfaces are up



  • With my IT-100, the LAN is plugged in as the internal card is attached to an internal 4 port switch. This means that the LAN will always be up. To make sure, I have a device constantly plugged into the one of the 4 ports of the LAN switch.



  • it sounds similar to my posted problem….

    I tired on the ssh shell a "dhclient wi0" and I get in IP via DHCP..... But after restarting the pfsense box, I to not receive an IP...



  • @jeroen234:

    if the lan is not plugt in then there is no bridge
    wlan can only be bridged if the lan is up

    bridging only works when all the bridged interfaces are up

    Up yes, but it doesn't have to be connected - at least it worked without being physically connected in RC2, so i believe it has something to do with the DHCP in connection with the OPT1 interface, not with the bridge.

    Regards,
    Alex



  • Update for all who may be concerned: It seems like those problems mentioned above are gone with 1.0.1. Thanks for the fix, whoever committed it :)

    Cheers,
    Alex



  • it is updated since few days and the same problem



  • hi,
    lets discuss the problem again. or does anybody solved it?

    I upgraded to 1.2-BETA-1 and the configuration is WAN=wireless adapter, which gets the IP via DHCP from another AP. LAN=interl card and works fine.

    If I reboot the pfsense box, then the WAN interface does not get an IP address. After a release/renew made by hand, it works fine.
    What should or could I do, that pfsense gets an IP address after rebooting?
    thx


Log in to reply