PfSense 2.0 beta + ppp…..



  • Привет Всем!
    Никто не сталкивался с подключением 3G модемов e160g и e1550, они вроде как определяются, но заставить работать не могу…...
    захожу в меню interfaces->assign->PPPs
    нажимаю добавить.
    выбираю Link interface(s), но почаму-то он определяется как две штуки :)  /dev/cuaU0.0 и /dev/cuaU0.1
    затем Description - 3G internet
    Username - megafon
    password - megafon
    Phone Number - 991#
    Access Point Name (APN) - "internet"
    затем жму save и появляется ppp0, ставлю его как wan
    и на этом все заканчивается, может в строке инициализации модема чё-нить написать надо?
    логи ppp пустые почаму-то



  • таки надо добавить как-то ввод пин или разблокировку сделать



  • @deutsche:

    таки надо добавить как-то ввод пин или разблокировку сделать

    это само собой, сделал, но… не помогает, в логах пишет что какбы его знает
    kernel: ugen1.2: <huawei technology="">at usbus1
    kernel: u3g0: <huawei 0="" 2="" technology="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 0.00,="" addr="">on usbus1
    kernel: u3g0: Found 2 ports.
    а вот ppp лог пустой,
    может попробывать модем переключить только в режим модема (без всяких там sd и сдромов), тока какне знаю, под виндой есть прога а как под фрёй?</huawei></huawei>



  • Процесс то работает?

    ps -eaxf | grep mpd
    

    чего говорит:

    ifconfig
    


  • @Evgeny:

    Процесс то работает?

    ps -eaxf | grep mpd
    

    а причём тут mpd? это не впн и им подобные пптп каналы….

    чего говорит:

    ifconfig
    

    а ничё толком не говорит, высвечивает тока ло и пару езернетов, а ppp0 нет :(



  • @Slava_D:

    @Evgeny:

    Процесс то работает?

    ps -eaxf | grep mpd
    

    а причём тут mpd? это не впн и им подобные пптп каналы….

    Ну в 1.2.3. PPTP на WAN mpd реализует. Не знаю про 2.0



  • @Evgeny:

    @Slava_D:

    @Evgeny:

    Процесс то работает?

    ps -eaxf | grep mpd
    

    а причём тут mpd? это не впн и им подобные пптп каналы….

    Ну в 1.2.3. PPTP на WAN mpd реализует. Не знаю про 2.0

    в 2.0 pptp тоже самое, мне надо модем заставить работать поднять не впн а ppp



  • Прошу прощения. Зарапортовался.



  • @Evgeny:

    Прошу прощения. Зарапортовался.

    забей!
    завтра попробую заставить его писать в лог, мож чё прояснится.



  • Slava_D покажи пжлст как разобрался с пином.



  • @deutsche:

    Slava_D покажи пжлст как разобрался с пином.

    привет!
    в общем тама есть, при создании ppp тама есть show advanced options и тама есть Sim PIN, а ваще проще его отключить на симке (или телефоном или видной или линуксом) …..



  • и так, через веб консоль ваще тишина, поправил ppp.conf на

    
    default:
        set log Phase Chat LCP IPCP CCP tun command
        ident user-ppp VERSION (built COMPILATIONDATE)
    
    megafon:
      set device /dev/cuaU0.1
      set speed 460800
    
      set dial "\"\" \
      AT OK \
      AT OK \
      ATS0=0 OK \
      AT OK \
      AT&FE0V1X1&D2&C1S0=0 OK \
    
      set phone "*99***1#"
      set login
      set authname "mobile"
      set authkey "internet"
    
      disable ipv6cp
      disable pap
      disable chap
      enable dns
    
      set ifaddr 10.0.0.1/0 10.0.0.2/0 255.255.255.0 0.0.0.0
      add default HISADDR
    
    

    ppp -ddial megafon

    в логах пишет

    ppp[52441]: tun0: Phase: Unknown protocol 0x0013 (reserved (transparency inefficient))
    ppp[52441]: tun0: LCP: deflink: SendProtocolRej(1) state = Req-Sent

    походу дела не знает фря его, будем копать в сторону usb_modeswitch (но тада можно и 1.2.3 поставить думаю)



  • Все заработало! не надо было по совету не которых форумов, отключать sd и cd1 (ну по крайне мере для модемов e160g и e1550)….
    Сначало испытания проводились на e160g, поднял tun0 для теста - ppp.conf

    
    #################################################################
    # PPP  Sample Configuration File
    # Originally written by Toshiharu OHNO
    # Simplified 5/14/1999 by wself@cdrom.com
    #
    # See /usr/share/examples/ppp/ for some examples
    #
    # $FreeBSD$
    #################################################################
    
    default:
        set log Phase Chat LCP IPCP CCP tun command
        ident user-ppp VERSION (built COMPILATIONDATE)
    
    megafon:
      set device /dev/cuaU0.0
      set speed 460800
      set ctsrts off
      set dial "ABORT BUSY ABORT NO\\sCARRIER TIMEOUT 5 \"\" AT OK-AT-OK ATE1Q0 OK \\dATDT\\T TIMEOUT 40 CONNECT"
    
      set phone "*99***1#"
      set login
      set authname "mobile"
      set authkey "internet"
    
      disable ipv6cp
      disable pap
      disable chap
      disable pred1 deflate deflate24 protocomp acfcomp shortseq vj mppe
      enable dns
    
      set ifaddr 10.0.0.1/0 10.0.0.2/0 255.255.255.0 0.0.0.0
      add default HISADDR
    
    

    затем

    
    # ppp -ddial megafon
    Loading /lib/libalias_cuseeme.so
    Loading /lib/libalias_ftp.so
    Loading /lib/libalias_irc.so
    Loading /lib/libalias_nbt.so
    Loading /lib/libalias_pptp.so
    Loading /lib/libalias_skinny.so
    Loading /lib/libalias_smedia.so
    Working in ddial mode
    Using interface: tun0
    
    #ifconfig tun0
    tun0: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
            options=80000 <linkstate>inet 10.205.31.128 --> 10.0.0.2 netmask 0xffffff00
            Opened by PID 46213
    
    # ping www.ya.ru
    PING ya.ru (77.88.21.3): 56 data bytes
    64 bytes from 77.88.21.3: icmp_seq=0 ttl=47 time=1018.293 ms
    64 bytes from 77.88.21.3: icmp_seq=1 ttl=47 time=699.875 ms
    64 bytes from 77.88.21.3: icmp_seq=2 ttl=47 time=634.733 ms
    64 bytes from 77.88.21.3: icmp_seq=3 ttl=47 time=575.579 ms
    64 bytes from 77.88.21.3: icmp_seq=4 ttl=47 time=516.430 ms
    ^C
    --- ya.ru ping statistics ---
    5 packets transmitted, 5 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 516.430/688.982/1018.293/175.580 ms
    
    # traceroute ya.ru
    traceroute: Warning: ya.ru has multiple addresses; using 87.250.251.3
    traceroute to ya.ru (87.250.251.3), 64 hops max, 40 byte packets
     1  10.77.196.222 (10.77.196.222)  967.883 ms  659.686 ms  696.844 ms
     2  10.77.240.229 (10.77.240.229)  701.812 ms  696.743 ms  700.828 ms
     3  10.77.240.21 (10.77.240.21)  660.832 ms  678.678 ms  659.714 ms
     4  10.77.25.12 (10.77.25.12)  659.846 ms  719.718 ms  678.950 ms
     5  * 10.77.25.34 (10.77.25.34)  698.533 ms *
     6  10.77.25.34 (10.77.25.34)  1339.382 ms  700.733 ms  821.811 ms
     7  * *^C</linkstate></up,pointopoint,running,multicast> 
    

    заработало, ура, подключил e1550 тоже самое работает!
    затем всё убил killall ppp

    снёс pfsense 2.0 (зачем-то), поставил 1.2.3, тама этим обстоит хуже, не нашел u3g, подумал надо поставить но это оказалось не так просто, решил с молого поставить просто mc для начала (для удобства гулять по файлам),  но устанока его потребовала еще кучу пакетов, терпения не хватило… реально...снёс :( (гдеж порты фри)
    загрузился с cd pfsense 2.0 попробывал создать ppp в веб, и оно заработало (e160g и e1550).... я в шоке...


    все как работает!
    осталось одно, как запусить pfsense на машине с одним эзернетом, где что надо поправить?


Locked