Ayuda con la conexión a lan



  • hola, buenas tardes

    hoy he instalado pfsense 1.2.3 livecd en un pentium4 y un pequeño disco duro de 4gb, al principio no arrancaba , pero al dar a la opcion 3 del arranque ( safe mode ) ha arrancando, el problema viene al intentar entrar a la configuracion via web.
    la configuracion viene a ser la siguiente

    Wan-> rl0 -> que conecta con dhcp ( 192.168.1.4 ) a un router con puerta de enlace 192.168.1.1
    lan-> vr0 -> 192.168.1.1 ( he intentado activar dhcp en la configuracion, pero en el menu no me aparece que tiene dhcp

    Bien, uso arch linux y la configuracion de la red para conectar al firewall va asi en el rc.conf "
    eth0="eth0 192.168.1.9 netmask 255.255.255.0 broadcast 192.168.1.255"
    gateway="default gw 192.168.1.1"
    ROUTES=(gateway)
    #eth0="dhcp"
    INTERFACES=(eth0)"

    pero no consigo que entre a la direccion del firewall , en los pings que intento hacer al servidor dice :
      ping 192.168.1.1
    PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
    From 192.168.1.9 icmp_seq=3 Destination Host Unreachable
    From 192.168.1.9 icmp_seq=4 Destination Host Unreachable
    […]
    y asi todo el rato.

    Bueno a ver si me podeis ayudar :) , muchas gracias



  • :) hola..

    el pfsense fue pensado para ser configurado via web, no via comando, de esta manera se hace mas facil su manejo, tambien se pueden hacer ajustes via comando o modificando archivos pero requiere un mejor entendimiento del como funciona la parte web para que los cambios tengan efecto y al reiniciar se mantengan.

    1. instalaste en el disco duro? o solo arrancas desde el cd ?
    2. al instalarse o ejecutarse desde el cd se puede cambiar la direccion ip de la lan, que te recomiendo que lo hagas, dado que ya tienes una direccion 192.168.1.1 en tu wan como puerta de enlace lo cual genera conflictos  entre la red del lado lan y la del lado wan, cuando cambias la ip tambien puedes definir si habilitas el dhcp en la lan.

    prueba lo que te dije y comentanos…



  • Hola, gracias por responder

    te cuento, Pfsense esta instalado en el disco duro

    te digo lo que voy haciendo

    acabo de arrancar pfsense, he desconectado el cable de wan y el de lan esta conectado
    he marcado la opcion 4 ( reset to factory defaults ) para poner todo en defecto.
    una vez reiniciado, he configurado las interfaces con lan y wan ( sin nunguna vlan )
    lan -> vr0
    wan -> rl0 ( cable desconectado )
    una vez hecho esto, he marcado la opcion 2 ( set LAN IP address ) y he puesto
    LAN IP address: 192.168.0.1
    Lan subnet bit count: 24
    Enable the dhcp server on LAN: Yes
    start address of the client address range: 192.168.0.2
    end address of the client address range: 192.168.0.255
    y he guardado los cambios,
    luego en mi ordenador con arch linux, he reiniciado la red con dhcp activado , pero este no carga:
    /etc/rc.d/network restart
    :: Stopping Network                                                                                                      [DONE]
    :: Starting Network                                                                                                      [FAIL]
    luego he probado a poner yo la ip
    eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
    gateway="default gw 192.168.0.1"
    ROUTES=(gateway)
    pero sigue sin cargar la pagina , ni un ping ni nada.

    bueno, sin mas , me despido a la espera de una respuesta :)



  • Es posible que pruebes con un cliente windows??



  • pues precisamente , con un cliente con windows ha entrado a la configuracion del firewall, pero no se decir porque, pueden ser los cables?… no encuentro una solucion razonable para que con gnu/linux no vaya  ???.
    vosotros usais algun cliente con linux y lo habeis conseguido conectar?



  • Yo uso ubuntu,basado en debian…

    La interfaces se configuran en /etc/network/interfaces

    Creo que en arch,es algo diferente...

    en ubuntu para una ip fija(aunque el dhcp en lan esté activo(2:25)es así:
    ################################
    auto eth0

    iface eth0 inet static

    address 192.168.1.2
    netmask 255.255.255.0
    gateway 192.168.1.1
    broadcast 192.168.1.255
    #####################################
    Para obtener una ip via dhcp,seria:

    auto eth0

    iface eth0 inet dhcp
    ##########################
    que dns tienes configurado en /etc/resolv.conf
    pon la direccion de la interface lan de pf.

    También puedes configurar las interfaces con ifconfig.

    info sobre network en arch: http://wiki.archlinux.org/index.php/Configuring_Network#For_Static_IP



  • probe el disco duro de el ordenador que no funciona en el que si funcionaba ( el que tenia windows ) y funciono perfectamente, asi que solo me queda como alternativa comprar una segunda tarjeta de red y probar de nuevo…. gracias por la ayuda prestada =)



  • prueba poner el rango dhcp de 192.168.0.2 a 192.168.0.254
    el 192.168.0.255 es la direccion de broadcast, y no creo que funcione el dhcp con ella en la configuracion.


Log in to reply