How to use both ethernet ports on the mobo



  • I am using an Alix PC Engines Alix2c10 board with an Atheros AR5004G mini pci card.
    I can't seem to figure out how to use wifi access point and wired lan at the same time.

    The board has 2 Ethernet ports. If I use (WAN) connection from the modem to the port next to the power connector, I can get the wifi to work and able to connect to the internet with my laptop tirelessly. But, other Ethernet port on the mobo becomes useless. I can not connect a patch cable from there to a pc and get lan connection.

    How can I use the access point and at the same time be able to use the other (WAN) port port on the mobo to connect a switch or pc to it?

    I thought it should work like this, connect WAN connection to the WAN port on the mother board and use the LAN port of the board to connect to a switch or pc.

    Am I not doing it right?



  • A fair bit more information is needed to understand what is going on.

    You have three network interfaces in the pfSense system, two wired and the WiFi. The pfSense configuration will want to configure one interface as WAN, one as LAN and one as OPT1 (or a name of your choice). It sounds as if you have configured the WiFi interface as LAN - correct?

    Have you configured and enabled OPT1?

    Depending on the NICs involved, you might need a cross over cable when you connect a PC directly to the NIC on the motherboard. A straight through cable should be suitable to connect to a switch. Did you try both a cross over cable and a straight through cable to connect to your PC? Have you tried connecting to a switch? What do the interface LEDs on both ends of the cable show?

    pfSense defaults to allowing all LAN traffic to the internet but blocking traffic from OPTx interfaces so you may need to add firewall rules to allow traffic from OPTx interfaces.

    If you want to allow WiFi clients to communicate with LAN clients you might want to bridge the WiFi interface on pfSense and the wired interface.

    Have you gone through any of the tutorials that can be found by following the link on the documentation page which can be reached from the pfSense home page (http://www.pfsense.org

    I recommend you make the pfSense LAN interface a wired interface since they tend to be more reliable than wireless so should give you better access to the pfSense management and configuration tools.



  • Here is my basic setup.
    What I am trying to figure out is how to use both WAN and LAN port on the router.
    I like to know how can I configure my setup so that I can use the WAN port to connect to my modem and use the LAN port to connect to a switch or pc directly using DHCP.
    Meantime, the OPT1 interface should act as an AP, just like consumer grade routers.

    Interface:

    WAN: DHCP
    LAN: Bridge with WAN
    IP 192.168.2.3/24
    OPT1wireless: DHCP
    Bridge with LAN
    802.11b
    Access point
    Firewall:
    NAT – Outbound
    Automatic
    Rules:
    LAN: * LANnet * * * *
    OPT1: * * * * * * *



  • Your LAN shouldn't be bridged with WAN. (But that may not be your only problem.)

    Your physical setup is very similar to mine.

    Have you been able to access the pfSense web GUI? If so, I suggest you enable DHCP server on the LAN interface and (if you have a switch) connect a switch to the LAN interface then plug a client computer in the switch and configure the client computer to get IP address by DHCP. After restarting the client computer it should have an IP address and a default route to 192.168.2.3



  • @wallabybob:

    Your LAN shouldn't be bridged with WAN. (But that may not be your only problem.)

    Your physical setup is very similar to mine.

    Have you been able to access the pfSense web GUI? If so, I suggest you enable DHCP server on the LAN interface and (if you have a switch) connect a switch to the LAN interface then plug a client computer in the switch and configure the client computer to get IP address by DHCP. After restarting the client computer it should have an IP address and a default route to 192.168.2.3

    Thanks, you put me in the right direction.
    Everything works as expected. Now I will tweak with Rules for better protection.


Locked