2.0 Beta и Squid



  • Вопрос такой: Стояло 1.3, pppoe server авторизация пользователей собственно по pppoe.
    Работал squid+squidquard+lightsquid, все было идеально, поставил 2.0 из-за того, что в 1.3 не работали совместно pppoe и pptp, т.е при включении pptp сервера сразу гасился pppoe, установил 2.0, установил все пакаджи, перенес настройки с 1.3 (кстати перенеслись через сохранение и загрузку настроек из меню) теперь squid работает (процесс запущен) но траффик через него не идет (настройки все сверил и сквида и фаервола - все один в один) Lightsquid показывает ошибку: LigthSquid diagnostic.
    Error : report folder '/var/lightsquid/report' not contain any valid data! Please run lightparser.pl (and check 'report' folder content)
    Please check config file !
    Как исправить, или может это косяк 2.0?



  • подробнее, как настроен squid?
    и где-то тут была табличка, в которой отображена готовность пакажей в 2.0. Кажется squid еще не готов.



  • Экспорт конфига подойдет? Или скриншоты настроек?
    И где эта табличка готовности пакаджей?



  • Нашел таблицу пакаджей в 2.0
    Написано, что squid рабочий с пометкой: "Still has some minor bugs, but it installs, runs, caches, etc."



  • Squid работает, если в браузере прописать прокси. В предыдущей версии pppoe пользователи автоматом заворачивались на squid. Может кто подскажет, какое правило нужно прописать, чтобы их на squid завернуть?



  • У кого-нибудь работает squid на 2.0 beta?
    В 1.2 все прекрасно работало и squid и squidguard и при установке сквида весь 80 порт автоматом на сквид шел, если его сделать прозрачным.
    А 2.0 как будто в упор сквида не видит. Весь трафик идет помимо него. Если у клиента прописать в браузере прокси, то траффик нормально через сквид идет, т.е. сквид рабочий, только осталось траффик на него завернуть.



  • u menya rabotaet v light squid nastroykax nado najat na knopochki update now i full update posle etogo pokajet



  • da k stati a kak proveril rabotaet skvid ili net???
    nado v rula zapreshchat vsyo iz lana i poprobovat



  • Лайтсквид работает. Попробовал у себя прописать прокси в настройках браузера. Лайтсквид меня показывает в отчетах.
    Хотя мой адрес не входит в доверенные подсети в сквиде. А если выключить прокси в бразере, то весь траффик идет напрямую.



  • bros syuda screenshot nastroek skvida i ruli  dlya LAN



  • Народ! может сначала смотрим сюда:
    http://spreadsheets.google.com/pub?key=tFSe4gIfr3P0Nr1uYLxCHdw&single=true&gid=0&output=html
    а потом вопросы "работает-не работает"
    сам жду - squid+guardsquid+Lightsquid  :)



  • @NegoroX:

    Народ! может сначала смотрим сюда:
    http://spreadsheets.google.com/pub?key=tFSe4gIfr3P0Nr1uYLxCHdw&single=true&gid=0&output=html
    а потом вопросы "работает-не работает"
    сам жду - squid+guardsquid+Lightsquid  :)

    хорошая табличка, может стоит её поднять в шапку? (вопрос к модерам)



  • Наверно придется ждать финала, тогда все будет работать. Или какое-нибудь хитрое правило в файерволе.
    Вот мои настройки файервола
    Пользователи авторизуются через pppoe.
    В алиасах ip (присваиваются каждому пользователю жестко) в шедулах время их работы.
    Повторяю, при тех же настройках фаерволла и сквида (все сверял один в один) на 1.2.3 все работало замечательно: сквид, сквидгуард и лайт
    Перешел на 2.0 только из-за того, что на 1.2.3 не работало вместе pppoe и pptp. Если включаешь pptp, то сразу гасится pppoe. На 2.0 тоже не все гладко - при включении pptp тоже перестает работать pppoe, но если зайти в его настройки и тупо нажать save, то pppoe включается и все работает нармально.




  • В основной ветке пишут, что надо добавить правило NAT port forward
    @MrHorizontal:

    Yeah I encountered this problem too. You basically need to tell pfSense to set an introspective NAT rule to forward traffic to squid:

    1. Go to Firewall -> NAT
    2. Click + to add a Port Forward rule
    3. Change Interface to the Interface that squid is listening on (ie your LAN)
    3. Set Protocol to TCP
    4. Set Source to the subnet of the interface you set in 2.
    5. Under Destination, Check the NOT box
    6. Under Destination select the interface address
    NB: This is important to avoid a potential forwarding loop and to ensure clients can connect to squid's socket legitimately too
    7. Set port range to HTTP - HTTP
    8. Set Redirect target IP to 127.0.0.1
    9. Set Redirect target port to HTTP
    10. Set Filter Rule Association to None (no need to set a FW rule since it should allow traffic from LAN->WAN anyway)
    11. Press Save and Apply

    Repeat for any other interfaces and / or protocols you are proxying (ie SSL or FTP)

    This forces pf to forward all HTTP traffic to localhost:80, which is what squid's tranny is listening on…

    Добавляю правило - все равно клиенты ходят без прокси.
    Прокси работает, т.к. при прописывании в браузере вручную прокси, все работает и в отчетах это видно.



  • Надо создавать правило не по 80 порту а по any, тогда работает


Log in to reply