Moving pfsense FROM vmware to physical (v2p), how?



  • I'm contemplating moving my pfsense to it's own VIA board, instead of it running on my vmware.
    But how do I do that?
    I've got quite a few packages installed:
    squid
    squidguard
    lightsquid
    imspector
    Dashboard
    Fit123
    anyterm
    Freeswitch

    I could uninstall most of these, to make to transition easier, but the three packages
    squid
    squidguard
    freeswitch

    have a lot of configurations in them, so I'm a bit worried on the transition.

    I've tried doing a 'save all config', and then load it up on the physical machine, but I didn't get anything working out of it.
    I copied the /usr/local/conf/freeswitch folder to the new server, but it didn't help.

    Then I thought about using clonezilla, but it wouldn't see my via IDE controller, so no HDA available it said.

    So what to do?


  • Rebel Alliance Developer Netgate

    The backup/restore of the config should get everything for the OS, and also for most packages, except freeswitch (I think). There is a backup package from the freeswitch author that I thought he had instructions somewhere for using to backup and restore freeswitch.



  • Just loading the config on a bare pfsense 1.2.3 didn't work, it failed on syncing the packages.
    It starts with trying to configure pubkey, then imspector, then lightsquid, nad finally it fails on squid and squidguard, as well as freeswitch.
    So instead I installed a new 1.2.3, installed the above packages before reloading the config, then reloaded the config, let it syncronize the packages.
    Last step was to stop freeswitch, rename the old /usr/local/freeswitch/conf folder, and copy the folder from the old pfsense into the server.

    That worked, it seems to be running fine now.


  • Rebel Alliance Developer Netgate

    If you can try that again and get the exact error messages that fail on package restore, we can try to fix it. It should be working without having to reinstall the packages manually.



  • Does it log the startup somewhere, the error code scrolls very quickly out of the screen?


Log in to reply