Still can't get bridged AG card to act like a WAP.



  • Hello All,

    I did read: http://forum.pfsense.org/index.php/topic,13351.0.html and when back about 4 years of posts in the wireless and DHCP forums.

    Have a Seokrin with a Atheros ABG card in it.

    I am trying to set up the router to treat the wireless like another wire port, connection, gives a DHCP checked up IP.

    Currently set up and working:
    Port 0: WAN.
    Port 1: Lan.
    Wireless card is showing and configurable and my laptops and devices see it, they just can't get an IP assigned (alway limited internet).

    Has anyone gotten this configuration working?

    I currently have the card set up as a bridged access point linked to the LAN.

    I tried setting up firewall rules 67 and 68, still no joy.

    Any ideas?



  • To start: dont bridge the WLAN to LAN.
    Give the WLAN its own subnet and configure its
    own DHCP server.
    Then create a rule on WLAN to allowing everything from everywhere.



  • First, Thank you GruensFroeschli for the advice!

    Second, I am not sure what you mean…

    My WAN is Port 0 and is the traffic from my ISP.

    My LAN is my home network.

    I have another "port" set up called WiFi which is the Atheros ABG card I installed in my mini-bsd router.

    I have the Wifi bridged with my LAN, thinking that would allow wireless devices to get DHCP addresses from teh LAN pool.

    Now how should I set up my network so my WiFI can join my LAN?

    Thanks for your time and patience everyone!



  • Ok I think I am making progress, I am not sure if my issues are with the interface having bugs or something I am doing…

    Ok, I have in interfaces, I have WiFi.

    I have that set to a Access Point with the IP of 192.168.5.0 and the gateway set to 192.168.5.1.

    I have a rule that any  can go to any destination in Rules.

    I can now ping and get to the router and get IP addresses for google and such but I can't ping or get to the internet.

    What do I need to do now?

    Thanks again!



  • Ok, GOT IT!, don't put anything in gateway in the WiFi area.

    Now a couple clean up questions:

    1. I can't get infrastructure to work, I can only get it working in AP (I know any port in a storm but still curious), if I set to infrastructure, the card stops transmitting till I set it back.

    2.  Ok, now with any able to get to any in both LAN and WLAN, It seems insecure, any suggestions how to lock it down better?

    Thanks,



  • Infrastructur = pfSense connects as a client to an existing WLAN infrastructure.
    Access Point = pfSense acts as an access point.

    You can only bridge if the wlan interface is in AP mode.

    If you put something into the gateway field, the interface is considered as an additional WAN. (for multiWAN setups).

    Security is subjective.
    What do you want?



  • I believe he's talking either WEP or WPA. For some reason. I've got everything setup and with no security enabled I am able to get wireless clients on the internet. But when i enable either WEP or WPA, with proper keys, I can't get clients to connect at all. They see it but fail to join, some won't even prompt for keys and some fail after trying to pass the keys to the AP.

    Still trying to Trial & Error my way through this. And have read back through a few years of posts without much help. Although The trials here closely mirror my own when setting this up.



  • Tell us about your clients. I'm aware of a couple of quirky issues with wireless encryption with my pfSense acting as an access point

    1). A Windows Vista laptop that suddenly stopped seeing DHCP responses. It needed a registry tweak to get it working again. I can't say for certain but my guess is that an automatic Windows Update broke something. A tcpdump on pfSense showed the DHCP requests from the windows client (suggesting the encryption wasn't the problem) but there was no sign the client was acting on the DHCP response I could see in the trace.

    1. A netbook running gOs (based on Ubuntu 8.04) worked fine with WAP2 encryption and pfSense WPA Pairwise set to Both. The netbook was upgraded to Ubuntu Netbook 10.04 and the WAP2 encrypted wireless link wouldn't come up using the internal VIA WiFi adapter. The WAP2 encrypted wireless link came up when I plugged in a Ralink based USB WiFi adapter. I changed the pfSense AP WPA Pairwise setting to AES and the internal WiFi adapter worked fine on the encrypted link.

Log in to reply