Hyper-V pfsense No Network Interface Found



  • Hi all,

    I'm trying a new setup of pfsense in Hyper-V.  I see other people have done it with success so know its possible.  My problem is pfsense won't detect any network interfaces upon boot.  I am running Windows 2008 R2 Database which is up do date.  Hyper-V has 2 virtual interfaces pointed to separate NIC interfaces.  I have tried installing the latest version pfsense 2.0 and 1.2.3.  Neither one will detect the virtual network interfaces.  I have another VM running windows 7 which detects and utilizes the virtual network interfaces just fine.  I don't think it should matter however, the NICS are Yukon Marvel  88E8056 and Yukon Marvel 88E8001/8003/8010.

    Any help would be greatly appreciated,
    -V



  • I had the same problem. Did you add Network Adaptors to the VM? When I first tried to install I had network adaptors added to the virtual machine, and it didnt find any interfaces. Once I changed it for legacy network adaptors it did find interfaces.

    cheers,
    Idle



  • Now I feel really dumb.  I just installed Linux and got that right.  That was the problem.  Some times the answer is staring you square in the face and you don't see it.

    Thanks for the help, you rock!
    -V


Log in to reply