Connection problem



  • Hi all,

    I copied the setup guide from the top of this section about setting up a Road warrior laptop. for some reason it wont connect. OpenVPN shows the following:

    Wed Aug 04 14:42:08 2010 OpenVPN 2.1.1 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Dec 11 2009
    Wed Aug 04 14:42:08 2010 NOTE: OpenVPN 2.1 requires '–script-security 2' or higher to call user-defined scripts or executables
    Wed Aug 04 14:42:08 2010 LZO compression initialized
    Wed Aug 04 14:42:08 2010 Control Channel MTU parms [ L:1542 D:138 EF:38 EB:0 ET:0 EL:0 ]
    Wed Aug 04 14:42:08 2010 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
    Wed Aug 04 14:42:08 2010 Local Options hash (VER=V4): '41690919'
    Wed Aug 04 14:42:08 2010 Expected Remote Options hash (VER=V4): '530fdded'
    Wed Aug 04 14:42:08 2010 Socket Buffers: R=[8192->8192] S=[8192->8192]
    Wed Aug 04 14:42:08 2010 UDPv4 link local: [undef]
    Wed Aug 04 14:42:08 2010 UDPv4 link remote: 19X.9X.22X.1X:1194
    Wed Aug 04 14:42:08 2010 TLS: Initial packet from 19X.9X.22X.1X:1194, sid=609c8efe d4a90975
    Wed Aug 04 14:42:09 2010 VERIFY OK: depth=1, /C=UK/ST=NA/L=XXXXX/O=XXXXXX/CN=pfsense-ca/emailAddress=user@domain.com
    Wed Aug 04 14:42:09 2010 VERIFY OK: nsCertType=SERVER
    Wed Aug 04 14:42:09 2010 VERIFY OK: depth=0, /C=UK/ST=NA/O=XXXXX/CN=server/emailAddress=user@domain.com

    It gets that far then stays on status as connecting.  ???

    Any ideas?

    Thanks in advance.



  • Hi,

    no matter about this, i found an entry in the logs for openVPN saying 'VERIFY ERROR: depth=1, error=certificate is not yet valid:' and it turned out to be an invalid time setting.

    Thanks


Log in to reply