Jetway Triple GIGA LAN Add-on Board (AD3RTLANG)



  • I've recently aquired rackmount systems setup with a Jetway motherboard. The motherboard has the new Via C7 and a single onboard 10/100 ethernet port (Jetway J7F2WE1G5D).

    I also installed the Triple GIGA Lan 'add on' board. Therein lies my problem. pfSense by default does not recognise the network interfaces, showing them as unknown PCI network devices with no driver attached (in dmesg). So only the single, on-board network interface works. (And apparently something called Ethernet-over-Firewire as fwe0 …).

    This is the 'add on' board in question:
    https://linitx.com/product_info.php?cPath=12_145&products_id=1085

    According to LinITX.com, these nics are based on the Realtek RTL81108. I have no idea what this chipset is, but it seems reasonable to assume thats its a subset of the RTL8110 family.

    According to pfSense's hardware support documentation, this should be supported by the re driver:

    The re(4) driver supports RealTek RTL8139C+, RTL8169, RTL8169S and
    RTL8110S based Fast Ethernet and Gigabit Ethernet adapters

    And, well, its not working.

    I downloaded the latest FreeBSD drivers from Realtek. There is a 'downloads' page that offers the ubiquitous RTL8139 drivers, but going through the products page to the RTL8110S and clicking on the software links brings up a RTL8110S download page, where I was able to download a tar fire targeted at FreeBSD systems. I made this file available at http://www.exosecurity.com/rtl_bsd_drv_v171.tar.

    The problem with the available drivers is that they need to be compiled either as a module or statically inside the kernel. Other versions of the RL driver come at least pre-compiled as a .ko module, not this one.

    NOTE: This RL driver is different from the 'original' 8139 driver, even though it seems to be the same. It seems to support the conventional 8139 boards plus a few other chipsets. The name of the module/driver is the same as the 'original' 8139 driver.

    My question is this:

    1. How do I make this work. Do I setup a 'pfSense' development environment to compile the module?
    2. If I compile it as a module, will the Kernel load it even though there might be a different version of the RL driver directly compiled inside the current pfSense Kernel?
    3. Whatever I do to make this work, will it break when I update my pfSense installation?

    Right now I'm stuck with two non-working network daughterboards, so any help would be immensely appreciated.

    Regards,

    -G



  • Maybe worth a try: Do you have any bios settings like pnp os? If so set it to "no" so that the bios assigns ressources to the cards and initializes them.



  • Ya, I thought of that but its a Phoenix AWARD Bios and this one, for some reason, doesn't offer that option. The IRC interrupts can be set to PCI Device (which is what they are set to) or Reserved, from the PnP/PCI Configuration, thats about it …  :-\

    Any other ideas?

    Thanks -

    G



  • I'm checking with Jetway about this.

    I've asked them to confirm which driver supports the board.

    Nick.



  • Thanks! that is extremely appreciated. I really don't know what to do.

    -G



  • Update:

    I've done my own parallel inquiry with Jetway and they directed me to the driver download page where I had already downloaded the RTL8110S driver.

    Could it be that this driver is more recent than pfSense's built-in re(4) and that would fix the problem?

    If so, what are my options? Are there any docs about compiling your own drivers for pfSense?

    -G



  • pfsense = freebsd 6.1
    so if you find a doc with google for compiling drivers under freebsd 6.1
    then it will work with pfsense



  • It works!

    I installed FreeBSD 6.1 in VirtualPC (I know I know … its just been lying there) and chose the 'Developper' setup. Then I downloaded the driver I was referred to (the RL driver) and half-followed the instructions in order to get me a nice if_rl.ko file.

    Since I found the process painful and time consuming, I've included the compiled module and objects with the original module source file, it can be downloaded at :
    http://www.exosecurity.com/rtl_bsd_drv_v171-bin.tar.gz

    Once this file in untar'ed, all you need to do is go in the rl folder in the archive, copy the if_rl.ko file to /boot/modules or /boot/kernel and add/modify the if_rl entry in /boot/defaults/loader.conf (so that it reads YES). Alternatively, once the module is copied in the right folder you can test it by loading it manually:

    pf# kldload if_rl.ko

    Hope this helps someone.

    -G





  • It looks to me like this is the same driver that comes with FreeBSD 6.x but just hasn't made it into the mainline release's yet. It doesn't look like this is in 6.2, but maybe 6.3?

    I suppose poking the freebsd dev's on the dev mailing list might be in order just to make sure this makes 6.3.

    Btw, nice work figuring this out, I just ordered one of these from LogicSupply.

    Phylon 7F2WE-1G5 Mini-ITX mainboard 1.5 GHz

    Phylon 3x 1Gb LAN module
    [AD3RTLANG]

    It has a RTL8110S-32 set of chips, which according to the 6.2 HW Release Notes 'IS' supported by FreeBSD's built in RE driver.

    I'm guessing that the Phylon 3x 10/100 LAN module [AD3RTLANP] with the RTL8100C chips is already supported in FreeBSD 6.1 as it's a bit older chip.

    I'll let you know how things turn out. I may try a full FreeBSD install of 6.2 if pfsense doesn't support it out of the box to see if 6.2 already supports it.

    I'm considering building a whole bucketload of 1U boxes with these running on compact flash cards for inter-office networking / vpn.

    P.S. the Phylon/Jetway boards appear to be basically identical, they're just OEM'd boards and the name varies by country/region.



  • P.S. Rumor has it that Sullrich has a new snapshot as of 12-04-06 with a FreeBSD 6.2 build. I'm going to test this on a Phylon 7F2WE-1G5 with the 3 port gigabit module and report back.





  • Snapshot 12-08-06 with FreeBSD 6.2 works 'out of the box' on the board I have with the 3x1000BT addon card. My configuration is a 1.5 GHz VIA C7 Processor, with 1024 MB of DDR2 533 Kingston Ram, with a 1GB Kingston Elite Pro 50x compact flash card, on a Travla C137B with a 120W power supply. I also have 2 1000BT Intel Nic's as backup in the rig.

    I hammered the hardware all night with about 20k connections per second and full throughput and didn't experience any problems on the realtek nic's. Apparently Realtek got the updates into FreeBSD 6.2.

    Anyways, for those that care, the Phylon 7F2WE-1G5 Mini-ITX Mainboard with Fan 7F2WE‑1G5 and the Phylon 3x 1Gb LAN module [AD3RTLANG] Add-on module for the Phylon 7F2WE series mainboards, works out of the box with Snapshot 12-08-06.

    Thanks Sullrich for your constant dedication to the project.

    Well, time to go build a few production scale boxes in 1U travla rackmounts….



  • Yay!  Glad to hear its working.



  • Thank you gbelanger! Providing the compiled driver really made my day and saved me a lot of work!
    Using your precompiled driver worked like a charm on my new Jetway Board.



  • SatireWolf -

    Does your card still work with the latest snapshots?

    I have a Jetway board with the AD3RTLANG daughterboard, and the only way I can get it working is manually installing the driver still - 6.2 snapshots don't seem to work for me.



  • I'm a Jetway reseller in Canada and find out that there is at least two AD3RTLANG board using different Realtek chip.  1.0.1 release works fine with the first gen RTL8110S-32 and not the RTL8110SC

    Martin



  • I haven't had a chance to test with the january era snapshots but I will.

    I have a cloned system setup in a Travla 1U rackmount with the exact same hardware that I'm building. I'll let you know if the latest snapshots are working.



  • I haven't followed up much, sorry.

    My 'manually' compiled driver still does the job just fine here. I too am making 1U's with travla boxes, except I use the C146 case. Its bigger but it looks alot meaner. I also like the spring-loaded ComptactFlash reader in the front.

    Note that the JetWay boards are different from the Via boards and that the C146 doesnt come with the right IOShield to accomodate the triple-lan daughterboard. My distributor has overcome this issue by having custom IOShields engineered. If anybody needs some, I can put you in contact.



  • Who is your distributor for this stuff?  I've been looking for custom I/O shields for the Travla cases.  Thanks!

    Chad



  • Hi All,

    So is anyone having any luck with these boards?  I eventually compiled the 172 rev of the rtl driver with version 1.0.1 and things almost work correctly.  The current problem is that the NIC isn't properly configured no a cold boot (warm boots seem to work OK).

    If anyone has gotten this to reliability work with either the 172 or 171 driver can you please reply with how?

    I'm wondering if there has been a new rev out that causes these problems, so again if anyone has this working could run a pciconf -l -v and output the results it'd be appreciated.

    rl0@pci0:9:0:   class=0x020000 card=0x10ec16f3 chip=0x816910ec rev=0x10 hdr=0x00
        class    = network
        subclass = ethernet
    rl1@pci0:11:0:  class=0x020000 card=0x10ec16f3 chip=0x816910ec rev=0x10 hdr=0x00
        class    = network
        subclass = ethernet
    rl2@pci0:12:0:  class=0x020000 card=0x10ec16f3 chip=0x816910ec rev=0x10 hdr=0x00
        class    = network
        subclass = ethernet
    
    


  • Replying to myself, in case anyone else has the same issue.

    After posting a bug report to the freebsd list, I received a patch for the 6.2 rev of the driver.  I was able to compile a pfsense kernel with this change in place and all is good.

    In case anyone wants a copy of this please let me know.



  • Has anyone checked which throughput is possible with this board between two gigabit ports (lan to lan traffic)?



  • paulpthcom: I am interested in getting a copy of that kernel. I've also had the same problems with warm/cold boots and the interfaces not coming up. Thanks!  ;D

    fwuser07: Sustained 'near' 100mbit traffic has not been a problem with these addon boards. Unfortunately, I don't have any other gigabit devices handy to check gig throughput..  :(

    –Tim



  • Just upgraded to 1.2-BETA2 today, still no support for the daughterboard with the RTL8110SC chip.  Working fine with the RTL8110S-32

    Will try gbelanger module tonight.

    Martin



  • Any follow up on the current state of these drivers ?

    Be good to be able to keep up to date info on our product pages,

    Nick.



  • Any Update to this?
    Anyone get the SC version working on a new snapshot?

    Looking into getting a M300-LCD with a tripple gigabit card but want to make sure it will work first…



  • Anyone test with 1.2 release? Did support get added? I'm looking at a new hardware buy and the jeyways price is hard to beat. 1.0.1 was fine.



  • Hello,

    The Jetway-board that I am using is called J7F2EDEN12G and the J2AD3RTLANG I am using unfortunately has the 8110SC-chipset.
    I was able to run 1.01 just fine using the driver provided  in this thread. Thanks again for that!
    The only thing I could not use was the traffic shaper because altq is not supported by this rl-driver.
    Hence my desire to upgrade to 1.2, hoping that the re-driver would support that.
    However, my upgrade to 1.2 was not that succesful and now I am back to my old configuration.

    After installing 1.2 I saw pfsense being stuck "starting" the NICs  during booting the system. The system would not finish booting.
    I somehow managed to get a running pfsense 1.2 just by trying out different NIC-combinations of the AD3RTLANG to be LAN/WAN at setup.
    The system then worked fine just once but when I changed my NIC-configuration back to my original plans the system would be stuck at bootup again.
    Really annoying and not an acceptable solution.

    User paulpthcom from some posts above has probably posted this one here:
    http://lists.freebsd.org/pipermail/freebsd-bugs/2007-March/023060.html
    I think my problem looks quite like that.

    My pciconf-output:

    
    # pciconf -l -v
    rl0@pci0:9:0:   class=0x020000 card=0x10ec16f3 chip=0x816710ec rev=0x10 hdr=0x00
        class    = network
        subclass = ethernet
    rl1@pci0:11:0:  class=0x020000 card=0x10ec16f3 chip=0x816710ec rev=0x10 hdr=0x00
        class    = network
        subclass = ethernet
    rl2@pci0:12:0:  class=0x020000 card=0x10ec16f3 chip=0x816710ec rev=0x10 hdr=0x00
        class    = network
        subclass = ethernet
    
    vr0@pci0:18:0:  class=0x020000 card=0x01021106 chip=0x30651106 rev=0x78 hdr=0x00
        class    = network
        subclass = ethernet
    
    

    My 2 cents here: If Jetway only built a daughterboard with some quality NICs, this Realtek-stuff has never been decent (performancewise). I'd be willing to pay two/three (ok, preferrably two times) times the price for the AD3RTLANG.

    But, anyway, that has been my experience with the new 1.2 so far. I would love to actually use it but I guess so far I am stuck with 1.01. :-(



  • @PreLo:

    After installing 1.2 I saw pfsense being stuck "starting" the NICs  during booting the system. The system would not finish booting.

    It'll hang on any interface without a link.  You can even jumper two empty interfaces together and it'll boot.  But you might just want to unassign the interfaces if you're not using them.

    I posted about this a while back, and was encouraged to hack on the driver, but I'm waiting on 1.3 to do that so we're synched with current FreeBSD development.



  • Thanks, that is interesting information.
    I hope that I can find the time to give it a try next weekend.
    I'll post here about my results.



  • I'm experiencing the same issues. Can anyone confirm that is is limited to the gigabit addon nic only and not the 10/100 nic? I've had to regress back to 1.0.1 for my jetway installations since all of my addon boards are gigabit…  :(

    Edit: I just found a patch that is supposed to fix this issue. Since I do not have a proper pfSense dev environment, can anyone patch the kernel and provide the kernel.gz? It would be most appreciated. Also, is it possible to have this patch (assuming it works) included in the next pfSense update?

    Patch link: http://lists.freebsd.org/pipermail/freebsd-bugs/2007-March/023075.html

    Edit 2: The latest monowall 1.3b11 works perfectly on this board. Any chance of having that functionality ported down to pfSense soon?!?

    –Tim



  • @bill_mcgonigle:

    I posted about this a while back, and was encouraged to hack on the driver, but I'm waiting on 1.3 to do that so we're synched with current FreeBSD development.

    There's no need to wait for pfSense 1.3. pfSense 1.2.1 is under development, for release by the end of this month (May). It's based on FreeBSD 6.3-RELEASE, which has much more modern hardware support compared to the 6.2-RELEASE behind pfSense 1.2.

    FreeBSD 6.2-RELEASE becomes end of life at the end of the month - hence the need for pfSense 1.2.1. There's no new features - just a shift in the base operating system and a few bug fixes.



  • Following up on this, our systems that were based on the Jetway boards + Triple Gig cards all crashed, one of them had to be replaced (motherboard) the other one had to be refitted with PCI cards, as the daughterboard was misbehaving.

    I would not advise to go that route for those of you who want a stable setup. A via board + a multi-lan PCI might be a safer bet.

    Alternatively, there are commercial manufacturers that offer all-in-one security appliance based on VIA or Intel platforms with multi-nics (and all the nice dels to go with them). These solutions have been (in my experience) very stable.

    Just my 2cents.

    Guillaume



  • That has been our eventual conclusion as well. The functionality (supposed) and price point make the via boards with addon modules very attractive. But, they just don't work properly. If/when the driver issue gets sorted out, I'd be willing to look at them in the future. But, for right now, we're sticking 100% with Intel based boards. They just work with no fuss or problems.

    –Tim



  • Looks interesting.


Log in to reply