Compatibilidad de Pfsense con tarjetas de red especiales



  • Saludos

    Tengo en mis manos la siguiente poderosa tarjeta de red:

    http://www.shopping.com/xPO-Alacritech-D…aturesArea

    La gracia de esta tarjeta es que tiene 2 puertos de 1Gbps, y no se si será compatible 100% con Pfsense, es decir, aprovechar los 2 puertos. Es que el empaque me da miedo, puesto que dice "para usar sus máximas capacidades", usar el CD de instalación", y donde sale la disponibilidad, sólo salen distintas versiones de Windows, lo cual fastidia mucho. ¿Hasta cuándo con eso de hacer tecnología pensada en Windows y no hacerla standard?



  • Este tema se ha hablado muchísimas veces…

    1. Muchos fabricantes sólo producen para Windows.
    2. Windows tiene los drivers "fuera" de su núcleo. Esto es una ventaja para reconocer nuevo hardware pero a veces también es un problema para la estabilidad del sistema.
    3. Linux y UNIX tienen los drivers "dentro" de su núcleo (kernel). Más estabilidad y no se requieren drivers "de fuera".
    4. pfSense es un FreeBSD tuneado (BSD son los UNIX libres).
    5. Para que un hard funcione con pfSense 1.2.3 tiene que ser compatible con FreeBSD 7.2.
    6. Lista de hardware compatible, http://forum.pfsense.org/index.php/topic,23409.0.html

    Las tarjetas que dices parecen no fabricarse ya, http://www.alacritech.com/Support/Documents/ProductIdMap.aspx y el fabicante parece que sólo da soporte para Windows. Esto no quiere decir que no funcionen. Habría que probarlas.

    Los fabricantes de hard van muy deprisa cambiando cosas en los chips y a veces hay problemas de reconocimiento de hardware cuando se emplea Linux o UNIX por este motivo. En estos casos sólo hay dos soluciones:

    A. Asegurarse al adquirir el hard que funcionará con la distribución/kernel empleados.
    B. Modificar las fuentes del kernel y recompilarlo. En este caso, como pfSense es un FreeBSD tuneado esto puede ser complicado.


Log in to reply