Configurar 1 lan y 1 Wireles



  • Buenas soy nuevo en PF pero venia usando monowall asi que algo de idea tengo!..
    Mipregunta es la siguiente, tengo un mother al cual le quiero poner un PF con solo 2 NICs uno Wireless (atheros) y el otro onboard del mother (sis900), si hago la instalacion y todo me reconoce las dos placas pero no puedo encontrar la forma de hacer funcionar la wireless Como "lan" y la "sis0" como wan (pppoe), intente poniendo como lan la SIS0 pero no puedo sacar la Wireless de WAN.. Alguna Ayuda seria buena..
    Saludos Nicolas



  • Es extraño, con la configuracion que indicas te deberia funcionar, debes dejar como WAN a la sis porque hay tendras el PPOE en donde conectaras tu modem, y la tarjeta wireles deberia ser tu LAN. verifica bien tu configuracion.-



  • HAciendo una instalacion nueva he podido dejar la sis0 como lan y la ath0 como wan, luego cambio esta configuracion y alfin puedo ver las opciones de la Wireless pero la configuro pongo todos lo parametros y luego escaneo con otra wireless(mi RT2500) y nunca puedo ver al PFsense!.. muy extraño
    Gracias por la pronta respuesta!
    Saludos



  • Profin pude hacerlo andar!!
    Tuve que poner la SIS0 como lan y terminar de configurar la Wireless por linea de comandos!!..
    Hasta ahora todo va de pelos!!!..
    Saludos!



  • Perfecto, gracias por comentar tus resultados, asi nos ayudas a otros que podemos tener el mismo problema.-



  • @hagar83:

    Profin pude hacerlo andar!!
    Tuve que poner la SIS0 como lan y terminar de configurar la Wireless por linea de comandos!!..
    Hasta ahora todo va de pelos!!!..
    Saludos!

    Tipico de las atheros. Creo que en la proxima version ya se podrá seleccionar el conector al que tenemos conectada la antena. Hasta entonces hay que ponerlo a mano desde consola (o desde diagnostics - command). en mi caso hago lo siguiente:
    sysctl -a ## Aquí compruebo la configuracion de las atheros, en la sección dev.ath.0.loquesea
    sysctl dev.ath.0.txantenna=1 ##
    sysctl dev.ath.0.rxantenna=1 ## con estos dos comandos le digo por que conector tiene que emitir y recibir la antena. Si tenemos un solo conector está claro que en los dos casos tenemos que poner lo mismo. El manual de madwifi dice que el conector de antena 0 es la derecha, el 1 la izquierda y el 2 para utilizar los dos conectores a la vez. Aunque tambien es cierto que tengo una atheros que solo me funciona si tengo la tx y la rxantenna en 2(cosa rara). Solo es cuestión de probar las diferentes opciones.
    sysctl dev.ath.0.diversity=0 ## Esto se utiliza para indicar que solo tenemos una antena seleccionada.


Locked