KVM / (ACPI) Shutdown?



  • I have installed pfSense under KVM and libvirt - works well for my purposes.

    The only issue I have is with shutting down pfSense remotely/automatically:

    • ACPI shutdown (virsh shutdown pfsense) does not yield any result

    • "ssh root@pfsense.domain shutdown -h now" just gives me the pfsense terminal menu, but does not seem to execute the shutdown

    Is there any way to get a gentle shutdown working? "virsh destroy pfsense" works, but is not really nice, as it might corrupt things.

    Thanks.



  • I am having (I believe) the same issue.  Not using xen, but proxmox (running pfsense with KVM.)  I do not have the 'disable acpi' box checked for the VM.  Any thoughts?



  • Actually, I think I was having a different issue.  kvm shutdown command totally ignored.  This seems to be freebsd-related, not specifically pfsense.  More specifically, freebsd is the victim - the bug is in the seabios used by kvm.

    http://git.linuxtogo.org/?p=kevin/seabios.git;a=commit;h=50ecfa88d6a27abb873174903c9e09f989f46f1a

    So, I guess I live with it until an update/fix.  Sorry for the wasted bandwidth.


Locked