OpenVPN will not pass HTTPS traffic



  • Welcome
    I have a problem with the OpenVPN server. The configuration file is a standard. I've added only "redirect-gateway", which works, but only for http connections. When I try to access the search engine for example gmail.com tries to redirect to google.com - but the error "page can not be found." how could I pass by the squid openvpn and https traffic?

    Server:

    
    writepid /var/run/openvpn_server0.pid
    #user nobody
    #group nobody
    daemon
    keepalive 10 60
    ping-timer-rem
    persist-tun
    persist-key
    dev tun
    proto tcp-server
    cipher BF-CBC
    up /etc/rc.filter_configure
    down /etc/rc.filter_configure
    client-to-client
    server 10.10.0.0 255.255.255.0
    client-config-dir /var/etc/openvpn_csc
    push "route 10.0.0.0 255.255.255.0"
    lport 443
    push "dhcp-option DNS 10.0.0.1"
    ca /var/etc/openvpn_server0.ca
    cert /var/etc/openvpn_server0.cert
    key /var/etc/openvpn_server0.key
    dh /var/etc/openvpn_server0.dh
    comp-lzo
    push "route 10.0.2.0 255.255.255.0"
     push "redirect-gateway def1"
    
    

    Client:

    
    float
    port 443
    dev tun
    dev-node ovpn
    proto tcp-client
    remote [PFSENSE_WAN_IP] 443
    ping 10
    persist-tun
    persist-key
    tls-client
    ca ca.crt 
    cert dom.crt 
    key dom.key 
    ns-cert-type server
    comp-lzo
    pull
    verb 4
    
    

Log in to reply