T-Home Entertain VLAN 8 (Media Receiver) keine IP



  • Servus,

    folgendes Problem:

    Ich habe die pfSense Version 2.0 Beta4 und das Problem, das ich keine IP auf dem VLAN 8 (Richtung ISP) bekomme.

    Internet über VLAN 7 funktioniert wunderbar, aber das TV Bild bleibt Schwarz. Mit tcpdump sehe ich DHCP Anfragen von IF mit VLAN 8, aber halt keine Antworten…

    Irgendwo habe ich gelesen, man bräuchte unbedingt den dhcpclient3 da auch Routing Einträge per DHCP verschickt werden.

    Hat hier jemand einen Tipp für mich, wie ich ein schönes Bild auf dem Fernseher zaubern kann?

    (Falls es hilft: Modem ist der Speedport 221)

    Vielen Dank!!



  • Update: Ich bekomme jetzt eine IP zugewiesen auf dem IF mit VLAN 8. Allerdings ist das Bild immer noch schwarz… :(

    Per tcpdump sehe ich UDP Anfragen von dem Media Receiver an eine 87.x Adresse, die allerdings unbeantwortet bleiben. (Routing??)

    Firewall ist komplett offen... (zum Testen)

    Den IGMP-Proxy habe ich auch konfiguriert. Aber soweit ich weiss, laufen die ersten ~10 Sekunden als UDP Stream. Insofern müsste ich ja auch ohne Proxy zumindest diese 10 Sekunden ein Bild bekommen...

    Hat hier einer Idee??

    Danke schon einmal!



  • also ich habe etwas von DHCP V4 gelesen

    siehe hier http://de.wikipedia.org/wiki/Telekom_Entertain



  • @Beerman:

    Update: Ich bekomme jetzt eine IP zugewiesen auf dem IF mit VLAN 8. Allerdings ist das Bild immer noch schwarz… :(

    Per tcpdump sehe ich UDP Anfragen von dem Media Receiver an eine 87.x Adresse, die allerdings unbeantwortet bleiben. (Routing??)

    Firewall ist komplett offen... (zum Testen)

    Den IGMP-Proxy habe ich auch konfiguriert. Aber soweit ich weiss, laufen die ersten ~10 Sekunden als UDP Stream. Insofern müsste ich ja auch ohne Proxy zumindest diese 10 Sekunden ein Bild bekommen...

    Hallo Beerman,

    ich habe im englischen Bereich des Forums einen Artikel geschrieben, http://forum.pfsense.org/index.php/topic,29329.0.html, bin aber auch noch nicht weiter. Sobald ich dem externen Interface ein zweites virtuelles Interface mit VLAN-Tag 8 gebe habe ich keine Internet Verbindung mehr. Vlan-7 braucht man offenbar gar nicht mehr, denn ohne jegliches Vlan-Tagging habe ich zumindest Internet, aber leider kein IP-TV..

    Wie hast Du es genau gemacht, um dem WAN Interface (in Richtung Modem) das VLAN-Tag 8 zuzuweisen?

    regards.

    .olaf



  • Hallo Monkeytower,

    ich hatte die gleichen Probleme wie Du. Alles funktionierte so, wie Du es beschrieben hast.
    Diese IP Adressen für die Routen, die Du in Deinem englischen Post hast, passen nicht. Ich habe mir im Protokoll meine angesehen und die richtige gefunden. Es kommt auf den Standort in Deutschland an. Das ist von Region zu Region unterschiedlich.
    Mir scheint, dass Dein Reveiver die folgende Adresse hat: 239.35.129.11
    Schau mal bei den Interfaces nach, welche IP das VLAN8 Interface hat. Für diese Adresse musst Du bei den Firewall Rules den IGMP Traffic freigeben. Das war bei mir nötig, danach ging alles.
    Alle anderen statischen Routen, von denen zu diesem Thema in anderen Posts die Rede ist, habe ich nicht eingetragen und kann trotzdem problemlos Fernsehen. Nur der IGMP Proxy stürzt einmal am Tag nach der Zwangstrennung der Telekom ab :-(

    Gruß
    Power_Matz



  • Hallo Power_Matz,

    Fernsehen klappt nun, dank der Hinweise, jedoch komme ich (noch) nicht an die Streaming-Inhalte von Videoload und dem TV-Archiv ("Film der Woche" und so was..). Durch die entsprechenden Seiten navigieren klappt, aber auf der "letzten Webseite vor dem Ausleihen" fehlen bereits die Vorschau-Bilder.

    Da mit dem T-Online Speedport W722V am selben Anschluss alles klappt fehlt mir noch irgend etwas im pfSense. Ich vermute, dass die fehlenden Inhalte von einem anderen Server kommen, welcher (noch) geblockt wird.. Komme da aber nicht weiter.

    Wenn das Speedport Router/Modem wenigstens so was wie exposed host (manchmal fälschlicherweise als DMZ bezeichnet) können würde, dann könnte ich das ja einfach seinen Teil machen lassen und mit pfSense in Reihe zwei leben..

    .olaf


Log in to reply