Падение пропускной способности PF.



  • Добрый день.
    Случилось странное: через пару суток аптайма у pf возникает нелюбовь к скачиванию файлов. На 10Мбит канале скорость скачивания файлов не превышает 8кб/сек. После ребута всё нормализуется, до поры до времени.

    Стоят:
    Backup
    Dashboard
    Dashboard Widget HAVP Status
    HAVP (parent for Squid)
    imspector
    rate
    siproxd
    Squid
    Squidguard
    vnstat

    Ранее были установлены, а затем удалены:
    Traffic Shaper
    FreeSWITCH

    Мне кажется, что глюк начался после удаления шейпера.

    Как вылечить, куда рыть?

    Спасибо.



  • Обратите внимание на используемую память, когда начинает тормозить. Думаю какой-то процесс ее кушает.
    Можно попробовать перезапустить поочереди установленные пакеты и посмотреть после чего станет лучше (если станет).



  • Памяти на PF выделен гиг. И выше 50% индикатор утилизации не поднимается.
    При внимательном наблюдении обнаружил, что 10000 states по видимому не хватает. Второй день аптайма и сейчас показывает 6019/10000. Я понаблюдаю ещё, вдруг действительно упирается.. А где лимит поправить? Что-то с наскоку не вижу.



  • System > Advanced - Firewall Maximum States



  • @suncheez:

    Добрый день.
    Случилось странное: через пару суток аптайма у pf возникает нелюбовь к скачиванию файлов. На 10Мбит канале скорость скачивания файлов не превышает 8кб/сек. После ребута всё нормализуется, до поры до времени.

    Стоят:
    Backup
    Dashboard
    Dashboard Widget HAVP Status
    HAVP (parent for Squid)
    imspector
    rate
    siproxd
    Squid
    Squidguard
    vnstat

    Ранее были установлены, а затем удалены:
    Traffic Shaper
    FreeSWITCH

    Мне кажется, что глюк начался после удаления шейпера.

    Как вылечить, куда рыть?

    Спасибо.

    Traffic Shaper -  у меня это убивало напрочь всю производительность и пинги вместо <1мс становились до 400, при условии что ПФ воткнут в общий свич, помог бекап до установки Шейпа, приетом количество сессий вырастало до 8000, как тока отключал половину сети и сесий становилось гдето 5000 то пинги уравновешивались снова становились <1 мс, то что я устанавливал линмит на 30000 никак не повлияло, памяти ест 10% сервак с 2 гигами памяти, проц более чем на 5% еще ниразу не нагружался. сейчас вот сижу и думаю чем ето победить…



  • Кто нить сталкивался с таким еще? или токо у нас двоих такое?



  • я так и не понял - после отключения шейпера всё нормально работает или нет?



  • @MasterMad:

    Кто нить сталкивался с таким еще? или токо у нас двоих такое?

    Я сегодня столкнулся. Только у меня ситуация куда проще. Шлюз (Celeron 950, 256 Мб) обслуживает ~20 пользователей. Канал 5 Мбит/с. Одновременно 20 пользователей никогда вместе не работают. Последний раз машинка отработала без перезапуска 5 месяцев. Две недели назад пришлось загасить в виду отключения электричества. Эти две недели также отработала без проблем, на ней ничего не ставилось и ничего не делалось. А вчера и сегодня пользователи просто телефон оборвали: очень низкая скорость.
    Подключаю ноут напрямую к провайдеру: 5064/5142 Мбит/с. Подключение через шлюз (остальных пользователей) физически от шлюза убрал): 1796/2149 Мбит/с.
    Что смотреть? Куда рыть?



  • MTU?



  • @deutsche:

    MTU?

    Поле было пустым. Принудительно поставил 1500. Завтра посмотрим что народ скажет.



  • @putinka:

    @deutsche:

    MTU?

    Поле было пустым. Принудительно поставил 1500. Завтра посмотрим что народ скажет.

    Потисипидампь на WAN.



  • для pppoe надо ставить 1492



  • @Evgeny:

    я так и не понял - после отключения шейпера всё нормально работает или нет?

    Да, после отключения шейпера все в норму возврашалось.



  • @MasterMad:

    @Evgeny:

    я так и не понял - после отключения шейпера всё нормально работает или нет?

    Да, после отключения шейпера все в норму возврашалось.

    Ну значит нашэйпил что-то не то -) здесь и копать.


Log in to reply