Captive portal on 05-Nov-2010 01:07 Snapshot



  • Is anyone else having problems with people getting to their captive portal authentication page with the newest snapshot?  The bypass by mac address works fine for getting through the captive portal, but when I am not on the list, I can't see or login to the captive portal.  It times out.
    As a side note, it works fine from the early Nov. 1st snapshot.  Haven't updated since then, and have no idea at which snapshot it doesn't work.



  • built on Sat Nov 6 00:43:13 EDT 2010
    Still has problems with authentication page

    Only packages running on pfSense box is NUT
    Reinstalled from scratch, restore backup, doesn't help

    Running a snapshot from Oct. 30th works

    I have tried other copies varying from the 3rd to today's most recent snap, none work



  • built on Sun Nov 7 05:11:10 EST 2010
    Still not working

    Both my "work" and home are having the same problems with the authentication page of the captive portal not showing up.  The page times out and nothing but the error page shows up on the web browser.  Doesn't work on any browser I have tried (FF, IE8, Chrome, Opera, Android mobile).



  • built on Sun Nov 7 05:11:10 EST 2010
    Still errors out, but this time I get an error on boot

    ___
    / f
    / p _
    / Sense
    _

        _
    _/

    Welcome to pfSense 2.0-BETA4  …

    Creating symlinks....stray irq7
    .too many stray irq 7's: not logging anymore
    .done.
    appending output to nohup.out
    Launching the init system...vr0: link state changed to UP
    vr1: link state changed to UP
    vr2: link state changed to UP
    vr3: link state changed to UP
    done.
    Initializing................................ done.
    Starting device manager (devd)...done.
    Loading configuration......done.
    Updating configuration...done.
    Cleaning backup cache.................................done.
    Setting up extended sysctls...done.
    Setting timezone...done.
    Starting Secure Shell Services...done.
    Setting up polling defaults...done.
    Setting up interfaces microcode...done.
    Configuring LAGG interfaces...done.
    Configuring VLAN interfaces...done.
    Configuring QinQ interfaces...done.
    Configuring WAN interface...done.
    Configuring LAN interface...done.
    Configuring WRLS interface...done.
    Configuring DMZ interface...done.
    Syncing OpenVPN settings...tun1: changing name to 'ovpns1'
    done.
    Starting syslog...done.
    Configuring firewall......done.
    Starting PFLOG...done.
    Setting up gateway monitors...No matching processes were found
    done.
    Synchronizing user settings...done.
    Starting webConfigurator...done.
    Configuring CRON...done.
    Starting OpenNTP time client...done.
    Starting DHCP service...done.
    Starting DNS forwarder...done.
    Starting captive portal... load_dn_sched dn_sched FIFO loaded
    load_dn_sched dn_sched QFQ loaded
    load_dn_sched dn_sched RR loaded
    load_dn_sched dn_sched WF2Q+ loaded
    load_dn_sched dn_sched PRIO loaded
    done
    sysctl: unknown oid 'net.inet.ip.ipsec_in_use'
    Configuring firewall......done.
    Generating RRD graphs...done.

    Warning: include_once(/usr/local/pkg/routed/routed.inc): failed to open stream: No such file or directory in /etc/rc.bootup on line 347

    Warning: include_once(): Failed opening '/usr/local/pkg/routed/routed.inc' for inclusion (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /etc/rc.bootup on line 347

    Fatal error: Call to undefined function setup_routed() in /etc/rc.bootup on line 348
    Starting CRON... done.
    Executing rc.d items...
    Starting /usr/local/etc/rc.d/nut.sh...done.
    Bootup complete


  • Rebel Alliance Developer Netgate

    That routed error should be fixed on the next new snap, one of the other devs checked in a fix for that earlier today.



  • What about the captive portal issue of not being routed to the login page? Were they related?


  • Rebel Alliance Developer Netgate

    No, separate issue.



  • So is anyone else having problems with their captive portal users getting to their login pages?  I am assuming (which is bad to do on my behalf) that it is working for others, but I have no conformation, or denial that anyone else is/n't having problems.  All I want to know is why does my network keep having problems getting to the captive portal page after the 30th of Oct?  I didn't change a thing in my configuration but do an update, and when I roll back to the 30th everything works, but with the newest update of today, it does not.

    Could any of this be because the interface I am running it on is the same one this (http://forum.pfsense.org/index.php/topic,29871.0.html) topic outlines? I have a Soekris net5510-70 board with my interfaces as followed (vr0 WAN; vr1 LAN; vr2 WRLS; vr3 DMZ)



  • Captive portal times out on 10 nov snapshots! any body confirming this?



  • Captive portal times out on 10 nov snapshots! any body confirming this?

    I'm curious how you already got your hands on a 10 nov snapshot. ;)

    I installed the 2010-11-08 17 18:04 (i386/full) update last night and now I am no longer able to reach my CP login page.  Since it isn't fixed in tomorrow's snapshots, I'll see about checking again on Thursday.

    The other funny thing is, I initially listed my snap date as 2010-11-09 18:04 - that's also in the future.  LOL.



  • None of the new snapshots are working for me, cirkit or PJ2.  I am glad now I am having two other people confirming this problem so maybe something will get done or someone will get looked at with it being an issue.



  • failed here too.. i need to fall back to the one built on 28th Oct 2010.



  • I have had the same about 6 days ago, before i thinks it was a mistake i make (some package tray or wrong configuration ?) then i make a clean install 2 days ago : same problem : after the last update : 2.0-BETA4 (i386) - built on Tue Nov 9 22:11:55 EST 2010, with no package, the problem steel be present for me …
    I put some information on a ticket who was just open and sam's to be regarding these problem. Maybe if some one have more technical information they can be put on the opened ticket : Bug #1004 "http://redmine.pfsense.org/issues/1004"


  • Rebel Alliance Developer Netgate



  • Backing that out makes the difference on my machine.  Thanks for tracking that down!



  • I removed that commit even though i would like it that way.



  • I should note that it's the redirection to the login page that isn't working with that commit.  CP itself does still work.

    If I connect to the captive portal network and then manually goto the CP page (http://pfSenseIP:8000) I am able to authenticate and then access the internet.

    Don't know if that information helps at all.

    I also tried forcing server.bind to listen only on the CP nic.  Redirect didn't work that way either.  Setting server.bind = 0.0.0.0 does work, but that probably defeats what you were trying to accomplish.



  • I was out of town for a while so I didn't want to commit a change while not physically being near the firewall itself.  I updated to the newest snapshot [built on Sun Nov 14 17:23:12 EST 2010] and captive portal is still not having the page show.  The page still times out.
    What changes to routing might have been done from the Oct 30th snap to the Nov 1st or 2nd snap?  I have narrowed it down to those dates.

    EDIT: It's working for me too.  I loaded it up at work and it works superb, but at home it doesn't work.  Maybe the little woman unplugged something accidentally at home while I was away on business.



  • Performed the built on Sun Nov 14 17:23:12 EST 2010 update and CP is working like a charm!
    I performed some tests using my Android phone, when trying to access Google, I'm redirected to the auth page and after I authenticated, it works great!



  • Just built clean with Wed Nov 24 21:47:30 EST 2010 and redirect not working again….:(



  • I've installed the i386 update built on Thu Nov 25 17:22:40 EST 2010.  CP redirect seems to work if I don't use HTTPS, but the secure redirection just hangs.  If I click on the link to show the existing login page (on the CP configuration page) it also freezes under HTTPS, but works correctly under HTTP.


Log in to reply