[fausse alerte] Problème de DHCP Client Hostname lié à pfSense



  • hello,

    afin d'enlever la neufbox fibre optique de mon installation, je souhaiterais raccorder directement mon fw pfsense à l'arrivée optique (via un convertisseur fibre <> ethernet cu fourni par l'opérateur).
    pour ceci il faut configurer l'interface wan en dhcp et copier le nom qui est utilisé dans la demande de bail dhcp de la 9box (pas de ppp en fibre) dans le champ client dhcp hostname, mais pfsense tronque le nom au premier point.
    le nom actuel est "neufbox5_NB5-SER-r1_NB5-MAIN-R3.0.17", mais pfsense envoie en réalité "neufbox5_NB5-SER-r1_NB5-MAIN-R3". l'ajout de "", "/", "." devant les points ne change rien.

    existe-t-il une solution de contournement?
    version : 1.2.3-RELEASE sur Alix2d3

    au passage j'ai un comportement très anormal en terme de débit, genre 80/2Mbps en mode device polling et 22/15Mbps en mode interruption sur les interfaces et des performances catastrophiques sur la beta4snapshot du 15/11 … mais c'est sans doute une autre histoire.

    merci! :)



  • apres lecture du code source au premier coup d'oeil je ne vois pas ce qui pourrait générer cela.
    A l'affichage du champs dans la page de configuratoin, la chaine est-elle tronquée?
    Dans le fichier de configuration XML, la chaine est-elle tronquée ?



  • merci juve.
    à la vue de ta réponse, j'ai quand même vérifié avec wireshark et pfsense envoie bien le nom complet avec les points. c'est la neufbox qui tronque l'affichage…
    le nom apparaît complet dans le fichier de configuration.

    fausse alerte :)

    du coup, y a t il possibilité de spécifier un vendor class identifier ou toute autre option au client dhcp de pfsense?
    self réponse : http://forum.pfsense.org/index.php/topic,21097.0.html



  • nouvelle self réponse : remplacer l'utilisation du dhcp host name en vendor id, puisque je n'utilise pas le hostname.

    editer /etc/inc/interfaces.inc
    dans la fonction "interfaces_opt_dhcp_configure", modifier comme suit la ligne avec dhcp-client-identifier:

    $dhclientconf_hostname = "send dhcp-class-identifier \"{$optcfg['dhcphostname']}\";\n";
    

Log in to reply