Alix 2D3 no arranca PFsense



  • Hola a todos!
    He montado un equipo con Alix 2D3 y una compact flash 4Gb, le he montado la imagne de nandoBSD de 4gb con physdiskwrite-0.5.2, he tenido varios problemas con la configuracion del puerto serie, primero tuve que configurar Putty con 38400 y poder entrar en la BIOS para cambiarlo a 9600, entonces me arranca bien pero se queda aqui:
    PC Engines ALIX.2 v0.99h
    640 KB Base Memory
    261120 KB Extended Memory

    01F0 Master 044A ELITE PRO CF CARD 4GB
    Phys C/H/S 7785/16/63 Log C/H/S 973/128/63

    1   FreeBSD
    2   FreeBSD

    Boot:   1

    Y nada… ni pulsando 1, ni pulsando enter, ni F1 ni nada..... alguna idea?
    Gracias!!



  • ¡Hola!

    Busca en el foro en inglés, a ver si alguien ha tenido el mismo problema con este equipo.

    Se parece al problema que hay con los FabiaTech FX5622 y que se soluciona "matando" la segunda slice de arranque de nanoBSD, http://forum.pfsense.org/index.php/topic,21194.0.html

    Si es así, la operación hay que hacerla en otra máquina capaz de arrancar…

    sysctl kern.geom.debugflags=16
    boot0cfg -v -B ad0

    http://www.freebsd.org/cgi/man.cgi?query=boot0cfg

    Nota: ad0 puede ser ad1, ad2, depende de la máquina.

    Saludos,

    Josep Pujadas



  • Hola Josep, gracias,
    Pues no se llevo toda la mañana buscando y… o no me entero o no lo encuentro,
    La versión NanoBSD debería arrancar desde un PC con una CF a IDE ? ...porque no me arranca... o tiene que ser una versión normal?
    Salu2



  • ¡Hola!

    En un PC normal con lector de CF puede que arranque o no. Depende del lector y de la BIOS. Tiene que ver la CF como un disco IDE más…

    ¡Suerte!

    Josep Pujadas



  • Si , la BIOS me lo reconoce, ningun problema, es como  un disco mas, pero con la imagen de NanoBSD no hace nada, si instalo la version normal sobre la CF arranca sin problemas, a eso me referia…
    Queria arrancar desde la CF con la version Nano para poder ejecutar esos comandos, puedo hacer algo conectando la CF a un sistema linux???
    Gracias de nuevo!



  • bueno…. ahora si que no entiendo nada....
    he vuelto a empezar de nuevo..... con physdiskwrite -u desde windows con un adaptador IDE->CF, he reiniciado el PC por si arrancaba desde el PC, lo he probado en la placa Alix y.... PREMIO!!!!... a la primera y sin complicaciones....
    no entiendo nada, porque sino he hecho esto como 5 veces esta mañana, no lo he hecho ninguna.... en fin...es la grandeza de la informatica.... bueno ahora toca jugar un rato....
    Muchas gracias como siempre Josep.
    Un saludo



  • ¡Hola de nuevo!

    Prueba a arrancar el PC normal con lector de CF mediante de CD Live de FreeBSD 7.2:

    ftp://ftp.freebsd.org/pub/FreeBSD/releases/i386/ISO-IMAGES/7.2/

    Creo que la imagen del Live es 7.2-RELEASE-i386-livefs.iso

    Una vez hayas arrancado reescribe el sector de arranque de la CF con las instrucciones:

    sysctl kern.geom.debugflags=16
    boot0cfg -v -B ad0

    Asegúrate de qué ad (ad0, ad1, ad2…) es tu CF. Puedes usar el comando:

    atacontrol list

    que te mostrará tus discos.

    ¡Suerte!

    Josep Pujadas


Log in to reply