Cryptography algorithm options missing



  • While trying to set up OpenVPN in 1.2.3 I noticed I have no cryptography options in the drop down box. I am following the "Pfsense and OpenVPN for new users" tutorial.

    Has anyone else seen this issue? I have searched all over and have not found any answers.



  • Fixed it myself. FYI for anyone else who may run into this problem with 1.2.3.

    I could not find anything that worked other than a full re-install but this ended up being a snap since the configuration backup carried over.

    With my current configuration backed up I re-installed pfSense. This time I chose the custom install dialog instead of the quick and easy setup. The dialog correctly detected that I had a dual core chip and so I enabled multiprocessor support. With the fresh install I could see the crypto options were available. I restored my original configuration and now everything is intact (or appears to be).

    I am not sure how well the quick install option handles multiple core processors. It may have been a fluke on my original install. But it works now.


  • Rebel Alliance Developer Netgate

    Quick install handles them fine. You are still prompted for the kernel on a quick install, so you can choose Symmetric Multiprocessor (SMP) and it works fine.

    As for why the crypto options were missing, it may have been a corrupt file.

    If I were you, I'd run a hard drive test to make sure the drive isn't failing.



  • Aw man, here I was all comfortable in a state of ignorant bliss and you come along talking about disk failures.  :)

    Thank you for the tip. I will give the disk a close look. I've been thinking about trying out 2.0 so this will give me an excuse.


Log in to reply