Server Configuration not being updated - 1.2.3 release

  • I can't get the OpenVPN server settings to update. First I noticed a problem with a pushed route not being added - it worked by manually adding it with the route command but both tunnelblick and openvpn2 clients fail to receive the pushed route. I thought there was an issue with just that IP address so I tried a whole bunch of different configurations but had no luck.
    Long story short: I've completely disabled the server and I can still connect to it and all of the pushed routes except the one I had trouble with before. I believe the OpenVPN server configuration is not being updated.

    Can anyone recommend a way to coax it into updating?
    Thanks in advance.

    built on Sun Dec 6 23:21:36 EST 2009

  • Rebel Alliance Developer Netgate

    You might go to Diagnostics > Command, and type: killall -9 openvpn

    Then edit and save each OpenVPN instance (clients and servers) once more.

  • Thanks jimp, I ended up restarting pfSense and the problem cleared up. I am interested in finding a way to reload the config without doing a full reboot and I'll try your suggestion if the problem pops up again.

Log in to reply