Wireless Access Point doesn't work



  • Have spent so many many hours on getting this running now, and not having any luck. Am extremely comfortable with Windows networking, but new to BSD.

    I have successfully managed to get my card showing in the interfaces tabs of the web GUI (it works using the run driver - that was highly frustrating just on its own), but i can't, despite much fettling and application of logic, get the wireless working. It's quite simply won't show up on my other machines when they search for wireless networks, as though i haven't set it up. When i have.
    I've configured it as per multiple guides on the internet - tried a few to check that it wasn't simply a duff guide (dead simple config: static IP, enabled the DHCP server for the interface in the DHCP server settings, no encryption so i can get it running easier, picked an SSID, made sure the interface is enabled and in access point mode - have also tried the other 2 modes too just in case - and made sure that the SSID isn't hidden). And it doesn't work. It exists, it's assigned, and it's set up - i can't fathom why it isn't showing up. Have restarted it etc, no effect.

    Config is:
    WAN (vr0 ethernet card, DHCP, not set up past that yet but will connect a cable modem using DHCP)
    LAN (fxp0 ethernet card, 192.168.1.1/24) - am using this to configure it.
    OPT1 (run0_wlan0 wireless USB, 192.168.0.253/24) - this is the troublesome connection.

    Anyone know what's going on?



  • Please post the output of the pfSense shell command # ifconfig -a

    I presume you are using a snapshot build of pfSense 2.0 BETA. Which build? I have been using pfSense-Full-Update-2.0-BETA4-20101127-0055.tgz and my run device works.

    You don't mention having done anything to get the run firmware loaded. (I don't recall exactly how the firmware load failure manifests and I'm not inclined to play with my system to find out.) Does the run firmware load correctly?



  • dont be fooled by the online resellers when they say the AR9220 works with PFsense as it doesn't. Before you buy an adapter check here on the forum to make sure it works, don't make the same expensive mistake I made!


  • Netgate Administrator

    How recent is the run driver in your snapshot?
    I see from the freebsd lists, here, that the driver didn't support hostap mode and I can find no mention of it being added subsequently.
    However that was over a year ago.

    Steve


Log in to reply