RRD



  • Как задать альтернативный ресурс чтоб ПФ пинговал его ?
    В Status: RRD Graphs-quality
    PF 1.2.3





  • СПС
    А если мне нада ещё и на OPT1  такую же штуку сделать ?
    ДЕлать так
    Открываем "/cf/conf/config.xml" и добавляем "<use_rrd_gateway>XXX.XXX.XXX.XXX</use_rrd_gateway>" в <interfaces><opt1>из <system>. Сохраняем. XXX.XXX.XXX.XXX - ip который собираемся пинговать.</system></opt1></interfaces>



  • Так должно выглядить модификация ?

    <pfsense><version>3.0</version>
            <lastchange><theme>nervecenter</theme>
            <system><interfaces><use_rrd_gateway>XXX.XXX.XXX.XXX</use_rrd_gateway>
                   <wan></wan></interfaces>

                    <interfaces><use_rrd_gateway>YYY.YYY.YYY.YYY</use_rrd_gateway></interfaces>
                    <optimization>normal</optimization>
                    <hostname>pfsense</hostname>
                    <domain>local</domain>
                    <username>admin</username>
                    <password>$1$ls5IBOCC$PKn4Pz6ULYNhVxP3TKJ1P1</password>
                    <timezone>Europe/Chisinau</timezone>
                    <time-update-interval><timeservers>0.pfsense.pool.ntp.org</timeservers>
                    <webgui><protocol>http</protocol>
                            <certificate><private-key><port>105</port></private-key></certificate></webgui>
                    <disablenatreflection>yes</disablenatreflection>
                    <ssh><authorizedkeys></authorizedkeys></ssh>
                    <maximumstates><shapertype><enablesshd>yes</enablesshd>
                    <dnsallowoverride></dnsallowoverride></shapertype></maximumstates></time-update-interval></system>

    или всё таки это нада делать так ?
    <interfaces><lan><if>rl1</if>
                            <ipaddr>192.168.0.1</ipaddr>
                            <subnet>24</subnet>
                            <media><mediaopt><bandwidth>100</bandwidth>
                            <bandwidthtype>Mb</bandwidthtype>
                            <bridge><disableftpproxy></disableftpproxy></bridge></mediaopt></media></lan>
                    <wan><if>vr0</if>
                            <mtu><media><mediaopt><bandwidth>100</bandwidth>
                            <bandwidthtype>Mb</bandwidthtype>
                            <spoofmac><pppoe><disableftpproxy><ipaddr>pppoe</ipaddr>
                            <use_rrd_gateway>XXX.XXX.XXX.XXX</use_rrd_gateway></disableftpproxy></pppoe></spoofmac></mediaopt></media></mtu></wan>
                    <opt1><if>rl0</if>
                            <descr>OPT1</descr>
                            <bridge><ipaddr>89.187.44.7</ipaddr>
                            <subnet>27</subnet>
                            <gateway>89.187.44.1</gateway>
                            <spoofmac>00:20:ed:69:37:ff</spoofmac>
                            <mtu><enable><disableftpproxy><use_rrd_gateway>YYY.YYY.YYY.YYY<use_rrd_gateway></use_rrd_gateway></use_rrd_gateway></disableftpproxy></enable></mtu></bridge></opt1></interfaces></lastchange></pfsense>



  • :(



  • поэкспериментируй, потом нам расскажешь.



  • 
     <pfsense><version>3.0</version>
            <lastchange><theme>nervecenter</theme>
            <system><interfaces><use_rrd_gateway>XXX.XXX.XXX.XXX</use_rrd_gateway>
                     <wan><interfaces><use_rrd_gateway>YYY.YYY.YYY.YYY</use_rrd_gateway>
                     <opt1><optimization>normal</optimization>
                    <hostname>pfsense</hostname>
                    <domain>local</domain>
                    <username>admin</username>
                    <password>$1$ls5IBOCC$PKn4Pz6ULYNhVxP3TKJ1P1</password>
                    <timezone>Europe/Chisinau</timezone>
                    <time-update-interval><timeservers>0.pfsense.pool.ntp.org</timeservers>
                    <webgui><protocol>http</protocol>
                            <certificate><private-key><port>105</port></private-key></certificate></webgui> 
                    <disablenatreflection>yes</disablenatreflection>
                    <ssh><authorizedkeys></authorizedkeys></ssh> 
                    <maximumstates><shapertype><enablesshd>yes</enablesshd>
                    <dnsallowoverride></dnsallowoverride></shapertype></maximumstates></time-update-interval></opt1></interfaces></wan></interfaces></system></lastchange></pfsense> 
    

    Этот способ провалился!
    при перезагрузке восстановился конфиг из бэкапа :(



  • хех а так заработало :)

     <interfaces><lan><if>rl1</if>
                            <ipaddr>192.168.0.1</ipaddr>
                            <subnet>24</subnet>
                            <media><mediaopt><bandwidth>100</bandwidth>
                            <bandwidthtype>Mb</bandwidthtype>
                            <bridge><disableftpproxy></disableftpproxy></bridge></mediaopt></media></lan> 
                    <wan><if>vr0</if>
                            <mtu><media><mediaopt><bandwidth>100</bandwidth>
                            <bandwidthtype>Mb</bandwidthtype>
                            <spoofmac><pppoe><disableftpproxy><ipaddr>pppoe</ipaddr>
                            <use_rrd_gateway>XXX.XXX.XXX.XXX</use_rrd_gateway></disableftpproxy></pppoe></spoofmac></mediaopt></media></mtu></wan> 
                    <opt1><if>rl0</if>
                            <descr>OPT1</descr>
                            <bridge><ipaddr>89.187.44.7</ipaddr>
                            <subnet>27</subnet>
                            <gateway>89.187.44.1</gateway>
                            <spoofmac>00:20:ed:69:37:ff</spoofmac>
                            <mtu><enable><disableftpproxy><use_rrd_gateway>YYY.YYY.YYY.YYY <use_rrd_gateway></use_rrd_gateway></use_rrd_gateway></disableftpproxy></enable></mtu></bridge></opt1></interfaces> 
    

Locked