Default Gateway …



  • Hallo,

    nach dem ich nun den ganzen Tag verbracht habe pfsense bei zu bringen normal über das default gateway zu routen, habe ich jetzt erst mal
    aufgegeben. aber vielleicht hat ja jemand von euch eine idee, würde mich sehr freuen.

    zur konfiguration. installation klappt eigendlich wunderbar ohne probleme. auch die interfaces lassen sich mit den richtigen ip's und netzmasken
    belegen. ebenfalls läst sich das default gateway setzen und auch anpingen. allerdings ist is mir auf keinster weise gelungen weiter als bis
    zum gateway zu kommen ohne eine static route z.b. zum dns-server.

    meine versuche waren die firewall erst mal ganz abzuschalten über die webgui und auch die option aufheben wo man 192er netze
    auf dem heissen interface blocken kann.

    alles ohne erfolg. wenn ich eine static route für einen x-belibigen host im internet setze kann ich die kiste dann pingen usw. aber
    das alles was nicht im localen netz ist über das gateway geroutet wird, nein das will die sense nicht.

    langsam bin ich wirklich ratlos, noch dazu wo ich freebsd und pf sowie hfsc schon seit jahren nutze aber gern auf pfsense umsteigen
    möchte weil es über das webgui einfach komfortabler ist als staendig in der pf.conf rumzuhacken.

    vielleicht leigt es ja auch daran das dass interface (WAN) mit einer echten 212.21.69.97 und netzmask 255.255.255.255 konfiguriert ist
    und pfsense nicht versteht das aber das gateway eine 192.168.23.8 ist, ist ja eigendlich eine privat network ip.

    aber pingen kann man die 192.168.23.8 dann fröhlich vor sich hin. nur danach ist nix zu erreichen, wie gesagt ohne static route …

    vielleicht hat ja jemand eine idee ...

    so lieben gruss,
    der Merl



  • Was für eine Art WAN ist das denn? Klingt irgendwie nach PPPoE, aber Du richtest das statisch ein?



  • also es ist so, dass über eine art transportnetz 192.168.23.0/24 das internet verteilt wird. auf den routern in diesem wird ein netzsegment zu mir geroutet 212.21.69.96/28 auf einer linuxbüchse oder auf meiner freebsd firewall route ich dann eigendlich nur mit 2 befehlen.

    route -net 192.168.23.0 netmask 255.255.255.0 interface eth0
    route add default gw 192.168.23.8 eth0

    das wars und schon kann ich im internet surfen. wie gesagt sinngleich auf meiner jetzigen freebsd firewall nur das da das interface rl0 heist.

    die sense konfiguriert auch das WAN korrekt, naemlich:

    rl1: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
            options=8 <vlan_mtu>inet6 fe80::210:f3ff:fe03:f66d%rl1 prefixlen 64 scopeid 0x2
            inet 212.21.69.97 netmask 0xffffffff broadcast 212.21.69.97
            ether 00:10:f3:03:f6:6d
            media: Ethernet autoselect (none)

    nun ist es so das man zwar das die 192.168.23.8 pingen kann und auch eine defaultroute vorhanden ist aber man erreicht nicht die weite welt.

    naja, das ist mein problem. abhilfe koennte ich sicher schaffen indem ich vor der sense noch eine büchse setze die dann nach extern routet und intern
    eine ip aus dem 212.21.69.96/28 netz hat.

    aber das wäre ja, naja, vor der firewall noch eine kiste nur damit die sense richtig routen kann.
    ist wirklich ein bissel viel aufwand.

    gruss merl</vlan_mtu></up,broadcast,running,simplex,multicast>



  • ich haette da eine möglichkeit gefunden.

    gibt es irgendwo ein script welches nach jeder änderung aufgerufen wird wo man reinschreiben kann.

    route delete default
    route delete 192.168.23.0
    route add -net 192.168.23.0 -netmask 255.255.255.0 -interface rl1
    route add -net 0.0.0.0 -netmask 0.0.0.0 -gateway 192.168.23.8

    gruss merl



  • Du konfigurierst es einfach nur "komisch".

    Dein WAN ist statisch:
    192.168.23.?/24
    Gateway 192.168.23.8

    Zusätzlich konfigurierst Du eine Virtuelle IP vom Typ Other oder ProxyARP auf dem WAN Interface mit 212.21.69.97/32. Denke das sollte dann funktionieren.

    Alternativ, wenn Du wirklich etwas scripten willst, schau Dir mal die hidden config.xml-Optionen an: http://faq.pfsense.com/index.php?action=artikel&cat=10&id=38&artlang=en&highlight=hidden



  • also ich habe eine lösung gefunden. ist zwar etwas naja, aber es geht so prima. ich habe in die /etc/rc fast ganz unten:

    route delete default
    route delete 192.168.23.0
    route add -net 192.168.23.0 -netmask 255.255.255.0 -interface rl1
    route add -net 0.0.0.0 -netmask 0.0.0.0 -gateway 192.168.23.8

    reingesetzt, und siehe da es rennt.

    gruss merl


Locked