[РЕШЕНО] lightsquid ошибка 500



  • нет графиков, есть  500 - Internal Server Error.
    смотрм пакет squid-2.7.9

    #pkg_info squid-2.7.9 -r
    Information for squid-2.7.9:

    Depends on:
    Dependency: openssl-1.0.0_4
    Dependency: cyrus-sasl-2.1.23_1
    Dependency: perl-5.10.1_3

    пошерстив по форуму, установил p5-GD

    #pkg_add -rvf p5-GD

    смотрм пакет lightsquid-1.8_2

    #pkg_info lightsquid-1.8_2 -r
    Information for lightsquid-1.8_2:

    Depends on:
    Dependency: perl-5.10.1_3

    Смотрим возможные ошибки

    cd /usr/local/www/lightsquid/

    perl graph.cgi

    Can't load '/usr/local/lib/perl5/site_perl/5.10.1/mach/auto/GD/GD.so' for module GD: Shared object "libjpeg.so.11" not found, required by "libgd.so.4" at /usr/local/lib/perl5/5.10.1/mach/DynaLoader.pm line 200.
    at graph.cgi line 23
    Compilation failed in require at graph.cgi line 23.

    ищем libjpeg.so, но libjpeg.so.11 нету

    #find / | grep libjpeg.so.
    /usr/local/lib/libjpeg.so.9

    решено установить новый пакет jpeg, но:

    #pkg_delete jpeg*
    pkg_delete: package 'jpeg-6b_4' is required by these other packages
    and may not be deinstalled:
    bandwidthd-2.0.1_1
    graphviz-2.26.3_3
    ntop-3.3.10_7
    ntop-3.3.10_7
    p5-GD-2.44_2
    p5-GD-2.44_2
    gd-2.0.35_7,1
    p5-GD-2.44_2

    Вопрос, как правильно установить jpeg-8_3, неужели надо снести все зависимости?
    Может кто-то решил по другому?



  • Смотрим версию PFSense - конечно-же 1.2.3 . А FreeBSD под ней 7.3 .
    А сейчас текущая FreeBSD 8.1 и установка

    pkg_add -rvf p5-GD
    

    качает нам пакеты для восьмерки.
    Нужно снести все, что наставилось и юзать установку пакетов для своей версии FreeBSD.

    pkg_add -rvf ftp://ПУТЬкСВОЕЙверсииПакета/p5-GD**.tbz
    


  • @dvserg:

    Смотрим версию PFSense - конечно-же 1.2.3 . А FreeBSD под ней 7.3 .

    Извините не написал

    uname -a

    FreeBSD home.lan 8.1-RELEASE FreeBSD 8.1-RELEASE #1: Fri Sep  3 14:15:24 EDT 2010    sullrich@FreeBSD_8.0_pfSense_2.0-snaps.pfsense.org:/usr/obj.pfSense/usr/pfSensesrc/src/sys/pfSense.8  i386



  • @killeo:

    @dvserg:

    Смотрим версию PFSense - конечно-же 1.2.3 . А FreeBSD под ней 7.3 .

    Извините не написал

    uname -a

    FreeBSD home.lan 8.1-RELEASE FreeBSD 8.1-RELEASE #1: Fri Sep  3 14:15:24 EDT 2010     sullrich@FreeBSD_8.0_pfSense_2.0-snaps.pfsense.org:/usr/obj.pfSense/usr/pfSensesrc/src/sys/pfSense.8  i386

    OK.. По идее```
    pkg_delete jpeg*



  • Попробуйте просто поставить jpeg-8_3.

    Сделал

    pkg_add -rvf jpeg

    Ошибка пропала, график появился! Спасибо большое за помощь!!!
    Перестал запускаться  bandwidthd :D :D :D ??? ??? ???


Locked