PfSense not playing well with Team Fortress 2 :(



  • I grab the server list on TF2, and pfSense seems to blacklist this mac address but I still get dhcp, just no data. I disable said nic and enable the 2nd one on my mobo, I get network again. After about 10 minutes, the original nic is accepted again. Any ideas? I have everything open in my firewall for LAN and WAN, pretty much everything else is on default settings.



  • What version number of pfSense, what firewall rules?  What do you mean by "blacklist this mac address"?



  • 1.2.3 running in vmware workstation on server 2008 r2 64bit. The computer I'm playing tf2 on is also a server 2008 r2 64bit. I guess "blacklist" isn't the correct term. Basically I can get the address from the dhcp server and stuff, but that's it, pfsense won't let me get any webpages or any data from other computers. After 5 minutes or something, it gives network access again. I have the default firewall rules, one asterik in everything. Firewall:NAT:Port Forward is empty, I suspect that may be the problem. Is there a way to open up all the ports to figure out if that's the problem?



  • I don't have an answer, buy just FYI for your trail and error adventure:

    For the past few months I have played TF2 (and other steam games) through pfSense 1.2.3, flawlessly. I did not change any firewall rules. The only difference, I guess, is that I'm running pfSense on a dedicated machine.

    I've since upgraded to pfSense 2.0, and it still works.



  • I'll give a shot at it with my p3, though I'm not sure it'd make any difference as it did work a month ago. The only difference between then and now, is that I reinstalled pfsense and I'm running server 2k8r2 as my workstation OS too. Could it be that 2k8r2 does something differently with the network so that it'd work with win7 but not now?

    Edit: some more info….
    -I went to some website with a list of tf2 server IP's, I connected to a random server via the console and it worked flawlessly, 19 ping and butter smooth gameplay
    -immediately after refreshing the tf2 server list, I get a timeout and all servers say "server not responding", and no more data goes over the network. Can't even access pfsense webUI or ping anything (except myself)
    -css, alien swarm, bfbc2 and tf2 beta server browser work perfectly, which leads me to think maybe tf2 server list contains too many entries and pfSense thinks it's an attack or something



  • I doubt that the size of the server list causes pfSense to do anything, it certainly won't think it's an "attack or something", otherwise nobody would be able to download ISO images or other large files.



  • Is there anything in pfsense that would block a client from getting any data (but still gets info from dhcp server), and if there is how can I disable this feature? If I can figure that much out, it'll be a first step.



  • Not by default. Are you running a default install?



  • yea, it's a fresh vmware appliance installation. I haven't tweaked any of the settings at all, just gave it what settings it needed to work basically. I'm using Google's dns (8.8.8.8 and 8.8.4.4), bell fibe 16 with 2wire modem/router, wan on pppoe mode so it doesn't use the 2wire router, dhcp range 192.168.1.100 - 192.168.1.199 and that's basically it.



  • TF2's server browser still not working, but the beta TF2's server browser works. I just discovered that while the CSS beta's server browser works, CSS doesn't. pfSense also kicks me off when I visit canadacomputers.com, the page doesn't load.

    I heard that it could be NAT flooding or something, I have no idea what that is but could it be a possibility?



  • I really doubt it's pfSense, it is more likely to be an issue with interactions with VMWare and the underlying platform.

    Do you have a separate item of hardware you can run pfSense on to rule out issues with VMWare and Windows 2008?



  • @Cry:

    I really doubt it's pfSense, it is more likely to be an issue with interactions with VMWare and the underlying platform.

    Do you have a separate item of hardware you can run pfSense on to rule out issues with VMWare and Windows 2008?

    You sir, are a genius. And you are absolutely correct. Is there anything I can do to get the vm to work properly? In the meantime I'm going to try reinstalling vmware, hopefully won't have to reinstall 2k8r2.

    Happy new year everyone :)



  • heh, I think I got it… in the properties tab, the virtual nic had eset nod32's firewall checked and I think that was causing the problem. I reinstalled vmware while I was at it, so I can't confirm whether eset was the culprit, but I'm just glad to know that pfsense was always rock solid and this was a pebkac ;) thanks everyone, problems solved

    I only noticed that eset was enabled on the virtual nic's when I was reconfiguring the vmware virtual network editor, and I noticed it said eset was enabled right next to the name of the nic. I didn't think that installing eset would of caused this. It's probably because I modified the regular eset installer so that it'd think it was a enterprise edition so I could get it to install on 2k8r2 properly.


Locked