SquidGuard package TEST



  • 1- need to add file squidguard_log.xml into your pkg_config.xml
    

    yes - fixed

    2- squidguard binary requires  "libdb3.so.3" to run properly
    

    must installed with squidGuard automaticly

    3 - if you want a tester ... i can do it 
    

    i will glad if you test this

    All changes will updated in near time (I posting this)
    Also will corrected some bugs



  • other little issues…
    change the name in pfsense services menu to other different of "proxy Server"  because is confusing to newbies.

    add new acl times is not working ?  i cant add time ranges

    apply new changes can be equal the pfsense add rule , it's too easy forgot to click that apply button in genreal settings tab.

    just a tought ... have the squid package installed together, with customized squid.conf and unified menus, look at squid config panels in pfsense has an options to acl, to blacklists, and an customized instalation can be more easy to maintain .



  • http://diskatel.narod.ru/squidguard/squidguard.zip  is not working .. was removed ? the site was in russian .. i cant understand …



  • @dhipo:

    http://diskatel.narod.ru/squidguard/squidguard.zip  is not working .. was removed ?

    Click on "save target as" does work however.



  • it's not working … i use wget .... and error 404 is file not found ....
    lucky!!



  • Hi all
    Sorry, now i can't update sources.
    Plz waite 1-2 day's -  i will repair this.
    Thanks



  • Yeah, you seem right. Sorry!
    I can DL the file but the zip archive is corrupt.

    Well, it just DLs the HTML page and saves it as the archive. Sorry for the confusion here!



  • This worked
    (1) http://diskatel.narod.ru/pfSense/packages/pkg_config.xml
    (2) http://diskatel.narod.ru/pfSense/packages/squidGuard-1.2.0_1.tbz
    but squidGuard-1.2.0_1.tbz need correct  - i tomorrow update
    Also you can prepare squidGuard-1.2.0_1.tbz file too - need unpack, remove squid from 'expected packages' list and pack to back.
    If take standart port from FreeBSD - this install latest version squid and system will have 2 squid versions (very bad  >:()
    Sorry

    ps You may need update only you local pkg_config.xml form  (1) source and all other's will downloaded and installed  automaticly.



  • When you are ready please send all of the needed bits to coreteam@pfsense.com and we will integrate this package into our master package area.



  • @sullrich:

    When you are ready please send all of the needed bits to coreteam@pfsense.com and we will integrate this package into our master package area.

    OK
    Now i catch bugs gui and fix specificity work SG.



  • Updated new _http://diskatel.narod.ru/pfSense/packages/squidGuard-1.2.0_1.tbz
    Now this package not need squid on installation (i remove this settings from this port)
    May be possible uninstall/reinstall squid without deinstallation squidGuard.
    –-----------------------------
    Updated new version sources files. I rebuild core gui for faster work.
    Plz anybody test new installation too.

    1\. Need install local xml-rpc. How - pls looking for this topic
    http://forum.pfsense.org/index.php/topic,312.0.html
    2\. Download pkg_config.xml for this package from
    http://diskatel.narod.ru/pfSense/packages/pkg_config.xml
    and put them to you xml-rpc. If all placed correct - in package list you looking one package -squidGuard
    3\. Install this package.
    


  • Found problems first installation

    • config not autocreate
    • blacklist not scanned&updated

    For fix - need in gui install (upload) blacklist and Apply changes
    PS i near time fix this problems for auto update on first installation



  • Ok
    Ready for test  ;)



  • i'm testing now …. instalations sounds good .. upload blacklist good.... interface good... some tip .... change the name on pfsense menu to other different of proxy server... hummm may be content filtering ….

    i still testing ....



  • when configuration was done on filter , the line of redirector appears on squid … right .. .good ...
    but the contents of  /usr/local/etc/squidGuard/squidGuard.conf are same on all situations ... no changes were made on file .... every time is look like this :

    more /usr/local/etc/squidGuard/squidGuard.conf

    ============================================================

    SquidGuard configuration file

    This file generated automaticly with SquidGuard configurator

    (C)2006 Serg Dvoriancev

    email: dv_serg@mail.ru

    ============================================================

    logdir /var/squidGuard/log
    dbhome /var/db/squidGuard

    acl {
            default {
                    pass none
                    redirect http://127.0.0.1/sgerror.php
            }
    }



  • i find the error ,
    when you define an time in acl , default or other acls , the config shows only that above squidguard.conf, if no time is used in acl ,,, evething is fine ,,



  • other typos

    when click save on squid properties, this remove the line of redirector on squid.conf, and the filter stops working …

    if you click the button start of squidguard in "Status > Services " menu , this hangs squid an stop then all.



  • Notation: If exists error in configuration data, Configurator maked small default config with DenyAll access. All error's posts in log on the firts page webGUI.
    This is default block config.

    # ============================================================
    # SquidGuard configuration file
    #
    # This file generated automaticly with SquidGuard configurator
    #
    # (C)2006 Serg Dvoriancev
    # email: dv_serg@mail.ru
    # ============================================================
    
    logdir /var/squidGuard/log
    dbhome /var/db/squidGuard
    
    acl {
             default {
                     pass none
                     redirect http://127.0.0.1/sgerror.php
             }
    }
    
    

    If You have this config - pleace looking Log on first page squidGuard gui (checkbox must be checked). Latest errors added when Apply button pressed

    ps I planing add 'ERROR config DATA' notification on first page .Thanks for you test - i will analyze bugs
    –---------------------------------
    BagBeer - beer for real programmer's



  • when click save on squid properties, this remove the line of redirector on squid.conf, and the filter stops working ...
    

    i know this problem, but temporary no see way to solve(only hack squid GUI src :( ).
    Now after change squid config need press Apply button in squidGuard gui. This renew all config's.

    if you click the button start of squidguard in "Status > Services " menu , this hangs squid an stop then all.
    

    OK, thanks



  • just an idea …. why don't you install squid togheter with squidguard, an proxy complete solution with filtering, and people can decide if they want only a proxy , they use squid or if want content filtreing proxy they will use your package ...

    i am running on a new trouble ....

    the message says

    The url_rewriter helpers are crashing too rapidly, need help!

    and squid crash ...

    and idea ?



  • Need Log list, SG config and more information about
    (log - from 1 page SG gui)

    PS How you name of package 'Proxy Content filter'?
    Word 'proxy' must exists in name, what makes it easy to understand



  • ok … NAME .. Proxy Content Filter .. great..

    the error on squid were because package db3 was missing ..... an pkg_add -r db3 solves all ...

    now in production ...



  • but …. ACLs with Times .... causes configuration error .. i try several ways .. with no success.

    look the log

    09.05.2007 11:39:09: sg_build_config: create squidGuard config
    09.05.2007 11:39:09: sg_build_config: check configuration data
    09.05.2007 11:39:09: sg_build_config: error configuration data. It's all errors:
    ACL 'default' error: overtime destination name '[' not found
    09.05.2007 11:39:09: sg_build_config: terminated.
    09.05.2007 11:39:09: sg_build_default_config: Created default configuration. All content will blocked.
    09.05.2007 11:39:09: sg_reconfigure: generate squidGuard config and save to /usr/local/etc/squidGuard/squidGuard.conf.



  • OK Big thanks I found problem source, but update only in evning or tomorrow



  • DVSerg ..what time is it you on UTC ?? i amin Brazil -3 UTC … and you?



  • @dhipo:

    DVSerg ..what time is it you on UTC ?? i amin Brazil -3 UTC … and you?

    Now i have 16:05 09-05-2007  ;D

    You can change self File /usr/local/pkgsquidGuard.inc
    need add line

     $sgx[FLD_OVERDESTINATIONNAME] = trim( str_replace('[', '', $sgx[FLD_OVERDESTINATIONNAME]) );
    

    LOOK this
    Line 1120 must be

                    } else {
                        $sgx[FLD_DESTINATIONNAME]     = trim( substr($pfx['dest'], 0, strpos($pfx['dest'], '[')) );
                        $sgx[FLD_OVERDESTINATIONNAME] = trim( strstr($pfx['dest'], '[') );
                        $sgx[FLD_OVERDESTINATIONNAME] = trim( str_replace(']', '', $sgx[FLD_OVERDESTINATIONNAME]) );
                        $sgx[FLD_OVERDESTINATIONNAME] = trim( str_replace('[', '', $sgx[FLD_OVERDESTINATIONNAME]) ); // add this
                    }
    

    and line 1159-1165

            } else {
                $sgx[FLD_DESTINATIONNAME]     = trim( substr($pfx['dest'], 0, strpos($pfx['dest'], '[')) );
                $sgx[FLD_OVERDESTINATIONNAME] = trim( strstr($pfx['dest'], '[') );
                $sgx[FLD_OVERDESTINATIONNAME] = trim( str_replace(']', '', $sgx[FLD_OVERDESTINATIONNAME]) );
                $sgx[FLD_OVERDESTINATIONNAME] = trim( str_replace('[', '', $sgx[FLD_OVERDESTINATIONNAME]) ); // add this
            }
    


  • other suggestion

    in destinations tab

    domains , expressions and/or urls can be separeted always with a new line…

    like this

    anydomian.com
    xyz.ccom
    zzz.com
    and so on

    same to urls or expressions

    sexy
    pussy
    etc

    it's make more sense to use other imported lists



  • I did not get a correct list of the transfer line from HTML form
    I set 'space' as separator from the need
    In expressions use '|' as separator by default in squidGuard db files
    Expressions may contains any other RegularExpression string  ;)

    'sex|porno' - mean as expression 'sex OR porno'

    ps I explore this problem once more.. but the first need test all other bugs



  • new thing … is a must have thing ..... the log of squid access.log ... to the admins look and insert new blocked content



  • other little bug

    redirect field in destinations …. is no accepting any inputs ...



  • new thing ... is a must have thing ..... the log of squid access.log ... to the admins look and insert new blocked content 
    ```Aaa .. my translator can't eat this  ;D More information plz.
    
    

    i find the error ,
    when you define an time in acl , default or other acls , the config shows only that above squidguard.conf, if no time is used in acl ,,, evething is fine ,,

    It's not a bug - it's gui future. This field take all you ACL settings and store to config.xml


  • sorry ….  a new feature to add .... in the log TAB ... we can view squid logs  aka ... /var/squid/log/access.log.... then admins can look who is looking for new forbbiden content and include in customized lists



  • @dhipo:

    sorry ….  a new feature to add .... in the log TAB ... we can view squid logs  aka ... /var/squid/log/access.log.... then admins can look who is looking for new forbbiden content and include in customized lists

    Ok, i look this.
    But exists one package - lightsquid, and develope SARG - report's for analyze squid Logs. I use lightsquid.



  • Right now I'm getting this error in the cache.log over and over again:
    /libexec/ld-elf.so.1: Shared object "libdb3.so.3" not found, required by "(squidGuard)"

    I also am running snapshot from 5-9-2007

    *edit

    After I installed freeradius, the lib error went away, I guessed this would happen since freeradius use to be missing the same library at one point when it was broken.  I thought it was fixed but then I tried just manually starting squid and it gave this error:

    /libexec/ld-elf.so.1: Shared object "libdb3.so.3" not found, required by "squidGuard"

    Along with that my cache.log errors changed to these:
    2007/05/10 00:40:14| WARNING: url_rewriter #1 (FD 6) exited
    2007/05/10 00:40:14| WARNING: url_rewriter #2 (FD 7) exited
    2007/05/10 00:40:14| Too few url_rewriter processes are running
    FATAL: The url_rewriter helpers are crashing too rapidly, need help!

    Squid Cache (Version 2.6.STABLE5): Terminated abnormally.
    CPU Usage: 0.118 seconds = 0.081 user + 0.037 sys
    Maximum Resident Size: 7360 KB
    Page faults with physical i/o: 0

    you can confirm by using this command:
    "ldd /usr/local/bin/squidGuard"
    This is the output
    squidGuard:
            libdb3.so.3 => not found (0x0)
            libc.so.6 => /lib/libc.so.6 (0x28086000)
    it seems that this should come as part of the berkley DB

    Resolution**
    pkg_delete db3-3.3.11_3,1
    pkg_add -r db3
    cp /usr/local/lib/libdb3.so.3 /libexec/

    Make sure squid is running if it isn't save its settings, make sure it starts
    Hit apply on squidguard, you should see its status changed to started

    Possible Bugs:
    On a restart, squidGuard will decide to reinstall itself during the package resync.  This has only happened once, and I will try to figure out how to reproduce the problem



  • Berkley db BUG - installator find db3 PORT on my site too (some path what and squidGuard port archive), I add this PORT.
    Please check new installation.

    Also updated files with bugs.

    ps Who need lightsquid - reload new pkg_config.xml. I add them sources and config.



  • other suggestion
    in destinations tab
    domains , expressions and/or urls can be separeted always with a new line...
    like this 
    anydomian.com
    xyz.ccom
    zzz.com 
    and so on
    same to urls or expressions
    sexy
    pussy
    etc 
    it's make more sense to use other imported lists 
    

    I found 'enter' code. May be you idea realisabe.  :)



  • i am researching now … but install package snort ... brokens the squid, squidguard...

    on new informations i will let you know



  • do you know any mode to remove the package squidguard …. in the interface ... this stop and don't remove
    can be done on command line ?



  • look the error

    when i click on squid ..
    Fatal error: Call to undefined function: squid_before_form_general() in /usr/local/www/pkg_edit.php(86) : eval()'d code on line 1



  • listing packages
    pkg_info

    delete
    pkg_delete squidGuard-1.2.0_1


Log in to reply