Multiple devices on UPNP



  • Per reading the sticky topic and trying everything I believe my situation is different.

    My old setup which worked was, surfboard 5120 > pfssnse box > dell unmanaged 24port switch > devices.

    Now the devices are 2 computers, 2 Xboxs, a ps3.

    At the old house / old set up upnp worked great. We could Xbox together or at the same time, same with pc's.

    Now it's, sb 6120(DOCSIS 3) > pfsense > hp managed switch > Dell unmanaged > devices.

    Now the manage switch has no port settings besides monitoring and vlan, and when I take the switch out of the loop upnp still doesn't work…

    Also with the new setup came a new house (I moved) and now I have lan's. Funny thing is 1.2.3 which I've been running with old setup for a year now won't work anymore but 2.0 beta 5 works great, sometimes now. If I disable/enable and have everyone connect / do a Xbox live test all xboxes will upnp and find there own ports and all the pc's will properly join games together without lag and ask upnp for ports.

    Now what pisses me off is, after awhile when the xbox's queue for a lobby(black ops / halo) the pc's wi randomly lag till the Xbox makes a connection(joins a game). Other then this everything runs smooth for the time being.

    Now after the LAN is over, we are at a new day I'll go to game, PC's are working perfect and Xboxs are not strict.

    Following the sticky topic if I deny upnp for anything but the Xboxs and set up a rule, PC's can't join the same server from inside the LAN. Now if I also change NAT type to manual and do the static port mess and what not, Xboxs work perfect all the time no NAT type change but again pc's now won't connect. As far as pc games are going we play cod4/bc2 and v/CSS/l4d2.

    The bc2 issue was clientport even when pc's worked but I had everyone clientport themselves and glad worked flawless. We had 6 people inside the LAN join a server and game for hours without issues.

    Anyway hoping you guys can help. I'm on my phone(so bare with me please) and VERY frustrated with all this so I thought I might as well just ask you guys since you guys can helps more then anyone right now.



  • Sorry to hear your frustration.  The best thing to do is to attack each issue and keep trying.

    Try to turn off UPnP for testing.  Just keep the outbound NAT to manual and static port forwards in place.

    Can you post your config in each section (NAT - Port Forward and Outbound, UPnP, Rules)?



  • Totally forgot about this thread lol. Sorry.

    My config is all default all the way through. I turned off UPNP and set outbound nat and static ports.

    This means PC's are UPNP'd and the xboxs arent.

    Both xbox's are upnp'd but ps3 is NAT Type 3.

    Someone please helppppppp

    EDIT: Also forgot to add, that just turns the nat type into moderate, I need to still port forward, problem is when i have 2+ xbox's its gonna be hard to port forward and I have frequent LANs at my house.



  • I posted on the sticky thread about UPnP.



  • I just viewed it.

    I did try those settings, but they only work for 1 xbox.

    Im talking about multiple xbox's. Ive tried adding port forwards for the 2nd and on xbox and nothing works.

    The one who's ip is entered manually into the UPNP works perfect all the time, but in this case, mine works great but my brothers doesnt get open.

    So how do we conquer multiple xbox's?


Locked