Get a 403 Forbidden Error on just a certian page only [SOLVED]



  • Hello,

    Not sure why but getting an 403 Forbidden Error on only 1 page, not sure why. I've even added the domain to the whitelist is squid. Domain is momapop.com (wife is going to it, I know it works, tried from 3g phone and is fine)

    Any ideas where to start looking?

    Error:
    You don't have permission to access / on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at mamapop.com Port 80

    Thanks for the help,
    Jake


  • Rebel Alliance Developer Netgate

    That error is coming from the remote server, not squid. There isn't anything squid could do to forbid you access on the remote server to / there. Everything in that error is talking about the web site you're trying to access.

    Looks like "mamapop.com" just redirects to "www.mamapop.com" - what happens if you access it with the www? If that works, there may just be something odd with how they redirect from one site to another.



  • I've tried doing www.mamapop.com and still get the same error. I've also tried going to the IP of the site and get the image that i have in the Redirect info section under squidguard and then under the default tab.

    I've tried this on other internet connections and the site works fine, just not behind the pfsense firewall.

    Anything else that I can try?

    Thanks for the help.



  • That doesn't change the fact that the error is from the mampop.com server. It may be that they're refusing access to those behind proxies, or there may be some other reason, but the error is still nothing you can fix.



  • ahh, ok.

    im sure there is no way to bypass the proxy for certian sites?


  • Rebel Alliance Developer Netgate

    you can bypass by IP in the squid GUI, sure.



  • Awesome, that worked. Thanks guys.


Locked