Lightsquid error



  • I was just letting the developers know that when you have lightsquid installed, when booting there is an error.
    Warning: strpos(): Empty delimiter in /usr/local/pkg/lightsquid.inc on line 327



  • Hello,

    I have the same problem when i want to install PfSense in a new PC configuration.

    What can we do to resolve this problem ?

    Best regards.



  • 1. Refresh now
    2. Refresh full
    3. Lightsquid Report
    4. Press F5
    5. Ready



  • The above doesn't get rid of the error.  I have the lightsquid refresh every hour and the data is always updated correctly. There is no stale data, at least I am not aware of any.
    I am hoping its just a simple error with the code since they updated the package not that long ago.



  • Must be fixed.

    lightsquid.inc.txt



  • Lightsquid is upgraded to 1.7.1 pkg v.1.2

    Now i cannot record any user logs in lightsquid.

    Where should i look for errors ???

    I'm so confused on making it work.

    Don't want to mess up something wrong.

    I had the same error mentioned above, now its gone but i cannot see any reports.

    Can anyone help me with re-installing it properly please.

    Thanks.



  • @ashrocks:

    Lightsquid is upgraded to 1.7.1 pkg v.1.2

    Now i cannot record any user logs in lightsquid.

    Where should i look for errors ???

    I'm so confused on making it work.

    Don't want to mess up something wrong.

    I had the same error mentioned above, now its gone but i cannot see any reports.

    Can anyone help me with re-installing it properly please.

    Thanks.

    Hm.. Reinstall LS XML from packages.



  • I'm a complete Newbie for Lightsquid application.

    Can you provide me with some steps or resources to look into on installing LS XML from packages.

    I followed the link for squid guard but that didn't help :(

    Thanks.



  • @ashrocks:

    I'm a complete Newbie for Lightsquid application.

    Can you provide me with some steps or resources to look into on installing LS XML from packages.

    I followed the link for squid guard but that didn't help :(

    Thanks.

    System > Packages > Installed -> 'XML' button  near 'Lightsquid package' line.



  • Hi,

    I followed your instructions.
    Re-installed, and went back to the proxy filter page, did a refresh now, refresh full, hit F5 and then on the Lightsquid report page, it does not show anything.

    Does it take some time to start reporting the URLs visited by the IP's.



  • Got one quick question.

    Do i have to enable blacklist in Squidguard in order to let squidguard report to LS.

    If so, what should be in my blacklist URL ???



  • I have got a problem with lightsquid and log rotation.

    In squid I enterd log rotate 2 and in /var/squid/log/ there are access.log and access.log.0
    This seems to be fine.

    In the past I had the problem, that lightsquid creats reports of every day and though I used log rotate 2 it didn't delete any reports older than two days. Therefore I did a cron job which deletes everything in the /var/lightsquid/reports/ folder every hour.
    If I am not misunderstanding the "refresh full" button, it should me refresh ALL log files - in my case the 2 logfiles for two days. But it didn't work, it only shows me the actual day.

    I'm using:
    2.0-BETA5 (i386) built on Tue Jan 11 14:19:18 EST 2011
    cron 0.1.5
    Lightsquid 1.8.0 pkg v.1.2
    squid 2.7.9_4

    Thanks for your help.



  • Can one of the admins please commit the change to the lightsquid package?



  • @LostInIgnorance:

    Can one of the admins please commit the change to the lightsquid package?

    I'll do it at the weekend.



  • Updated.



  • Is this fixed on 2.0-BETA5 (i386) built on Sun Jan 16 22:00:36 EST 2011 ?

    I got:

    "17.01.2011 08:18:51";"172.17.0.1";"LOG ALERT";"KERNEL: ";"INFORMATIONAL MESSAGE";"PARSE ERROR: SYNTAX ERROR, UNEXPECTED '{' IN /USR/LOCAL/PKG/LIGHTSQUID.INC ON LINE 327"
    

    If I try to reinstall, it hangs on:

    Removing Lightsquid components...
    Tabs items... done.
    Menu items... done.
    Loading package instructions...
    


  • Probably syntax error.
    Don't update upto next fixing.
    –-
    Fixed.



  • Hi,

    could not de- or reinstall lightsquid package:

    Removing package...
    Starting package deletion for lightsquid-1.8_2...done.
    Skipping package deletion for perl-5.10.1_3 because it is a dependency.
    Removing Lightsquid components...
    Tabs items... done.
    Menu items... done.
    Loading package instructions...
    

    How could I fix this on my pfsense?

    2.0-BETA5 (i386) built on Tue Jan 18 03:34:33 EST 2011

    Thanks



    1. Delete package from GUI as is.
    2. From console pkg_info / pkg_delete any Lightsquid package
    3. Install from GUI new.


  • I could not delete it from the GUI.
    pkg_info shows me this:

    bsdinstaller-2.0.2010.1110 BSD Installer mega-package
    cyrus-sasl-2.1.23_1 RFC 2222 SASL (Simple Authentication and Security Layer)
    gettext-0.18_1      GNU gettext package
    grub-0.97_3         GRand Unified Bootloader
    jpeg-8_3            IJG's jpeg compression utilities
    libiconv-1.13.1_1   A character set conversion library
    libwww-5.4.0_4      The W3C Reference Library
    openldap-sasl-client-2.4.23 Open source LDAP client implementation with SASL2 support
    openssl-1.0.0_4     SSL and crypto library
    perl-5.10.1_3       Practical Extraction and Report Language
    squid-2.7.9         HTTP Caching Proxy
    squid_radius_auth-1.10 RADIUS authenticator for squid proxy 2.5 and later
    
    


  • @dvserg:

    1. Delete package from GUI as is.
    2. From console pkg_info / pkg_delete any Lightsquid package
    3. Install from GUI new.

    My router helped.



  • Nachtfalke
    Email me - i send to you fixed files.


Locked