RUTA ESTATICA NO FUNCIONA



  • Que tal, estoy configurando un servidor pfsense con openvpn, tengo unas rutas estaticas para dirigir el trafico de internet hacia la vpn para que navege por mis oficinas remotas, la cuestion es que cuando pongo la siguiente ruta 0.0.0.0/1 10.245.0.1 esta ultima es la vpn, solo me deja navegar en las paginas que empiezan con direcciones ip antes de 128 por ejemplo google  74.6.146.30 pero cuando intento accesar a una de mas de 128 por ejemplo esmas.com  187.141.2.120 no me deja, lo que pienso es que es necesario establecer la ruta de 0.0.0.0/0 en lugar de 0.0.0.0/1 pero no se como hacerlo de manera manual en pfsense pudiera alguien darme una mano, Ojala me puedan ayudar es super urgente

    Gracias



  • ¿Y no puedes poner varias?

    Lo digo porque no conviene que pongas todos los rangos, ya que hay direcciones que son privadas y otras que no existen (bogon networks).

    http://es.wikipedia.org/wiki/Red_privada

    http://www.gossamer-threads.com/lists/nsp/bogon/21026



  • la verdad no se como hacerlo, es decir en la ruta siguiente LAN–->0.0.0.0/1 10.245.0.1 le estoy forzando a que todo lo que no conozca, osea internet lo mande por la 10.245.0.1 y de esa manera obligo a que se vayan por la vpn todos mis clientes, perdona bellera no entiendo muy bien lo que me quisiste comentar, ojala me puedas ayudar porque es un proyecto importantisimo para mi institucion.



  • Poner varias rutas, no sólo una.

    ¿Dónde configuraste la ruta?



  • la puse en statics routes de pfsense
    LAN 0.0.0.0/1 10.245.0.1



  • si esto funcionara bellera seria una solucion para muchos porque con esto puedes pasar de manera transparante sin nat tus clientes de sitios remotos y los podrias filtrar sin perder sus ip originales de sus redes locales remotas con ello me permite obtener estadisticas por ip de que paginas visitan mis usuarios y ademas bloquearles por ip a unos el messenger y aotros no, usamos websense en oficinas centrales

    saludos. y ojala me eches la mano porque la verdad es muy bueno el pfsense y esta es la ultima parte de mi configuracion espero :)  :P



  • cuando pongo la ip de esmas.com y le digo que  para alcanzar esa ip se tiene quie ir por la vpn si lo alcanza



  • En la página 329 del libro de pfSense se explica cómo cambiar "de un plumazo" la puerta por defecto de los clientes OpenVPN.

    Quita la ruta estática que pusistes y añade en el lado [server] de OpenVPN la [custom option]:

    redirect-gateway def1
    (def y número 1, no la letra L minúscula)

    Buscando en Google openvpn redirect-gateway encontré:

    http://manoftoday.wordpress.com/2006/12/03/openvpn-20-howto/

    http://openvpn.net/index.php/open-source/documentation/howto.html

    No hace falta push si en [custom options] no tienes nada más:

    http://www.bellera.cat/josep/pfsense/imatges/openvpn_server_edit_3.gif

    Ya dirás si te funcionó.



  • Muchas gracias, he logrado que el trafico salga por la vpn, muchas gracias bellera, te agradesco el tiempo y el que me hayaas contestado todas mis preguntas, la opcion de redirect-gateway def1 me funciono, solo estaba poniendo comillas y push por eso no funcionaba.
    Saludos.


Locked