Traffic Shaper Wizard



  • I am using the single WAN Multi LAN wizard and am running into an issue.

    I get this error 'Upload bandwidth of connection 0 is not valid.'

    This is the Jan31 i386 snapshot.  did the same on Jan29.

    I have a 6/6 WAN and 2 VLANs (one for VoIP the other for LAN), Default LAN interface is disabled (same behavior even when enabled).

    The error occurs on the second page of the wizard when I check Priotize VoIP traffic.  I want to allocate about 800k up and down and I have even tried using a percentage.  This error occurs after  when I click next to move to the next page.

    Any ideas?



  • Maybe screenshots will help

    ![Capture2-1-2011-6.00.11 AM.png](/public/imported_attachments/1/Capture2-1-2011-6.00.11 AM.png)
    ![Capture2-1-2011-6.00.11 AM.png_thumb](/public/imported_attachments/1/Capture2-1-2011-6.00.11 AM.png_thumb)
    ![Capture2-1-2011-6.00.43 AM.png](/public/imported_attachments/1/Capture2-1-2011-6.00.43 AM.png)
    ![Capture2-1-2011-6.00.43 AM.png_thumb](/public/imported_attachments/1/Capture2-1-2011-6.00.43 AM.png_thumb)
    ![Capture2-1-2011-6.01.38 AM.png](/public/imported_attachments/1/Capture2-1-2011-6.01.38 AM.png)
    ![Capture2-1-2011-6.01.38 AM.png_thumb](/public/imported_attachments/1/Capture2-1-2011-6.01.38 AM.png_thumb)



  • Same thing here.  It worked fine once (first time since Beta 4).  then I was getting nothing into the qVOIP queue (during VOIP).  So, I tried Single-WAN-Multi-LAN and wizard and that had some other problem.  So, I went back and ran Single-LAN-Mutli-WAN again and got caught in this "30%" loop.  One thing I did NOT do on the 2nd time through Single-LAN-Mutli-WAN was activate the catchall-2-P2P check box (not sure if that affects anything that triggers the "30%" deal).  I am running 'Version 2.0-BETA5 (i386) built on Fri Jan 28 04:47:10 EST 2011' FWIW.



  • It has also worked for me in the past.  Haven't need to use it in a while though.  If I try the Multi-Multi I get

    You cannot set the VoIP download bandwidth on connection 1 higher than 80% of the connection.

    Last time I checked 800k of 6,000k is not 80%



  • Same problem on this version:

    2.0-BETA5  (i386)
    built on Sun Feb 6 07:21:52 EST 2011

    Any hope of getting this fixed?



  • So, I commented out the following lines in traffic_shaper_wizard_multi_lan.inc, and got it working…

    //if (!is_numeric($_POST["connupload"])) {
                    //      $savemsg = gettext("Upload bandwidth of connection {$i} is not valid.");
                    //      $stepid–;
                    //      return;
                    //}

    I'm not sure why connupload is not returning a numeric. Commenting out the check allows it to work. Just checked the queues and all is well.

    Ermal - Any thoughts?



  • I been having this problem also.
    On snap
    2.0-BETA5 (i386)
    built on Wed Feb 9 01:34:47 EST 2011

    Everything was fine with some older snaps

    Thanks!



  • Fixed. Thank you for reporting.



  • Hi ermal,

    after updating today to snap

    2.0-BETA5 (i386)
    built on Thu Feb 10 22:00:00 EST 2011

    still get the error using the wizzard for Single Wan multi Lan:  Upload bandwidth of connection 0 is not valid.  ???

    Bye,
    Alex



  • it´s me again,
    with the update to 2.0 RC1 (2011/02/14) the wizzard works again, sorry for my impatience

    Bye,
    Alex



  • I saw this same error when I used the multi wan multi lan wizard…. But No error when I went through the Multi Lan single wan wizard.

    This is on the latest build that I updated last night.

    Edit: I take that back, I see this error unless I specify a % instead of trying to specify a specific speed amount.



  • I get this error on the latest updated RC3:

    "You cannot set the VoIP upload bandwidth on connection 0 higher than 80% of the connection."

    What is the fix for this? I am trying Single-WAN-Multi-LAN

    Thanks,



  • Altq does not allow setting realtime above 80%.  Just the way it is, i imagine because it could so easily starve everything else.  Don't worry it can still use the other 20%, it just will have to share it with other queues.



  • I am not sure anyone on the Bug Tracker or on the forum gets this. There is an issue with this. THIS IS A BUG. No matter I set 5% or 90% of the bandwidth the page won't move and it will show the 80% limit and just stop there. This is a problem not the mere mention that less than 80% should be used.



  • i get the same issue on the wizard.



  • i have the most recent release and i get the same thing.



  • I get the same thing on this build:
    2.0-RC3 (i386)
    built on Fri Jul 8 06:31:45 EDT 2011

    but when I changed from Kbit to % I got it to work. Then at the end I get a message about custom queues being more than 30% but none of them are. I'm not sure what to make of that one yet.

    I may try to update to the latest build but seeing this morning that scourtney2000 has the same thing I'm not too confident for it to work. Has anyone posted an official bug report for this yet?



  • Can you post screenshots pleasE?



  • Sorry Ermal. I've been too busy to try this again and I won't have a chance again until next week. I will try to get screenshots though.



  • I agree it is a problem, please comment on this tracker item in Redmine:

    http://redmine.pfsense.org/issues/1728



  • Hi all,

    I has tried with built on Fri Jul 29 14:40:48 EDT 2011 all working perfect, let all tries….  :)



  • @focalguy:

    Sorry Ermal. I've been too busy to try this again and I won't have a chance again until next week. I will try to get screenshots though.

    Okay, I tried again today with total bandwidth being 1.3Mb/sec and choosing 320Kb/sec for VoIP. I get around this by choosing 25% instead of 320Kb/sec. This is on a T1  with 1.5Mb/sec actual bandwidth.






  • Fixed. Please next time you can be more clear and saying you are using the multi lan wizard!



  • Thank you! I will try updating tomorrow and running the wizard again.

    Sorry for not specifying which wizard I was using.



  • On build:
    2.0-RC3 (i386)
    built on Wed Aug 3 02:34:00 EDT 2011

    I no longer get the error when specifying the VoIP queue bandwidth using kbps.

    Thank you



  • @focalguy:

    On build:
    2.0-RC3 (i386)
    built on Wed Aug 3 02:34:00 EDT 2011

    I no longer get the error when specifying the VoIP queue bandwidth using kbps.

    Thank you

    I think I reported this.

    What I find is I have to state the bandwith in MB and the voip shaping in MB also. Instead of using 512kbps for voip shaping I have to say .512 Mb.



  • What happens if you don't do that? Does the wizard let you continue? Does the queuing work?


Locked