After cvs_sync.sh, no access to webgui



  • Pfsense 1.0.1 Updated (full install on HD).

    After launching:

    "fetch -q -o - http://www.pfsense.com/~sullrich/tools/cvs_sync.sh | sh"

    and got:

    Setting CVS_IP to cvs.pfsense.com
    Cannot find cvsup, pkg_add in progress
    Cannot find cvs, fetching static cvs…
    [..]

    Rebooted at the end of the procedure. The firewall seems to work fine, but - when trying to access the
    webgui, I get:

    Warning: main(includes/functions.inc.php): failed to open stream: No such file or directory in /usr/local/www/index.php on line 40 Fatal error: main(): Failed opening required 'includes/functions.inc.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /usr/local/www/index.php on line 40

    Please, help.

    /gbosco

    P.s. I have not physical access to the device - so I cannot proceed with reinstallation.



  • You only should run that command when instructed.

    Afraid a reinstall is in order.  Please DO NOT run that command unless someone tells you to in the future.  It is NOT a general user update mechanism.  It is a troubleshooting update mechanism used by the devs.



  • I´m one of those experiencing problems retaining IP through dhclient.

    http://forum.pfsense.org/index.php?topic=2645.0

    the cvs_sync was suggested as a solution for the problem.

    However, I´m aware of the dangers related to CVS sync, so I´m not blaming anyone.

    Since I have SSH access to the device, could it help relaunching a cvs sync from shell?

    My impression is that - the process has been interrupted before it was finished.

    /gbosco



  • Yes it was interrupted before it was finished.  But keep in mind, I have not instructed you to run this command again.  You can try running the command again but I am not sure what will happen.



  • For future reference.

    It worked.

    thx

    /gbosco


Locked